PDA

View Full Version : [SOLVED] Problem installing nvidia driver



KasumiNinja
5th January 2013, 03:23 PM
I can't get the nvidia drivers in Fedora 18 installed. Nouveau is disabled. I think the problem is that there isn't a driver for the latest kernel in rpmfusion. Anyone else has problems installing the nvidia drivers? Is there a solution?


# yum install kmod-nvidia

Loaded plugins: langpacks, presto, refresh-packagekit, remove-with-leaves
Resolving Dependencies
--> Running transaction check
---> Package kmod-nvidia.x86_64 1:304.64-1.fc18.2 will be installed
--> Processing Dependency: kmod-nvidia-3.6.7-5.fc18.x86_64 >= 1:304.64-1.fc18.2 for package: 1:kmod-nvidia-304.64-1.fc18.2.x86_64
--> Running transaction check
---> Package kmod-nvidia-3.6.7-5.fc18.x86_64.x86_64 1:304.64-1.fc18.2 will be installed
--> Processing Dependency: kernel-uname-r = 3.6.7-5.fc18.x86_64 for package: 1:kmod-nvidia-3.6.7-5.fc18.x86_64-304.64-1.fc18.2.x86_64
--> Processing Dependency: nvidia-kmod-common >= 1:304.64 for package: 1:kmod-nvidia-3.6.7-5.fc18.x86_64-304.64-1.fc18.2.x86_64
--> Running transaction check
---> Package kmod-nvidia-3.6.7-5.fc18.x86_64.x86_64 1:304.64-1.fc18.2 will be installed
--> Processing Dependency: kernel-uname-r = 3.6.7-5.fc18.x86_64 for package: 1:kmod-nvidia-3.6.7-5.fc18.x86_64-304.64-1.fc18.2.x86_64
---> Package xorg-x11-drv-nvidia.x86_64 1:304.64-3.fc18 will be installed
--> Processing Dependency: xorg-x11-drv-nvidia-libs(x86-64) = 1:304.64-3.fc18 for package: 1:xorg-x11-drv-nvidia-304.64-3.fc18.x86_64
--> Running transaction check
---> Package kmod-nvidia-3.6.7-5.fc18.x86_64.x86_64 1:304.64-1.fc18.2 will be installed
--> Processing Dependency: kernel-uname-r = 3.6.7-5.fc18.x86_64 for package: 1:kmod-nvidia-3.6.7-5.fc18.x86_64-304.64-1.fc18.2.x86_64
---> Package xorg-x11-drv-nvidia-libs.x86_64 1:304.64-3.fc18 will be installed
--> Finished Dependency Resolution
Error: Package: 1:kmod-nvidia-3.6.7-5.fc18.x86_64-304.64-1.fc18.2.x86_64 (rpmfusion-nonfree)
Requires: kernel-uname-r = 3.6.7-5.fc18.x86_64
Installed: kernel-3.6.10-2.fc17.x86_64 (@updates/17)
kernel-uname-r = 3.6.10-2.fc17.x86_64
Installed: kernel-3.6.10-4.fc18.x86_64 (@fedora)
kernel-uname-r = 3.6.10-4.fc18.x86_64
Available: kernel-debug-3.6.10-4.fc18.x86_64 (fedora)
kernel-uname-r = 3.6.10-4.fc18.x86_64.debug
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


# yum --enablerepo=updates-testing install kmod-nvidia

Loaded plugins: langpacks, presto, refresh-packagekit, remove-with-leaves
Resolving Dependencies
--> Running transaction check
---> Package kmod-nvidia.x86_64 1:304.64-1.fc18.2 will be installed
--> Processing Dependency: kmod-nvidia-3.6.7-5.fc18.x86_64 >= 1:304.64-1.fc18.2 for package: 1:kmod-nvidia-304.64-1.fc18.2.x86_64
--> Running transaction check
---> Package kmod-nvidia-3.6.7-5.fc18.x86_64.x86_64 1:304.64-1.fc18.2 will be installed
--> Processing Dependency: kernel-uname-r = 3.6.7-5.fc18.x86_64 for package: 1:kmod-nvidia-3.6.7-5.fc18.x86_64-304.64-1.fc18.2.x86_64
--> Processing Dependency: nvidia-kmod-common >= 1:304.64 for package: 1:kmod-nvidia-3.6.7-5.fc18.x86_64-304.64-1.fc18.2.x86_64
--> Running transaction check
---> Package kmod-nvidia-3.6.7-5.fc18.x86_64.x86_64 1:304.64-1.fc18.2 will be installed
--> Processing Dependency: kernel-uname-r = 3.6.7-5.fc18.x86_64 for package: 1:kmod-nvidia-3.6.7-5.fc18.x86_64-304.64-1.fc18.2.x86_64
---> Package xorg-x11-drv-nvidia.x86_64 1:304.64-3.fc18 will be installed
--> Processing Dependency: xorg-x11-drv-nvidia-libs(x86-64) = 1:304.64-3.fc18 for package: 1:xorg-x11-drv-nvidia-304.64-3.fc18.x86_64
--> Running transaction check
---> Package kmod-nvidia-3.6.7-5.fc18.x86_64.x86_64 1:304.64-1.fc18.2 will be installed
--> Processing Dependency: kernel-uname-r = 3.6.7-5.fc18.x86_64 for package: 1:kmod-nvidia-3.6.7-5.fc18.x86_64-304.64-1.fc18.2.x86_64
---> Package xorg-x11-drv-nvidia-libs.x86_64 1:304.64-3.fc18 will be installed
--> Finished Dependency Resolution
Error: Package: 1:kmod-nvidia-3.6.7-5.fc18.x86_64-304.64-1.fc18.2.x86_64 (rpmfusion-nonfree)
Requires: kernel-uname-r = 3.6.7-5.fc18.x86_64
Installed: kernel-3.6.10-2.fc17.x86_64 (@updates/17)
kernel-uname-r = 3.6.10-2.fc17.x86_64
Installed: kernel-3.6.10-4.fc18.x86_64 (@fedora)
kernel-uname-r = 3.6.10-4.fc18.x86_64
Available: kernel-3.6.11-3.fc18.x86_64 (updates-testing)
kernel-uname-r = 3.6.11-3.fc18.x86_64
Available: kernel-debug-3.6.10-4.fc18.x86_64 (fedora)
kernel-uname-r = 3.6.10-4.fc18.x86_64.debug
Available: kernel-debug-3.6.11-3.fc18.x86_64 (updates-testing)
kernel-uname-r = 3.6.11-3.fc18.x86_64.debug
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

hmaarrfk
5th January 2013, 05:03 PM
yea.... that happens (at least with the kmod VirtualBox -- don't have a NVidia card anymore)

you just have to wait until the RPM fusion team makes an rpm for it. They don't have to do much so it only takes 1-2 days (maybe 3)

it is weird that the kernel version is so far behind. Maybe the RPM fusion doesn't care so much since Fedora 18 is not release yet.

I noticed you have kernel 3.6.10.2, so you can try downloading
http://download1.rpmfusion.org/nonfree/fedora/updates/17/x86_64/repoview/kmod-nvidia-3.6.10-2.fc17.x86_64.html
and installing it.

I don't have F18, but I think it should work...

KasumiNinja
5th January 2013, 09:56 PM
Thanks for the help! I'll wait for the update.

DBelton
5th January 2013, 11:48 PM
You just need to enable the rpmfusion updates-testing repo. The kmod is built and in there.

yum --enablerepo=rpmfusion-nonfree-updates-testing install kmod-nvidia

Edit:

Both Fedora and rpmfusion have applied an update to turn off the updates-testing repos in your configuration. But most of the updates are still going into updates-testing.

KasumiNinja
6th January 2013, 06:47 PM
rpmfusion-updates testing did have the wrong kmod file ( kmod-nvidia-3.6.11-3.fc18.x86_64-304.64-1.fc18.3 ). I solved this by doing:


yum --enablerepo=updates-testing install kernel
yum --enablerepo=rpmfusion-nonfree-updates-testing install kmod-nvidia