PDA

View Full Version : Switch lxde desktop to other locale



Yurij
31st December 2012, 04:30 PM
Hello all! Do you celebrate a new year fest?

my question is how to change gui desktop localization\?
I set locale


$locale
LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE="en_US.utf8"
LC_MONETARY="en_US.utf8"
LC_MESSAGES=en_US.UTF-8
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=
i have most (but not all) menus in russian and i want to switch all to english.

sea
31st December 2012, 04:49 PM
If you're keyboard is stuck (wrong layout): system-config-keyboard
If your gui language is wrong: system-config-language.

Either by alt+f2 or in a terminal window.

Hope this helps

Yurij
31st December 2012, 08:42 PM
Both the keyboard and language are set to en_US. that do not effect. the messages in terminal and menus in gui desktop still in russian

PabloTwo
31st December 2012, 09:18 PM
You might check the output from these:

cat /etc/sysconfig/i18n
cat /etc/sysconfig/keyboard
cat /proc/cmdline

Yurij
2nd January 2013, 12:28 PM
You might check the output from these:

cat /etc/sysconfig/i18n
cat /etc/sysconfig/keyboard
cat /proc/cmdline

It seems these settings not afect the the locale in my f17 lxde.

$ cat /etc/sysconfig/i18n
LANG="en_US.UTF-8"
SYSFONT="latarcyrheb-sun16"
$ cat /etc/sysconfig/keyboard
KEYTABLE="us"
MODEL="pc105+inet"
LAYOUT="us"
VARIANT="intl"
OPTIONS="grp:shifts_toggle,grp_led:scroll"
$ cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-3.3.4-5.fc17.i686 root=/dev/mapper/vg_serv-lv_root ro rd.md=0 rd.dm=0 rd.lvm.lv=vg_serv/lv_root SYSFONT=True rd.luks=0 KEYTABLE=us-acentos rd.lvm.lv=vg_serv/lv_boot rd.lvm.lv=vg_serv/lv_swap LANG=en_US.UTF-8 rhgb quiet


i have always localized system i.e. i have localized messages from bash interpreter in terminal and localized ru desktop. although i need only russian keyboard switcher a have all system russified