PDA

View Full Version : AKMOD Dependency Errors



Americanzer0
22nd December 2012, 05:52 PM
Using the installation guide for Nvidia AKMOD Fedora 16/17 I have ran into a problem...

The installation of AKMOD is stopped by two errors revolving around rpm and glibc-common being too new(?). I have attempted a variety of methods to solve this with no success. Using --skip-broken doesn't work, as well as attempting to downgrade the files...

Any and all help would be appreciated....



[stephen@localhost ~]$ sudo yum install --tolerant akmod-nvidia xorg-x11-drv-nvidia-libs
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package akmod-nvidia.x86_64 1:304.64-1.fc18.3 will be installed
--> Processing Dependency: nvidia-kmod-common >= 1:304.64 for package: 1:akmod-nvidia-304.64-1.fc18.3.x86_64
--> Processing Dependency: akmods for package: 1:akmod-nvidia-304.64-1.fc18.3.x86_64
--> Processing Dependency: kmodtool for package: 1:akmod-nvidia-304.64-1.fc18.3.x86_64
---> Package xorg-x11-drv-nvidia-libs.x86_64 1:304.64-3.fc18 will be installed
--> Running transaction check
---> Package akmods.noarch 0:0.4.0-3.fc18 will be installed
--> Processing Dependency: gcc for package: akmods-0.4.0-3.fc18.noarch
--> Processing Dependency: rpm-build for package: akmods-0.4.0-3.fc18.noarch
--> Processing Dependency: /usr/bin/rpmdev-vercmp for package: akmods-0.4.0-3.fc18.noarch
---> Package kmodtool.noarch 0:1-21.fc18 will be installed
---> Package xorg-x11-drv-nvidia.x86_64 1:304.64-3.fc18 will be installed
--> Processing Dependency: nvidia-settings for package: 1:xorg-x11-drv-nvidia-304.64-3.fc18.x86_64
--> Processing Dependency: nvidia-xconfig for package: 1:xorg-x11-drv-nvidia-304.64-3.fc18.x86_64
--> Running transaction check
---> Package gcc.x86_64 0:4.7.2-8.fc18 will be installed
--> Processing Dependency: cpp = 4.7.2-8.fc18 for package: gcc-4.7.2-8.fc18.x86_64
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.7.2-8.fc18.x86_64
--> Processing Dependency: cloog-ppl >= 0.15 for package: gcc-4.7.2-8.fc18.x86_64
--> Processing Dependency: libmpc.so.2()(64bit) for package: gcc-4.7.2-8.fc18.x86_64
---> Package nvidia-settings.x86_64 0:1.0-26.fc18 will be installed
---> Package nvidia-xconfig.x86_64 0:1.0-25.fc18 will be installed
---> Package rpm-build.x86_64 0:4.10.1-3.fc18 will be installed
--> Processing Dependency: rpm = 4.10.1-3.fc18 for package: rpm-build-4.10.1-3.fc18.x86_64
--> Processing Dependency: patch >= 2.5 for package: rpm-build-4.10.1-3.fc18.x86_64
---> Package rpmdevtools.noarch 0:8.3-1.fc18 will be installed
--> Processing Dependency: xemacs-filesystem for package: rpmdevtools-8.3-1.fc18.noarch
--> Processing Dependency: fakeroot for package: rpmdevtools-8.3-1.fc18.noarch
--> Running transaction check
---> Package cloog-ppl.x86_64 0:0.15.11-4.fc18.1 will be installed
--> Processing Dependency: libppl_c.so.4()(64bit) for package: cloog-ppl-0.15.11-4.fc18.1.x86_64
--> Processing Dependency: libppl.so.9()(64bit) for package: cloog-ppl-0.15.11-4.fc18.1.x86_64
---> Package cpp.x86_64 0:4.7.2-8.fc18 will be installed
---> Package fakeroot.x86_64 0:1.12.4-5.fc18 will be installed
--> Processing Dependency: fakeroot-libs = 1.12.4-5.fc18 for package: fakeroot-1.12.4-5.fc18.x86_64
---> Package glibc-devel.x86_64 0:2.16-24.fc18 will be installed
--> Processing Dependency: glibc-headers = 2.16-24.fc18 for package: glibc-devel-2.16-24.fc18.x86_64
--> Processing Dependency: glibc = 2.16-24.fc18 for package: glibc-devel-2.16-24.fc18.x86_64
--> Processing Dependency: glibc-headers for package: glibc-devel-2.16-24.fc18.x86_64
---> Package libmpc.x86_64 0:0.9-3.fc18.2 will be installed
---> Package patch.x86_64 0:2.6.1-14.fc18 will be installed
---> Package rpm-build.x86_64 0:4.10.1-3.fc18 will be installed
--> Processing Dependency: rpm = 4.10.1-3.fc18 for package: rpm-build-4.10.1-3.fc18.x86_64
---> Package xemacs-filesystem.noarch 0:21.5.32-1.fc18 will be installed
--> Running transaction check
---> Package fakeroot-libs.x86_64 0:1.12.4-5.fc18 will be installed
---> Package glibc.i686 0:2.16-24.fc18 will be installed
--> Processing Dependency: glibc-common = 2.16-24.fc18 for package: glibc-2.16-24.fc18.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.16-24.fc18.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.16-24.fc18.i686
---> Package glibc-headers.x86_64 0:2.16-24.fc18 will be installed
---> Package ppl.x86_64 0:0.11.2-10.fc18 will be installed
--> Processing Dependency: libpwl.so.5()(64bit) for package: ppl-0.11.2-10.fc18.x86_64
---> Package rpm-build.x86_64 0:4.10.1-3.fc18 will be installed
--> Processing Dependency: rpm = 4.10.1-3.fc18 for package: rpm-build-4.10.1-3.fc18.x86_64
--> Running transaction check
---> Package glibc.i686 0:2.16-24.fc18 will be installed
--> Processing Dependency: glibc-common = 2.16-24.fc18 for package: glibc-2.16-24.fc18.i686
---> Package nss-softokn-freebl.i686 0:3.14-5.fc18 will be installed
---> Package ppl-pwl.x86_64 0:0.11.2-10.fc18 will be installed
---> Package rpm-build.x86_64 0:4.10.1-3.fc18 will be installed
--> Processing Dependency: rpm = 4.10.1-3.fc18 for package: rpm-build-4.10.1-3.fc18.x86_64
--> Finished Dependency Resolution
Error: Package: rpm-build-4.10.1-3.fc18.x86_64 (fedora)
Requires: rpm = 4.10.1-3.fc18
Installed: rpm-4.10.2-1.fc18.x86_64 (@updates-testing)
rpm = 4.10.2-1.fc18
Available: rpm-4.10.1-3.fc18.x86_64 (fedora)
rpm = 4.10.1-3.fc18
Error: Package: glibc-2.16-24.fc18.i686 (fedora)
Requires: glibc-common = 2.16-24.fc18
Installed: glibc-common-2.16-28.fc18.x86_64 (@updates-testing)
glibc-common = 2.16-28.fc18
Available: glibc-common-2.16-24.fc18.x86_64 (fedora)
glibc-common = 2.16-24.fc18
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

christian_l
22nd December 2012, 07:43 PM
That's weird... As far as I can see, I have all the packages in the same version as you have, yet akmod-nvidia and xorg-x11-drv-nvidia-libs are also installed in the latest version. I had installed these packages a while ago though, before I updated from F17 to F18.

ryanvade
28th December 2012, 08:22 AM
I am having the exact same problem. Anyone figure this out?

Kmod is having a similar problem:

[root@Ryan-windows-PC ryan]# yum install kmod-nvidia xorg-x11-drv-nvidia-libs kernel-PAE-devel kmod-nvidia-PAE
Loaded plugins: langpacks, presto, refresh-packagekit
No package kernel-PAE-devel available.
No package kmod-nvidia-PAE available.
Resolving Dependencies
--> Running transaction check
---> Package kmod-nvidia.x86_64 1:304.64-1.fc18.2 will be installed
--> Processing Dependency: kmod-nvidia-3.6.7-5.fc18.x86_64 >= 1:304.64-1.fc18.2 for package: 1:kmod-nvidia-304.64-1.fc18.2.x86_64
---> Package xorg-x11-drv-nvidia-libs.x86_64 1:304.64-3.fc18 will be installed
--> Processing Dependency: xorg-x11-drv-nvidia = 1:304.64-3.fc18 for package: 1:xorg-x11-drv-nvidia-libs-304.64-3.fc18.x86_64
--> Running transaction check
---> Package kmod-nvidia-3.6.7-5.fc18.x86_64.x86_64 1:304.64-1.fc18.2 will be installed
--> Processing Dependency: kernel-uname-r = 3.6.7-5.fc18.x86_64 for package: 1:kmod-nvidia-3.6.7-5.fc18.x86_64-304.64-1.fc18.2.x86_64
---> Package xorg-x11-drv-nvidia.x86_64 1:304.64-3.fc18 will be installed
--> Processing Dependency: nvidia-settings for package: 1:xorg-x11-drv-nvidia-304.64-3.fc18.x86_64
--> Processing Dependency: nvidia-xconfig for package: 1:xorg-x11-drv-nvidia-304.64-3.fc18.x86_64
--> Running transaction check
---> Package kmod-nvidia-3.6.7-5.fc18.x86_64.x86_64 1:304.64-1.fc18.2 will be installed
--> Processing Dependency: kernel-uname-r = 3.6.7-5.fc18.x86_64 for package: 1:kmod-nvidia-3.6.7-5.fc18.x86_64-304.64-1.fc18.2.x86_64
---> Package nvidia-settings.x86_64 0:1.0-26.fc18 will be installed
---> Package nvidia-xconfig.x86_64 0:1.0-25.fc18 will be installed
--> Finished Dependency Resolution
Error: Package: 1:kmod-nvidia-3.6.7-5.fc18.x86_64-304.64-1.fc18.2.x86_64 (rpmfusion-nonfree)
Requires: kernel-uname-r = 3.6.7-5.fc18.x86_64
Installed: kernel-3.6.6-3.fc18.x86_64 (@koji-override-0/$releasever)
kernel-uname-r = 3.6.6-3.fc18.x86_64
Installed: kernel-3.6.11-3.fc18.x86_64 (@updates-testing)
kernel-uname-r = 3.6.11-3.fc18.x86_64
Available: kernel-3.6.10-4.fc18.x86_64 (fedora)
kernel-uname-r = 3.6.10-4.fc18.x86_64
Available: kernel-debug-3.6.10-4.fc18.x86_64 (fedora)
kernel-uname-r = 3.6.10-4.fc18.x86_64.debug
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

twohot
28th December 2012, 08:46 AM
I am having the exact same problem. Anyone figure this out?
Simple, there's no kmod package for the latest kernel. This is also affecting broadcom-wl ... essentially most kernel dependent packages from rpmfusion misbehave. FC18 is also updatiung pretty fast on the kernel side so apply caution


Any and all help would be appreciated....
Change your repo settings. your machine shouldn't be looking for 32bit glibc-common when you are running 64bit fedora. Its also possible that some approved updates haven't arrived at updates-testing repo by the time you ran this installation session

ryanvade
28th December 2012, 08:57 AM
Fixed. I added
--enablerepo=updates-testing
https://bugzilla.redhat.com/show_bug.cgi?id=889895
Thanks!