PDA

View Full Version : Gtk-WARNING **: cannot open display: :0



debo2011
20th December 2012, 09:01 AM
Hi, before yesterday to receive an update on Fedora 18 beta, running any command or any with zenity, yad and others received the following message. not allow me to run many commands, as:


su
sudo nautilus


Gtk-WARNING **: cannot open display: :0 ...

I solved the problem as follows (as normal user):


echo 'xhost + && clear' >> $HOME/.bashrc

but I'm still not convinced, there is another way to do it.

Yellowman
20th December 2012, 06:19 PM
gdm-3.6.2-4.fc18 is broken



su
yum downgrade gdm*

I gave it negative karma

https://admin.fedoraproject.org/updates/FEDORA-2012-20593/gdm-3.6.2-4.fc18

I also found a bugreport for my gparted issue

https://bugzilla.redhat.com/show_bug.cgi?id=887816

---------- Post added at 05:19 PM ---------- Previous post was at 10:41 AM ----------


gdm-3.6.2-4.fc18 is broken



su
yum downgrade gdm*

I gave it negative karma

https://admin.fedoraproject.org/updates/FEDORA-2012-20593/gdm-3.6.2-4.fc18

I also found a bugreport for my gparted issue

https://bugzilla.redhat.com/show_bug.cgi?id=887816

gdm-3.6.2-5.fc18 fixes the issue here

https://koji.fedoraproject.org/koji/buildinfo?buildID=374009

debo2011
21st December 2012, 09:07 AM
thanks @Yellowman, it works! I just hope the new upgrade gdm, for now I will disable all gdm upgrade.

Yellowman
21st December 2012, 09:09 AM
thanks @Yellowman, it works! but I think it would be good to disable updates about "gdm" for now

Just update to the latest gdm gdm-3.6.2-5.fc18

https://admin.fedoraproject.org/updates/FEDORA-2012-20736/gdm-3.6.2-5.fc18


https://koji.fedoraproject.org/koji/buildinfo?buildID=374009