PDA

View Full Version : Question about kernel update



Zlobniy Shurik
16th December 2012, 06:40 AM
Sorry for dumb question, but...

Why I must run by hands "grub2-mkconfig -o /boot/grub2/grub.cfg" after each kernel update in apper?

Can I automate this operation?

R3v0lut10nary
16th December 2012, 06:44 AM
If you're upgrading through the normal procedure then you shouldn't have to manually update grub.

Are you just using 'yum upgrade'?

Zlobniy Shurik
16th December 2012, 06:49 AM
If you're upgrading through the normal procedure then you shouldn't have to manually update grub.

Are you just using 'yum upgrade'?

Yes, I know about "yum upgrade". But in my case I try to update everything in apper (I am dumb user, that likes GUI ;) ).

R3v0lut10nary
16th December 2012, 06:57 AM
Yes, I know about "yum upgrade". But in my case I try to update everything in apper (I am dumb user, that likes GUI ;) ).

Yeah I haven't used apper to upgrade but I still thought it would take care of updating grub for you.

Maybe next time, just to test it, try upgrading from the command line and see if it still requires you to update grub. At least then you'll know if it's a problem with apper.

Also it could just be a F18 issue since it's still in development.

Zlobniy Shurik
16th December 2012, 07:17 AM
Yeah I haven't used apper to upgrade but I still thought it would take care of updating grub for you.

Maybe next time, just to test it, try upgrading from the command line and see if it still requires you to update grub. At least then you'll know if it's a problem with apper.

Also it could just be a F18 issue since it's still in development.

No, this problem started from Fedora17 (or 16?), when grub2 appeared. I hoped than problem disappear in FC18, but...

Normal Grub2 menu usually appears as:
Fedora (start system with newest kernel)
Advanced options (list of all installed kernels)

After update with apper Grub2 menu become:
3.6.10.xxx (newest kernel)
Fedora (start system with previos kernel)
Advanced options (list of all installed kernels without latest kernel)

Grub2 menu restores to normal state after 'grub2-mkconfig -o /boot/grub2/grub.cfg'

This is non critical bug for me, but very annoying.

DBelton
16th December 2012, 08:42 AM
You don't have to run grub2-mkconfig after a kernel update. But to get the default menu, as grub2-mkconfig creates it, then you need to since the kernel update procedure doesn't create teh new entry exactly like grub2-mkconfig does.

It would function just the same if your didn't run grub2-mkconfig. You would just have the extra entries that show in the menu. I actually prefer that behaviour myself. It lists the installed kernels and I just select one if I wish to boot a previosu kernel without selecting that crappy Advanced Options sub-menu (Which I have been meaning to edit the config files to eliminate, but just haven't gotten around to yet)

R3v0lut10nary
16th December 2012, 05:03 PM
You don't have to run grub2-mkconfig after a kernel update. But to get the default menu, as grub2-mkconfig creates it, then you need to since the kernel update procedure doesn't create teh new entry exactly like grub2-mkconfig does.

It would function just the same if your didn't run grub2-mkconfig. You would just have the extra entries that show in the menu. I actually prefer that behaviour myself. It lists the installed kernels and I just select one if I wish to boot a previosu kernel without selecting that crappy Advanced Options sub-menu (Which I have been meaning to edit the config files to eliminate, but just haven't gotten around to yet)

Oooohhhhh ...... I guess I'm like you in that I like the menu as it is without running any grub updates.

Also, I've been on EFI for quite a while now and have to remember to keep in mind most people are still using the bios grub menu.

In other words I should probably duck out at this point. :sleep:

jrl1357
16th December 2012, 07:21 PM
Oooohhhhh ...... I guess I'm like you in that I like the menu as it is without running any grub updates.

Also, I've been on EFI for quite a while now and have to remember to keep in mind most people are still using the bios grub menu.

In other words I should probably duck out at this point. :sleep:


efi's caused me as many problems as bios did. it's boots faster, but hell if it was ever see any of my multiboots. I have to edit the files my self

chrismurphy
16th December 2012, 08:30 PM
After update with apper Grub2 menu become:
3.6.10.xxx (newest kernel)
Fedora (start system with previos kernel)
Advanced options (list of all installed kernels without latest kernel)

This is the result of grubby updating the grub.cfg after a kernel update. It's quite ugly and I wish we could get rid of grubby for GRUB2 based installations, for this very reason. So it's actually not a bug, but expected behavior.

---------- Post added at 12:25 PM ---------- Previous post was at 12:23 PM ----------

On Fedora 17, UEFI computers are still using GRUB Legacy EFI. This changes to GRUB2-EFI with Fedora 18 so UEFI users are going to see this same ugliness the OP (and everyone else with a BIOS computer) is seeing.

---------- Post added at 12:30 PM ---------- Previous post was at 12:25 PM ----------


efi's caused me as many problems as bios did. it's boots faster, but hell if it was ever see any of my multiboots. I have to edit the files my self

You might check out the fork for rEFIit, called rEFInd which is quite a bit better finding bootable systems than rEFIt. It is a boot manager, not a boot loader. GRUB2 is both a boot manager and a boot loader.

You can use rEFInd to use EFISTUB on newer kernels (since 3.3) as the boot loader, to obviate needing GRUB at all.

R3v0lut10nary
16th December 2012, 10:52 PM
efi's caused me as many problems as bios did. it's boots faster, but hell if it was ever see any of my multiboots. I have to edit the files my self

I'll vouch for chrismurphy's rEFInd recommendation. Great boot manager for EFI, I use it.

Still, I've experienced some problems on less EFI-ready systems. Several methods of trying to add Slackware to my options ended in utter FAIL mode.

AdamW
18th December 2012, 02:27 AM
cmurf is correct, this is intended behaviour. It's a little inconsistent, but it's all working as intended. If you just leave things be, you wind up with 'all grubby style' after three kernel updates, replacing 'mkconfig style'.

Zlobniy Shurik
18th December 2012, 04:42 AM
Well, I am prefer "mkconfig style", so I shall continue to run "grub2-mkconfig" by hands :)

AdamW
18th December 2012, 06:31 AM
you could do something really hacky and make grubby a wrapper which just ran 'grub2-mkconfig', i guess, that'd be a hacky way to make it happen 'automatically'.

Zlobniy Shurik
18th December 2012, 07:42 AM
Hm, interesting idea... I shall try to implement it.