View Full Version : MCSE trying to do Linux...Help!!!

3rd December 2004, 08:06 PM
I have installed Fedora Core 3 onto my laptop. I was having issues with X performance and found out that the Nvidia card in the laptop was a possible cause. The recommendation was to install the latest drivers from Nvidia. I followed the step by step instructions and somehow succeeded with the install!! The system now appears to work fine in X.

The problem I noticed now is that when I do a Logout from X...I get a whole bunch of errors in a split second and back to the userprompt. However X did not seem to shutdown. What it used to do was actually stopp a bunch of the services and then bring me to the prompt. The errors look like this:

manager.c/1070: Recieved 'die', initiating shutdown
manager.c/1003: unmounting all volumes that we saw mounted in our life

(nautilus:3253): Eel-CRITICAL **: file eel-preferences.c: line 872 (preferences_entry_remove_callback): assertion 'entry__>callback_list !=NULL' failed

** (nautilus:3253): WARNING **: destroyed file still being monitored
/usr/lib/python2.3/site-packages/gtk-2.0/gtk/__init__.py:90: GtkDeprecationWarning: gtk.mainquit is depreciated, use gtk.main.quit instead
self.warn(message, DepreciationWarning)

waiting for X server to shut down
(nautilus:3253):Bonobo-WARNING **: Leaked a total of 1 refs to 1 bonobo object

the prompt looks like this:

[root@localhost ~]$

Anybody have any ideas? Also, is there a way to back out of the driver install to get back to the default installed driver? There is no "Add\Remove Programs" MMC <--lol



3rd December 2004, 08:23 PM
The errors that you are seeing are probably what is on tty session 1. Enter ctrl-alt-f1 to switch to that session. You are probably still logged in there - if you started X manually, that is definitely the case. To clean up:

1- Switch back to X with ctrl-alt-f7
2- Terminate X with ctrl-alt-backspace
3- You should be back in tty session 1.
4- If you are root (I assume you are since you were installing X), you can restart gdm and exit the tty session with:

gdm-restart ; exit

If none of this makes any sense, we'll need a little more detail on how you started X after installing the Nvidia driver.

3rd December 2004, 08:30 PM
Thank for the response. I actually had to terminate X with the telinit 3 command from X or logout to X. The system is currently setup to boot into multiuser mode (I guess thats straight to command prompt). I also notice that the StarWars saver no longer can open or be previewed. That's not important. More importantly I am 100% sure that the system is not functioning properly although much faster with the Nvidia driver installed. Could this be a non-issue item? I just know that when I logged out from the "Actions" menu on top that it used to go through a longer process with absolutley no errors. Again...I am a Microsoft guy trying to figure this out. I know...its a handicap.


Shadow Skill
3rd December 2004, 08:33 PM
Did you install the nvidia driver rpm's or did you use their installer method? They should have instructions on how to remove the drivers somewhere in their documentation. It probably is related to how you started X it gives me errors like that when I start it from any other virtual terminal [the tty's the other poster mentioned .] other than the designated seventh virtual terminal which always is used to display the GUI.

About being an MSCE that is not nessecarily a handicap I was just an above average windows user and it took me a couple of months to get the hang of everything you being an MSCE mght make the learning curve somewhat shorter than mine was.. Welcome to the world of real Operating Systems I hope you enjoy your stay, and don't get discouraged this new world was frightening to alot of us here when we first started so we know all too well your current pain. :)

3rd December 2004, 08:53 PM
Shadow...thanks for the encouragement. I'm still required to manage and configure Windows Servers, but find myself more and more interested in playing with Linux.

I just had a thought...When I bootup..the Lilo loader displays two ver of Fedora. The Original and the one from after the Up2date updates. Perhaps I can start from the original and redo those updates. Nvidia says that any new Kernal or X11 packages installed will require a reinstall of their driver.

Thanks Again,


3rd December 2004, 11:37 PM

Welcome aboard. I too am an MCSE who was intrigued by Linux a few years ago. Have been a Red Hat Linux fan since, even though I still do use Windows on a day to day basis.

When you mentioned Lilo, you likely meant Grub. Grub is a newer bootloader that Fedora uses. The two entries that you see are Kernel entries. By choosing one of the other, you can pick which version of the kernel that you boot. However, all of the other software on the system runs in their updated version.

It's not abnormal to see a series of often cryptic and strange messages when you come back out of X. In fact, sometime while in X, hit CTRL-ALT-F1 and it will take you back to the first virtual console. You are likely going to see information messages on the screen, even though everything is working just fine. You can go back to your X Session by pressing CTRL-ALT-F7.

The real question is whether you can boot up to the command prompt, login, type startx to begin an X session, from the actions menu logout, get back to command line and type startx and get x to start again. If you can, I wouldn't worry too much about those messages, but would rather spend time playing with other things. You will learn more from these other items than you likely will trying to troubleshoot every informational message displayed when you exit X. However, if X is crashing or won't start back up properly, you likely do have some type of problem and need to address it.

In terms of the drivers, usually with the driver installs, they build modules that are dependent upon the source code of the kernel installed. Therefore, if you install a new kernel, you would also want to install the kernel-source for that kernel and then recompile the software driver for the hardware. However, by picking the older kernel from Grub, you go back to where you were with the right drivers for your installed kernel version. See what happens from there.

Anyway, welcome aboard. With a little patience and some help from the group here, you will be just fine.

4th December 2004, 12:37 AM
You can run
setup in a terminal prompt and select X configuration. You should be able to get back to the origional, non 3D accelerated driver.

As to what this does, there is a Driver option in the Section "Device" of the /etc/X11/xorg.conf file. I have seen it set to "nv".