PDA

View Full Version : No login screen after F18 update



swashplate
10th November 2012, 01:11 PM
Hi all.

Updated F18 yesterday and it said a core update to Fedora 3.6.6-3.fc18.i686 so I rebooted after the update had continued.

It booted to the new core and the 'fedora progress bar' thing came on as normal and then it flashed.

However, instead of a login screen I got the following message:

dracut-cmdline[57] : warning: kernel command line option 'KEYTABLE' is deprecated.

ap' instead

dracut-cmdline[57] : /etc/locale.conf: Line 1 : locale.LANG=en_US.UTF-8 : command n

[OK] Started sendmail mail transport client

[FAILED] Failed to start Wait for Plymouth Boot screen to quit.

see 'system status plymouth-quit-wait.servioce' for details

[OK] Reached target multi user.

[OK] Reached target graphical interface

It never gets to the fedora login screen and just freezes, won't accept any keyboard input, which I assume is something to do with the keytable message?

Is there any way of sorting this out? F18 was running OK until this update! I'm using my old hard drive on USB with my F16 operating system back up to write this.

All help much appreciated! :-)

secipolla
10th November 2012, 02:30 PM
http://lists.fedoraproject.org/pipermail/test/2012-November/111519.html

swashplate
10th November 2012, 07:55 PM
Thanks for that, Secipolla

Looks like it might be a prob with 'plymouth'. Is there a way of booting up without plymouth? As I don't get to login, I can't run yum update.

---------- Post added at 06:55 PM ---------- Previous post was at 04:31 PM ----------

After some Googling, I have made some progress:

Wait until the above message comes up, then hit Alt-F2 to get a terminal screen.

Type: init3 {ENTER} init5 {ENTER}

...which kills the X-Window stuff, restarts it, and gets me to the login screen! On F18 KDE now, but don't want to do this every time - will an update cure it?

marvin_ita
11th November 2012, 03:00 PM
I ran into that problem myself yesterday.

I switched to a terminal screen with Alt-F2, logged in and did "yum downgrade plymouth*". Everything worked fine after that, just remember to not upgrade plymouth again until that problem is fixed! ;-)

swashplate
11th November 2012, 03:05 PM
That's fascinating marvin, I had no idea you could do a 'downgrade'! I'll have a go at that later, thanks a lot. :-)

BTW, can you do 'yum upgrade "everything-except-plymouth"' or not possible?

marvin_ita
11th November 2012, 03:11 PM
BTW, can you do 'yum upgrade "everything-except-plymouth"' or not possible?

I don't think so... but by using a gui you can easily exlude plymouth from being upgraded. Personally I use yumex.

swashplate
11th November 2012, 03:40 PM
Just done the 'yum downgrade plymouth` and it boots OK now. Will have to make sure it doesn't upgrade plymouth until this is fixed.

Thanks a lot everyone! :-)

secipolla
11th November 2012, 04:10 PM
KEYTABLE= was replaced with vconsole.keymap=
It's just for the console keymap.
localectl command sets these things now. Maybe better would be to just remove them (key, locale - this one gives an error anyway - and font) from /etc/default/grub and update GRUB's menu.

To boot without plymouth, take out 'rghb' from the boot line (at least it was like that in F17, maybe now it's rd.plymouth=1 then you would change it to 0).

I use lightdm and don't have this issue but maybe the problem's with the video driver, not the display manager.

DBelton
12th November 2012, 11:23 PM
That's fascinating marvin, I had no idea you could do a 'downgrade'! I'll have a go at that later, thanks a lot. :-)

BTW, can you do 'yum upgrade "everything-except-plymouth"' or not possible?

Well, if you want yum to update everything except plymouth, you could easily do that...



yum --exclude=plymouth* update

marvin_ita
15th November 2012, 06:23 PM
I've reported the problem in bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=875474

The solution is to update plymouth, then run command 'dracut -f' before restarting.

Ihatewindows
15th November 2012, 06:40 PM
I think for now, at least, that because F18 is still an alpha, and not even in beta yet that we should do something like that in a virtual machine so that we can experiment with it there instead of on your personal machine. Just my take on the issue. :)

swashplate
15th November 2012, 07:02 PM
Just tried:

sudo yum update plymouth ; sudo dracut -f

followed by a reboot and this works fine!

Next time I have an issue, I shall also report it on buzilla.redhat as well.

I originally tried installing F18 on my F16 system's Virtualbox, but it threw a tantrum. So I cloned my laptops hard drive onto one of my spare hard drives using DD (took 8 hours!) and took the plunge... :eek:

Thanks to everyone who has helped with this! :cool: I feel that I have learned a lot about Linux this week as well as sorting my system out! :)

One can never have enough knowledge! :cool: :)