PDA

View Full Version : no sound in xfce 4.10



ianoscar
31st October 2012, 08:06 AM
Hi there..

I have just installed XFCE 4.10 on top on my F17 gnome. Now, when I logged in XFCE desktop I just cannot configure why was it has no sound. I put the mixer volume in full, player volume in full.
If I logged to Gnome, I got the sound.

nirik
31st October 2012, 11:49 PM
How are you logging into each? gdm in both cases?

stevea
1st November 2012, 12:43 AM
Have you tried jiggling the pavucontrol & alsamixer.

The ONLY way the DE makes a differnce, that I am aware of, is the startup of the pulse daemon. (In fedora each user login starts the pulse daemon, if it fails ... no sound).

If you use this command in a terminal window (DO NOT use root privileges)
/usr/bin/pulseaudio --start --log-target=syslog
then if sound works, then thats the problem. You should also look for the daemon with
ps -aefl | grep pulse


Normally a freedesktop compliant desktop like XFCE should use this config file,
/etc/xdg/autostart/pulseaudio.desktop
to start pulse. That file is part of .... pulseaudio-module-x11 package.

So there is a good change your (homebuilt?) xfce 4.10 doesn't pull in all the packages.

PLZ post whatever you find (and mark it solved when it is).

ianoscar
1st November 2012, 05:38 AM
I am using GDM for Log In.

I have open up the Audio Mixer, it shows sound card : HDA Intel (Alsa MIxer).
After that I try to change it to Playback:PulseAudio Mixer and still it doesnt have any difference.

I change it back to HDA Intel (alsa mixer) and then reboot my computer.
Now I got back the Sound when I logged in to XFCE.

Previously I have some error on Rhythmbox that showup in my error list.