PDA

View Full Version : NVIDIA driver issue?



Vespa
29th October 2012, 12:31 AM
Today I performed a yum upgrade to F18 from F17. It went pretty smoothly I must say. The only problem I have had is getting the proprietary NVIDIA driver working. If I load the system without an 'xorg.conf' file it loads the default drivers just fine. When specifying the nvidia driver, however, the system will not load the display manager. Shell access is still available though. Is the proprietary driver ready for prime time yet or should I be more patient?


[vespa@qwerty ~]$ rpm -qa *\nvidia\* *\kernel\*|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat /etc/X11/xorg.conf
abrt-addon-kerneloops-2.0.17-2.fc18.x86_64
akmod-nvidia-304.60-1.fc18.x86_64
kernel-3.6.2-2.fc18.x86_64
kernel-3.6.2-4.fc17.x86_64
kernel-3.6.3-3.fc18.x86_64
kernel-devel-3.6.1-1.fc17.x86_64
kernel-devel-3.6.2-4.fc17.x86_64
kernel-devel-3.6.3-3.fc18.x86_64
kernel-headers-3.6.3-3.fc18.x86_64
kernel-modules-extra-3.6.2-4.fc17.x86_64
kernel-modules-extra-3.6.3-3.fc18.x86_64
libreport-plugin-kerneloops-2.0.17-1.fc18.x86_64
nvidia-settings-1.0-27.fc18.x86_64
nvidia-xconfig-1.0-25.fc18.x86_64
xorg-x11-drv-nvidia-304.60-1.fc18.x86_64
xorg-x11-drv-nvidia-libs-304.60-1.fc18.x86_64
3.6.3-3.fc18.x86_64
nouveau 890739 0
mxm_wmi 12823 1 nouveau
wmi 18697 2 mxm_wmi,nouveau
i2c_algo_bit 13257 1 nouveau
drm_kms_helper 44701 1 nouveau
ttm 79760 1 nouveau
drm 255010 3 ttm,drm_kms_helper,nouveau
i2c_core 38314 6 drm,i2c_i801,drm_kms_helper,i2c_algo_bit,nouveau,v ideodev
video 18936 1 nouveau
cat: /etc/X11/xorg.conf: No such file or directory

chepioq
29th October 2012, 07:19 AM
It seem that nouveau driver is not blacklisted...

Yellowman
29th October 2012, 07:45 AM
Try


akmods --force
dracut -f -v /boot/initramfs-$(uname -r).img $(uname -r)
reboot

chepioq
29th October 2012, 08:44 AM
Hummmm...
For me it's very strange (maybe I don't understood)

I installed the nvidia driver 304.60-1 from rpmfusion repo.

When I boot, I can see nvidia logo.

nouveau is blacklisted (part of my xorg.conf) :
linux /vmlinuz-3.6.3-3.fc18.x86_64 root=UUID=83d24e47-9506-47d6-bb69-b7ba17757bad ro quiet rhgb SYSFONT=latarcyrheb-sun16 LANG=fr_FR.UTF-8 KEYTABLE=fr-latin9 vga=normal nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off


I have a blacklist-nouveau.conf in my /etc/modprode.d

But when I run "rpm -qa *\nvidia\* *\kernel\*|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat /etc/X11/xorg.conf", I have this result:

[root@dominique ~]# rpm -qa *\nvidia\* *\kernel\*|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat /etc/X11/xorg.conf
abrt-addon-kerneloops-2.0.17-2.fc18.x86_64
akmod-nvidia-304.60-1.fc18.x86_64
kernel-3.6.1-1.fc18.x86_64
kernel-3.6.2-2.fc18.x86_64
kernel-3.6.3-3.fc18.x86_64
kernel-devel-3.6.1-1.fc18.x86_64
kernel-devel-3.6.2-2.fc18.x86_64
kernel-devel-3.6.3-3.fc18.x86_64
kernel-headers-3.6.3-3.fc18.x86_64
kmod-nvidia-3.6.3-3.fc18.x86_64-304.60-1.fc18.x86_64
libreport-plugin-kerneloops-2.0.17-1.fc18.x86_64
nvidia-settings-1.0-27.fc18.x86_64
nvidia-xconfig-1.0-25.fc18.x86_64
xorg-x11-drv-nvidia-304.60-1.fc18.x86_64
xorg-x11-drv-nvidia-libs-304.60-1.fc18.i686
xorg-x11-drv-nvidia-libs-304.60-1.fc18.x86_64
3.6.3-3.fc18.x86_64
nvidia 11275293 51
nouveau 890739 0
mxm_wmi 12823 1 nouveau
i2c_algo_bit 13257 1 nouveau
drm_kms_helper 44701 1 nouveau
ttm 79760 1 nouveau
drm 255010 3 ttm,drm_kms_helper,nouveau
i2c_core 38314 7 drm,i2c_i801,drm_kms_helper,i2c_algo_bit,nvidia,no uveau,videodev
wmi 18697 2 mxm_wmi,nouveau
video 18936 1 nouveau
# RPM Fusion - nvidia-xorg.conf
#
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection
[root@dominique ~]#

My F18 seem work well with nvidia drivers, but why can I see "nouveau" in output of the command ?

DBelton
29th October 2012, 02:38 PM
You probably have nouveau being loaded in your initramfs and it needs to be rebuilt after you blacklist the nouveau module.



su -
(root password)
cp /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r).bak
dracut -f /boot/initramfs-$(uname -r).img $(uname -r)

Vespa
29th October 2012, 11:15 PM
Try


akmods --force
dracut -f -v /boot/initramfs-$(uname -r).img $(uname -r)
reboot

This is what finally worked for me, thank you. I had regenerated the initramfs a few times and had ensured that nouveau was blacklisted. It was not until I ran the akmods --force that the nvidia driver worked for me.

Cheers!

chepioq
30th October 2012, 06:23 AM
You probably have nouveau being loaded in your initramfs and it needs to be rebuilt after you blacklist the nouveau module.



su -
(root password)
cp /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r).bak
dracut -f /boot/initramfs-$(uname -r).img $(uname -r)


That don't solve the problem, after this command I have same result :

[root@dominique ~]# rpm -qa *\nvidia\* *\kernel\*|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat /etc/X11/xorg.conf
abrt-addon-kerneloops-2.0.17-2.fc18.x86_64
akmod-nvidia-304.60-1.fc18.x86_64
kernel-3.6.1-1.fc18.x86_64
kernel-3.6.2-2.fc18.x86_64
kernel-3.6.3-3.fc18.x86_64
kernel-devel-3.6.1-1.fc18.x86_64
kernel-devel-3.6.2-2.fc18.x86_64
kernel-devel-3.6.3-3.fc18.x86_64
kernel-headers-3.6.3-3.fc18.x86_64
kmod-nvidia-3.6.3-3.fc18.x86_64-304.60-1.fc18.x86_64
libreport-plugin-kerneloops-2.0.17-1.fc18.x86_64
nvidia-settings-1.0-27.fc18.x86_64
nvidia-xconfig-1.0-25.fc18.x86_64
xorg-x11-drv-nvidia-304.60-1.fc18.x86_64
xorg-x11-drv-nvidia-libs-304.60-1.fc18.i686
xorg-x11-drv-nvidia-libs-304.60-1.fc18.x86_64
3.6.3-3.fc18.x86_64
nvidia 11275293 51
nouveau 890739 0
mxm_wmi 12823 1 nouveau
i2c_algo_bit 13257 1 nouveau
drm_kms_helper 44701 1 nouveau
ttm 79760 1 nouveau
drm 255010 3 ttm,drm_kms_helper,nouveau
i2c_core 38314 7 drm,i2c_i801,drm_kms_helper,i2c_algo_bit,nvidia,no uveau,videodev
wmi 18697 2 mxm_wmi,nouveau
video 18936 1 nouveau
# RPM Fusion - nvidia-xorg.conf
# rpm -qa *\nvidia\* *\kernel\*|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat /etc/X11/xorg.conf
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection
[root@dominique ~]#


I don't know if it's important but

[dominique@dominique ~]$ glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
301 frames in 5.0 seconds = 60.042 FPS
300 frames in 5.0 seconds = 59.829 FPS
300 frames in 5.0 seconds = 59.828 FPS
300 frames in 5.0 seconds = 59.829 FPS
^C
[dominique@dominique ~]$

It's very small, with my F17 and driver nvidia I have a better result

==EDIT==
I also do "akmods --force" for same result

Thetargos
30th October 2012, 06:48 AM
What about

glxinfo | grep opengl?
Vendor string should be Nvidia, not nouveau.

Enviado desde mi GT-I9100 usando Tapatalk 2

chepioq
30th October 2012, 05:56 PM
What about

glxinfo | grep opengl?
Vendor string should be Nvidia, not nouveau.


This command return nothing, the good command is glxinfo | grep OpenGL

[dominique@dominique ~]$ glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GT 525M/PCIe/SSE2
OpenGL version string: 4.2.0 NVIDIA 304.60
OpenGL shading language version string: 4.20 NVIDIA via Cg compiler
OpenGL extensions:
[dominique@dominique ~]$


Drivers nvidia are loaded and active, I don't know why I see nouveau in "lsmod |grep -e nvidia -e nouveau"... :confused:

[dominique@dominique ~]$ lsmod |grep -e nvidia -e nouveau
nvidia 11275293 67
nouveau 890739 0
mxm_wmi 12823 1 nouveau
i2c_algo_bit 13257 1 nouveau
drm_kms_helper 44701 1 nouveau
ttm 79760 1 nouveau
drm 255010 3 ttm,drm_kms_helper,nouveau
i2c_core 38314 7 drm,i2c_i801,drm_kms_helper,i2c_algo_bit,nvidia,no uveau,videodev
video 18936 1 nouveau
wmi 18697 2 mxm_wmi,nouveau
[dominique@dominique ~]$

Thetargos
30th October 2012, 07:00 PM
sudo rmmod nouveau ;-)

Enviado desde mi GT-I9100 usando Tapatalk 2

chepioq
30th October 2012, 08:07 PM
sudo rmmod nouveau ;-)

Enviado desde mi GT-I9100 usando Tapatalk 2

That solve problem for the session :

[dominique@dominique ~]$ lsmod |grep -e nvidia -e nouveau
nvidia 11275293 51
i2c_core 38314 6 drm,i2c_i801,drm_kms_helper,i2c_algo_bit,nvidia,vi deodev
[dominique@dominique ~]$

But after reboot, nouveau appear...

[dominique@dominique ~]$ lsmod |grep -e nvidia -e nouveau
nvidia 11275293 51
nouveau 890739 0
mxm_wmi 12823 1 nouveau
i2c_algo_bit 13257 1 nouveau
drm_kms_helper 44701 1 nouveau
ttm 79760 1 nouveau
drm 255010 3 ttm,drm_kms_helper,nouveau
i2c_core 38314 7 drm,i2c_i801,drm_kms_helper,i2c_algo_bit,nvidia,no uveau,videodev
video 18936 1 nouveau
wmi 18697 2 mxm_wmi,nouveau


But it's not a big problem, my F18 work fine anyway.

patrick
2nd November 2012, 10:46 PM
I have a similar problem after updating the kernel.

Nouveau is blacklisted in /etc/modprobe.d, again in the grub kernel line, I have removed the nouveau package, and I rebuild initramfs with dracut. Yet it still appears! Mind boggling!

Booting older 3.6.0-1 kernel works fine, but the 3.6.2-2 and 3.6.5-2 kernels I have are nouveau fanatics.

I have not tried to rmmod, a little embarrassed I didn't think of that...

chepioq
3rd November 2012, 06:30 AM
@patrick

I open a bug on rpmfusion bugzilla : https://bugzilla.rpmfusion.org/show_bug.cgi?id=2559

If you want, add a comment...

Yellowman
3rd November 2012, 12:39 PM
@patrick

I open a bug on rpmfusion bugzilla : https://bugzilla.rpmfusion.org/show_bug.cgi?id=2559

If you want, add a comment...

I just closed it, please file another against kmod at redhat bugzilla

---------- Post added at 11:39 AM ---------- Previous post was at 08:19 AM ----------


I have a similar problem after updating the kernel.

Nouveau is blacklisted in /etc/modprobe.d, again in the grub kernel line, I have removed the nouveau package, and I rebuild initramfs with dracut. Yet it still appears! Mind boggling!

Booting older 3.6.0-1 kernel works fine, but the 3.6.2-2 and 3.6.5-2 kernels I have are nouveau fanatics.

I have not tried to rmmod, a little embarrassed I didn't think of that...

There seems to be only one way to block nouveau



dracut -f -v --omit-drivers nouveau /boot/initramfs-$(uname -r).img $(uname -r)

secipolla
8th November 2012, 08:02 PM
I upgraded yesterday to F18 (yum) and obviously was faced with this issue.
nouveau is loaded regardless of the blacklist and I could only get to the desktop with 'nomodeset' in the boot line.

I will try copying blacklist-nouveau.conf to /lib/modprobe.d as per https://bugzilla.redhat.com/show_bug.cgi?id=873220

---------- Post added at 03:33 PM ---------- Previous post was at 02:04 PM ----------

Didn't work. Must go with the dracut command, then.
Ops, I misunderstood it. We must edit /usr/lib/dracut/modules.d/90kernel-modules/parse-kernel.sh, it seems.

---------- Post added at 05:02 PM ---------- Previous post was at 03:33 PM ----------

I rebuilt initramfs omitting nouveau and, apart from the pending dracut bug, all is well.

Note that just with 'nomodeset' and nouveau loading (mixed with nvidia) that was crashing thunar, tumbler and other Xfce components so it's a must to run the command Yellowman provided.

vallimar
8th November 2012, 09:37 PM
You can also create a file to do this automatically with kernel upgrades.
Create the file /etc/dracut.conf.d/99-local.conf and place inside it:

omit_drivers+=" nouveau "
You can also add "crypt", "dm" and "lvm" if you don't need them.
You might also wish to add:

# build initrd only to boot current hardware
hostonly="yes"

secipolla
8th November 2012, 10:48 PM
Thanks for the tip, but I think it's

omit_drivers+=" nouveau "

vallimar
8th November 2012, 11:36 PM
Thanks for the tip, but I think it's

omit_drivers+=" nouveau "

Yes, fixed, thanks.
Also, if you don't want a graphical boot, you can add "plymouth".
That will shrink the initramfs file a good chunk also.

secipolla
8th November 2012, 11:50 PM
The 'dm', 'md', 'lvm', 'crypt', 'plymouth' are dracut modules but 'nouveau', 'radeon' are drivers.
So it would be different lines.

vallimar
9th November 2012, 02:55 PM
Right again, this is what I get for not paying good attention to which file I copied from.
Thanks for the corrections.

VastOne
30th November 2012, 10:54 PM
You can also create a file to do this automatically with kernel upgrades.
Create the file /etc/dracut.conf.d/99-local.conf and place inside it:

omit_drivers+=" nouveau "
You can also add "crypt", "dm" and "lvm" if you don't need them.
You might also wish to add:

# build initrd only to boot current hardware
hostonly="yes"


The 'dm', 'md', 'lvm', 'crypt', 'plymouth' are dracut modules but 'nouveau', 'radeon' are drivers.
So it would be different lines.

Can either of you provide an example of the exact syntax for these in 99-local.conf, please?

I have google fu'd it and find different ways of doing it...

Is this OK


omit_drivers+=" nouveau "

or would it need to be something similar to this (obviously for a different module):


dracut -o "multipath lvm" no-multipath-lvm.img

Thank you...