PDA

View Full Version : exactimage on fedora



Himlad1519
26th October 2012, 07:46 PM
hello guys. I ve been trying to install package ExactImage (http://www.exactcode.com/site/open_source/exactimage/) to my FC17, and since it's not in any repo i could find, i ve decided to compile it. Having some problems though.

./configure would give me this:


checking whether the C++ compiler works ... yes
checking for C++ STL support ... yes
checking for C++ templates ... yes
checking for C++ template specialization ... yes
checking for C++ partial template specialization ... yes
checking whether C++ supports templates ... yes
checking for header iostream ... found
checking for header string ... found
checking for header iostream ... found
checking for header sstream ... found
checking for header fstream ... found
checking for package x11 (atleast 11.0) ... yes (11.0)
checking for package libagg (atleast 2.3) ... yes (2.5.0)
checking for package freetype2 (atleast 9.5.0) ... yes (14.0.8)
checking for package evas (atleast 0.9.9) ... yes (1.0.1)
checking for header Evas_Engine_GL_X11.h ... found
checking for package libjpeg ... yes
checking for package libtiff ... yes
checking for package libpng (atleast 1.2) ... yes (1.5.10)
checking for package libungif ... no
checking for package jasper ... yes
checking for package expat ... yes
checking for package OpenEXR (atleast 1.2.0) ... yes (1.7.0)
checking for package lcms (atleast 1.10) ... yes (1.19)
checking for package bardecode ... no
For optional, proprietary barcode recognition, place it in 'external/'.

checking for package swig (atleast 1.3.32) ... yes (2.0.8)
checking for package lua (atleast 5.1) ... yes (5.1.4)
checking for package perl (atleast 5.8.0) ... yes (5.14.2)
checking for package php (atleast 5.2.0) ... yes (5.4.7)
checking for package python (atleast 2.5.0) ... yes (2.7.3)
./configure: line 103: python-config: command not found
checking for package ruby (atleast 1.8.5) ... yes (1.9.3p286)

make would give me errors. i ve tried to install libungif from repos, only to find out that it is already installed with the giflib package. i dont know why python-config would complain in line 103 and generally speaking i have no clue on what to do. has anyone installed this package before? is there a guide somewhere, cause google would give me nothing about fedora. any tips would be appreciated. thank you for your time. :)

PabloTwo
26th October 2012, 07:59 PM
Try this,

# yum install giflib python-devel
Edit: Right.... giflib-devel

DBelton
26th October 2012, 08:00 PM
Do you have the python-devel package installed? I believe that is what provides python-config.
You may also need the giflib-devel package as well.

Himlad1519
26th October 2012, 08:09 PM
indedd i haven't installed giflib-devel and python-devel. thank you for that. however make returns a handful of errors:


C++ objdir/lib/scale.o
lib/scale.cc:62:0: warning: ignoring #pragma omp parallel [-Wunknown-pragmas]
lib/scale.cc:102:0: warning: ignoring #pragma omp parallel [-Wunknown-pragmas]
C++ objdir/lib/optimize2bw.o
C++ objdir/lib/Colorspace.o
lib/Colorspace.cc: In function ‘void normalize(Image&, uint8_t, uint8_t)’:
lib/Colorspace.cc:92:5: warning: ‘black’ may be used uninitialized in this function [-Wmaybe-uninitialized]
lib/Colorspace.cc:37:29: note: ‘black’ was declared here
.
.
.
lib/Colorspace.cc:92:5: warning: ‘black’ may be used uninitialized in this function [-Wmaybe-uninitialized]
lib/Colorspace.cc:37:29: note: ‘black’ was declared here
lib/Colorspace.cc:92:5: warning: ‘white’ may be used uninitialized in this function [-Wmaybe-uninitialized]
lib/Colorspace.cc:37:36: note: ‘white’ was declared here
C++ objdir/lib/hocr.o
C++ objdir/lib/agg.o
C++ objdir/lib/FG-Matrix.o
C++ objdir/lib/low-level.o
C++ objdir/lib/rotate.o
lib/rotate.cc:247:0: warning: ignoring #pragma omp parallel [-Wunknown-pragmas]
lib/rotate.cc:375:0: warning: ignoring #pragma omp parallel [-Wunknown-pragmas]
lib/rotate.cc: In function ‘Image* copy_crop_rotate(Image&, int, int, unsigned int, unsigned int, double, const Image::iterator&)’:
lib/rotate.cc:422:35: warning: ‘t’ may be used uninitialized in this function [-Wmaybe-uninitialized]
C++ objdir/lib/crop.o
C++ objdir/lib/Matrix.o
C++ objdir/lib/ContourMatching.o
C++ objdir/lib/empty-page.o
C++ objdir/lib/segmentation.o
C++ objdir/lib/Image2.o
C++ objdir/lib/GaussianBlur.o
C++ objdir/lib/Image.o
C++ objdir/lib/riemersma.o
C++ objdir/lib/canvas.o
C++ objdir/lib/ContourUtility.o
C++ objdir/lib/floyd-steinberg.o
C++ objdir/lib/DistanceMatrix.o
C++ objdir/lib/vectorial.o
In file included from lib/vectorial.cc:34:0:
/usr/include/agg2/agg_conv_curve.h: In member function ‘unsigned int agg::conv_curve<VertexSource, Curve3, Curve4>::vertex(double*, double*) [with VertexSource = agg::path_base<agg::vertex_block_storage<double> >; Curve3 = agg::curve3; Curve4 = agg::curve4]’:
/usr/include/agg2/agg_conv_curve.h:186:13: warning: ‘ct2_x’ may be used uninitialized in this function [-Wmaybe-uninitialized]
/usr/include/agg2/agg_conv_curve.h:186:13: warning: ‘ct2_y’ may be used uninitialized in this function [-Wmaybe-uninitialized]
/usr/include/agg2/agg_conv_curve.h:186:13: warning: ‘end_y’ may be used uninitialized in this function [-Wmaybe-uninitialized]
/usr/include/agg2/agg_conv_curve.h:186:13: warning: ‘end_x’ may be used uninitialized in this function [-Wmaybe-uninitialized]
C++ objdir/lib/Contours.o
LINK LIB objdir/lib/lib.a
C++ objdir/codecs/dcraw.o
In file included from codecs/dcraw.cc:117:0:
codecs/dcraw.h: In function ‘void dcraw::vng_interpolate()’:
codecs/dcraw.h:3978:3: warning: narrowing conversion of ‘128’ from ‘int’ to ‘const signed char’ inside { } is ill-formed in C++11 [-Wnarrowing]
codecs/dcraw.h:3978:3: warning: narrowing conversion of ‘136’ from ‘int’ to ‘const signed char’ inside { } is ill-formed in C++11 [-Wnarrowing]
codecs/dcraw.h:3978:3: warning: narrowing conversion of ‘128’ from ‘int’ to ‘const signed char’ inside { } is ill-formed in C++11 [-Wnarrowing]
codecs/dcraw.h:3978:3: warning: narrowing conversion of ‘136’ from ‘int’ to ‘const signed char’ inside { } is ill-formed in C++11 [-Wnarrowing]
codecs/dcraw.h:3978:3: warning: narrowing conversion of ‘128’ from ‘int’ to ‘const signed char’ inside { } is ill-formed in C++11 [-Wnarrowing]
codecs/dcraw.h:3978:3: warning: narrowing conversion of ‘136’ from ‘int’ to ‘const signed char’ inside { } is ill-formed in C++11 [-Wnarrowing]
codecs/dcraw.h: In function ‘void dcraw::parse_phase_one(int)’:
codecs/dcraw.h:5707:26: warning: variable ‘type’ set but not used [-Wunused-but-set-variable]
codecs/dcraw.h: In function ‘void dcraw::adobe_coeff(const char*, const char*)’:
codecs/dcraw.h:6458:3: warning: narrowing conversion of ‘65472’ from ‘int’ to ‘short int’ inside { } is ill-formed in C++11 [-Wnarrowing]
codecs/dcraw.h:6458:3: warning: narrowing conversion of ‘65520’ from ‘int’ to ‘short int’ inside { } is ill-formed in C++11 [-Wnarrowing]
codecs/dcraw.h:6458:3: warning: narrowing conversion of ‘65472’ from ‘int’ to ‘short int’ inside { } is ill-formed in C++11 [-Wnarrowing]
codecs/dcraw.h:6458:3: warning: narrowing conversion of ‘65520’ from ‘int’ to ‘short int’ inside { } is ill-formed in C++11 [-Wnarrowing]
codecs/dcraw.h:6458:3: warning: narrowing conversion of ‘63472’ from ‘int’ to ‘short int’ inside { } is ill-formed in C++11 [-Wnarrowing]
codecs/dcraw.h:6458:3: warning: narrowing conversion of ‘63820’ from ‘int’ to ‘short int’ inside { } is ill-formed in C++11 [-Wnarrowing]
codecs/dcraw.h:6458:3: warning: narrowing conversion of ‘65520’ from ‘int’ to ‘short int’ inside { } is ill-formed in C++11 [-Wnarrowing]
codecs/dcraw.h:6458:3: warning: narrowing conversion of ‘63484’ from ‘int’ to ‘short int’ inside { } is ill-formed in C++11 [-Wnarrowing]
codecs/dcraw.h:6458:3: warning: narrowing conversion of ‘63472’ from ‘int’ to ‘short int’ inside { } is ill-formed in C++11 [-Wnarrowing]
codecs/dcraw.h: In function ‘void dcraw::foveon_interpolate()’:
codecs/dcraw.h:3142:35: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:3143:36: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:3142:19: warning: array subscript is above array bounds [-Warray-bounds]
.
.
.
codecs/dcraw.h:3096:19: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:3096:19: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h: In function ‘void dcraw::parse_mos(int)’:
codecs/dcraw.h:4820:15: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:4820:15: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:4820:15: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:4820:15: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:4820:15: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:4820:15: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h: In function ‘void dcraw::parse_phase_one(int)’:
codecs/dcraw.h:5729:17: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:5729:17: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:5729:17: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:5729:17: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:5729:17: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:5729:17: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h: In function ‘void dcraw::adobe_coeff(const char*, const char*)’:
codecs/dcraw.h:6469:14: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:6469:14: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:6469:14: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:6469:14: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:6469:14: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:6469:14: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:6469:14: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:6469:14: warning: array subscript is above array bounds [-Warray-bounds]
codecs/dcraw.h:6469:14: warning: array subscript is above array bounds [-Warray-bounds]
C++ objdir/codecs/openexr.o
C++ objdir/codecs/agg_svg_path_renderer.o
C++ objdir/codecs/png.o
codecs/png.cc: In member function ‘virtual int PNGCodec::readImage(std::istream*, Image&, const string&)’:
codecs/png.cc:74:39: error: ‘png_infopp_NULL’ was not declared in this scope
codecs/png.cc:85:50: error: ‘png_infopp_NULL’ was not declared in this scope
codecs/png.cc:102:20: error: ‘int_p_NULL’ was not declared in this scope
codecs/png.cc:107:23: error: invalid use of incomplete type ‘png_info {aka struct png_info_def}’
In file included from codecs/png.cc:19:0:
/usr/include/png.h:722:16: error: forward declaration of ‘png_info {aka struct png_info_def}’
codecs/png.cc:126:17: error: invalid use of incomplete type ‘png_info {aka struct png_info_def}’
In file included from codecs/png.cc:19:0:
/usr/include/png.h:722:16: error: forward declaration of ‘png_info {aka struct png_info_def}’
codecs/png.cc:199:44: error: ‘png_bytepp_NULL’ was not declared in this scope
codecs/png.cc:203:48: error: ‘png_infopp_NULL’ was not declared in this scope
codecs/png.cc: In member function ‘virtual bool PNGCodec::writeImage(std::ostream*, Image&, int, const string&)’:
codecs/png.cc:227:40: error: ‘png_infopp_NULL’ was not declared in this scope
codecs/png.cc:242:13: error: ‘Z_BEST_COMPRESSION’ was not declared in this scope
codecs/png.cc:247:26: error: ‘png_info_init’ was not declared in this scope
make: *** [objdir/codecs/png.o] Error 1

i ve added:
.
.
.
to show similar output, cause it would be too long to post

DBelton
26th October 2012, 08:18 PM
try installing libpng-devel

Himlad1519
26th October 2012, 08:19 PM
Package 2:libpng-devel-1.5.10-1.fc17.i686 already installed and latest version

i am trying to install this package (http://dl.exactcode.de/oss/exact-image/exact-image-0.8.7.tar.bz2)

Himlad1519
27th October 2012, 12:19 PM
so... no idea, on what to do?

drs
4th December 2012, 05:12 AM
I believe the problem is the libpng 1.4 included in Fedora 17 has depreciated some code used by ExactImage (which is probably based on libpng 1.2). I was able to get it to compile by the removing codecs/png.cc and codecs/png.hh files. Hopefully you don't need to work with png files.

I also had to follow the suggestion[1] to add "LDFLAGS += -lgif” to the end of the Makefile generated by ./configure.

I only compiled this to use hocr2pdf. However, it would not work on hocr files produced by cuneiform and I don't know if my workaround is the cause of this failure. Maybe you'll have better luck.

[1]http://blogs.gnome.org/muelli/2011/02/ocring-a-scanned-book/