PDA

View Full Version : VirtualBox - Can't make it work.



Depado
23rd October 2012, 06:43 PM
Hello.

It's been about 2 hours that I'm trying to make VirtualBox work. It seems that I can't.
So I tried :

yum install VirtualBox
Kernel driver not installed (rc=-1908)
The virtualbox linux kernel driver (vboxdrv) is probably not loaded.
[root@silence hellsing]# /etc/sysconfig/modules/VirtualBox.modules
ERROR: Module vboxdrv not found.
ERROR: Module vboxnetflt not found.
ERROR: Module vboxnetadp not found.

Sooo... Okay the Fedora package doesn't contain the vboxdrv ? (I tried rebooting, still don't have it)
Well I tried so many things...
Can someone help me with that ? Is there a simple way of installing VirtualBox on Fedora (and make it work ?)

nonamedotc
23rd October 2012, 06:57 PM
Yes. I use virtualbox everyday and this is what I do.


curl http://download.virtualbox.org/virtualbox/rpm/fedora/virtualbox.repo -o /etc/yum.repos.d/virtualbox.repo

yum install VirtualBox-4.1

For the 4.1.22 version extension pack - http://download.virtualbox.org/virtualbox/4.1.22/Oracle_VM_VirtualBox_Extension_Pack-4.1.22-80657.vbox-extpack

Done!

Note: if you want Virtualbox 4.2, replace VirtualBox-4.1 in the above yum line by VirtualBox-4.2

meine
23rd October 2012, 08:19 PM
in the beginning I also had some trouble getting VB working. I discovered that VB has a heavy dependency on its kernel modules, without the proper one(s) it will not run. to get the right kernel modules and updates for it you can install akmod-virtualbox. I discovered the akmod- in analogy with the akmod for the nvidia drivers.

below are the dumps of $ yum info virtualbox; yum info akmod-virtualbox for further info. both VB and akmod-VB come from the rpmfusion-free repo, so you'll have to install this first

# yum --nogpgcheck install -y http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
# yum install -y virtualbox akmod-virtualbox

it should be mentioned that the akmod-virtualbox is not always up to date directly after a new version of VB. this causes a non working VB, but after a day or two this often is fixed and the kernel modules are updated too. personally I don't know/use a workaround for this, i'll just wait...

another good how2 on installing VB is here http://www.if-not-true-then-false.com/2010/install-virtualbox-with-yum-on-fedora-centos-red-hat-rhel/, just use the Fedora parts only and skip the rest. this guide does not provide any instructions on installing the akmod-virtualbox though.

Installed Packages
Name : VirtualBox
Arch : x86_64
Version : 4.2.0
Release : 3.fc17
Size : 49 M
Repo : installed
From repo : rpmfusion-free-updates
Summary : A general-purpose full virtualizer for PC hardware
URL : http://www.virtualbox.org/wiki/VirtualBox
License : GPLv2 or (GPLv2 and CDDL)
Description : A general-purpose full virtualizer and emulator for 32-bit and
: 64-bit x86 based PC-compatible machines.

Installed Packages
Name : akmod-VirtualBox
Arch : x86_64
Version : 4.2.0
Release : 1.fc17
Size : 11 k
Repo : installed
From repo : rpmfusion-free-updates
Summary : Akmod package for VirtualBox kernel module(s)
URL : http://www.virtualbox.org/wiki/VirtualBox
License : GPLv2 or CDDL
Description : This package provides the akmod package for the VirtualBox kernel
: modules.

Ihatewindows
24th October 2012, 12:41 AM
I cant remember how I got VirtualBox on mine, I think I used apper.

sudo yum install apper
It behaves alot like the Ubuntu Software Center. It comes natively with the KDE spin.

sea
24th October 2012, 12:52 AM
Yikes guys.. its much simpler, at least thats been working for me...


su
wget http://download.virtualbox.org/virtualbox/rpm/fedora/virtualbox.repo -P /etc/yum.repos.d
yum install -y "VirtualBox-4.* kernel*devel kernel*headers"
/etc/init.d/vboxdrv setup

Hth

NOTE: Alternativly you might want to use DKMS so you dont have to start /etc/init.d/vbixdrv setup after every reboot or kernel update.

solo2101
24th October 2012, 01:09 AM
don't forget the DKMS packets


yum install dkms

devyreham
28th October 2012, 02:07 PM
Also, I found it better to restart the Host after installing each package (DKMS, kernel devel and finally virtualbox).
The same goes with Guest Additions: need to restart Host, then restart Guest