PDA

View Full Version : Grub2 to act like windows?



kiasta
21st October 2012, 06:08 PM
I have Fedora 17 64-bit as my primary and only OS and I would like to know how to automatically boot into linux? Also, if there is a way to only show the boot loader options by pressing a button like with windows and F8? I ask this only because I'm not the only person on this computer and I don't want someone messing with the boot loader and doing something they shouldn't without the need for bios password protect.

I'm not completely new to Linux; I've used it on and off for years, just never as a primary OS until now. But I'm not really that advanced because I've only messed around with it like a fun little toy, until now. I've googled several different ways to ask the question, but I can't even find a single tutorial on how to boot directly to linux without the loader screen. I've seen some suggestions to hack the kernel to boot like the old kernels used to etc. but that is way above my understanding. I don't care about grub being there; I prefer it, in fact. I just don't want it visible unless I press a certain key.

Perhaps someone could show me something that might help? Be it a guide, instructions or whatever. Thanks a lot!

marriedto51
21st October 2012, 06:56 PM
Try editing the file /etc/default/grub (you will need to do this as root) and setting values for the variables GRUB_TIMEOUT, GRUB_HIDDEN_TIMEOUT, and GRUB_HIDDEN_TIMEOUT_QUIET.

For example,

GRUB_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT=2
GRUB_HIDDEN_TIMEOUT_QUIET=true
should make sure the menu is not displayed unless a key is pressed within 2 seconds, but not print any "Press a key to see the menu" message.

I got this from the GNU Grub documentation at http://www.gnu.org/software/grub/manual/html_node/Simple-configuration.html#Simple-configuration.

kiasta
22nd October 2012, 02:23 PM
Alright so I've read that manual but I'm still a bit confused as to how I would change the button to a specified button. The description is not very elaborate... any ideas about that? Thanks so much for the auto-boot that worked fine.