PDA

View Full Version : FC17 Freezes on Boot



zlander79
13th October 2012, 09:28 PM
I have been having issues with Fedora 17 not booting after the latest round of updates. I am able to enter the pass for my disk encryption, the boot logo acts normally but after the animation is complete, the boot fails to progress further.

I checked the diagnostics and it seems that there is an issue in plymouth-quit-wait.service. When I check systemctl status on this service, I am informed that the service has been loaded but timed out when start was attempted.

I have tried disabling the system using systemctl disable plymouth-quit-wait.service with and without the force option, with no success.

I am really lost here, I'm not even sure what exactly isn't working. What can I do to fix this issue, or at least troubleshoot it further?

I'm running FC17 x86-64 on an ASUS G53SW with akmod driver.

secipolla
13th October 2012, 10:43 PM
Can you boot into an older kernel? Or can you boot in this kernel in single user mode?
Either way check /var/log/messages (or archived messages if necessary) to look for some clue.

Also people are having issues with the latest 3.6 kernel and a certain wireless driver.

zlander79
14th October 2012, 02:53 AM
I can boot into TTY2 and TTY3, none of the older kernels seem to work. I'll grab the log and post it.

---------- Post added at 10:47 PM ---------- Previous post was at 10:06 PM ----------

After looking through /var/log/messages I think the issue is with akmods, here are some things I saw:

Client has version 304.57 but kernel has version 304.37.
fedora akmods: Ignoring nvidia-kmod as it failed to build or install
fedora kdm[988]: X server died during startup
fedora kdm[988]: x server for display :0 cannot be started
(previously mentioned issue with plymouth)
TrouSerS failed to find device

The only network related thing I saw was:
fedora networkmanager: failed to allocate [something] cache (can't read my handwriting)

Is this useful at all? I used the command:

su -c 'cat messages | grep "Oct 12" > messagesoct12' to filter the file, I'm not super handy with regular expressions yet so I wasn't able to do any more filtering.

Does this help at all?

---------- Post added 14th October 2012 at 01:24 AM ---------- Previous post was 13th October 2012 at 10:47 PM ----------

So I have a new update. I saw that akmods failed to build so I attempted to force it with:

su -c '/usr/sbin/akmods --force'

It failed again so I checked the build log file and the place it fails at is the cc sanity check, the package is looking for the C compiler command, as 'cc'. As far as I know I've only used 'gcc' for any C needs. If I run "which cc", nothing comes back. Would editing the makefile work, or could I create a symbolic link to gcc under a command cc?

---------- Post added at 01:53 AM ---------- Previous post was at 01:24 AM ----------

Hate to keep adding to this post but:

I tried using:

export cc=gcc

and the build failed again but with a new message about gcc being unable to make objects and that I need to make sure I have the libc development files installed.

So this raises a new question, I can only get access with TTY, which there isn't any internet access for and it doesn't seem to be that I can see any USB drives. How am I to get this libc-development installed?

weitjong
14th October 2012, 04:10 AM
Do you have a working network connection in the virtual terminal? If you do, have you tried just to perform another 'yum update' to pull the corresponding the 'kmod-nvidia' package from rpmfusion repo for your latest kernel (3.6.1). That is, if you believe your boot problem is caused by the akmods build failure. Rather than trying to figure out how to force build, I think it is easier just to install the matching kmod version. And I reckon by now the matching 'kmod-nvidia' package should be available in the closest repo mirror near you already.

If you have problem with wireless connection, just drop back temporarily to a wired connection until you have resolved the boot issue.

zlander79
14th October 2012, 04:12 AM
Will the virtual terminal be able to connect by default to the ethernet port? I've tried to yum the package more than a few times and each time I just get a bunch of curl errors about being unable to connect to anything.

weitjong
14th October 2012, 04:21 AM
It depends on how you get there. If you boot normally (runlevel 5) then you should be able to connect to the internet after switching to a virtual terminal (Ctrl+Altr+Fn) at the point where you think your boot process has frozen. Alternatively, you can pass a boot parameter to grub2 to boot into runlevel 3. This runlevel has the network service started but without a Desktop Environment (DE), i.e. you are in text mode directly.

zlander79
14th October 2012, 04:49 AM
Ah, success, sorta. WJ I followed your advice and I'm back in action. :)

So here is what the problem is (I think):

Akmod starts to update causing the driver to have a new version but the actual nvidia-kmod has the old version. This causes the X server to throw an error and prevents it from starting. This problem stems from akmod being unable to build the corresponding kmod as akmod is unable to find a working compiler.

What remains to be figured out is why akmod is unable to land on a working compiler. I did a check and I have the libc and libc-devel libraries installed and a working C compiler. I've used it to install plenty of things (e.g. MPI, CUDA, ect) as well as my own code. Any ideas there?

Thanks for the help everyone!