PDA

View Full Version : Can't get printer to work in FC16 64bit



pccitizen
9th October 2012, 05:22 PM
FC16 64 bit. Have installed Brother HL2070 printer on 32 bit fedora14 no problem. I add a network printer via IP; it finds it and the queue. It says ipp and cups, I click forward (I can't find a printer driver at brother/linux), so I do generic postscript, point it to file in /usr/share/cups/model CUPS-PDF.PPD. It installs and seems happy and prints.... but it prints multiple blank pages. Have tried many options, always same result. This printing stuff is VERY confusing. Any help?? thanks!!

smr54
9th October 2012, 05:47 PM
There's an HL-2070N at http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html

I would think that would work. As I recall, first download the LPR driver and install that, then install the CUPS driver. Then, run the cups printer setup from the web browser and it should work. I'm going by memory here, but I think that's what I did for my Brothers printer, a 2170W.

marko
9th October 2012, 10:30 PM
linuxprinting.org has it as "mostly working" (note I only found the "N" version, not sure if that's a problem. I was
unable to find any reference to Brother ever having a HL-2070)

http://www.openprinting.org/printer/Brother/Brother-HL-2070N

their suggested driver is the hl1250

http://www.openprinting.org/driver/hl1250

the current 'foomatic-db' package on my system has the file:

/usr/share/foomatic/db/source/driver/hl1250.xml

which seems to support the HL2070N

pccitizen
11th October 2012, 03:54 PM
Really appreciate replies.... Getting a little behind here.
Will post my result this wkend hopefully!
J

David Batson
12th October 2012, 11:54 AM
Maybe this helps: http://forums.fedoraforum.org/showthread.php?t=275665

pccitizen
13th October 2012, 02:47 PM
Well, installing printers is getting better..... I installed the two rpms brhl2070nlpr-2.0.1-1.i386 and cupswrapperHL2070N-2.0.1-1.i386, both from the welcome.solutions.brother.com.
..I could SWEAR I was here before, but was probably completely confused as to what I needed.
This installed the printer as a usb printer. --it popped up in the printer listing GUI!
Changed the URI to network printer, and entered the IP. It found the Q and I applied. all worked.
I must admit, printing support has always been a mystery to me.
Thanks again!!!
John

marko
13th October 2012, 07:32 PM
The system-config-printer tool is pretty good now, if the usb printer is plugged in and you run system-config-printer, it will frequently find it automatically