PDA

View Full Version : Fedora 17 & Galaxy Samsung S3



jnbrunet
6th October 2012, 06:20 AM
Hello,

I just had a hard time trying to access my new Galaxy Samsung SIII with usb. I want to share the solution for people who are as lost as I was some hours ago.

So if you do have a Galaxy Samsung S3, do not give up ! You are at 5 easy steps to get it working.

I'm sorry if I make some gramar or syntax errors, english isn't my primary language.

The problem we get is that the Galaxy Samsung S3 use MTP (Media Transfer Protocol) for the multimedia transfet. In order to get this working, we will using libmtp (the latest version you can get, actually I'm working with the 1.1.5, older probably won't work), and jmtpfs which will mount the phone on a directory.

Alright, here we go.

1. Install requirement


# sudo yum install gcc-c++ fuse-devel libmtp-devel glib-devel glib2-devel file-devel


2. Installing libMTP
- Download the latest version of libmtp and extract it to your home directory. For this example, it will be ~/libmtp-1.1.5


# cd ~/libmtp-1.1.5
# ./configure
# make
# sudo make install


3. Installing jmtpfs


# cd
# wget http://research.jacquette.com/wp-content/uploads/2012/05/jmtpfs-0.3.tar.gz
# tar xfvz jmtpfs-0.3.tar.gz jmtpfs-0.3
# cd jmtpfs-0.3
# ./configure
# cd src
# make
# sudo make install


4. Allowing other with fuse
Edit the file /etc/fuse.conf and uncomment the line

# user_allow_other
to

user_allow_other

5. Mounting the phone !
Now we are ready to mount the phone. Make sure your Samsung Galaxy S3 is connected with a usb cable :)



# mkdir ~/Samsung_Galaxy_S3
# jmtpfs -o allow_other ~/Samsung_Galaxy_S3 (this can take some time (1-2 minutes for me)


You may have a warning after the last command, I get this:



PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device


Just ignore it.

You are now ready.



# cd ~/Samsung_Galaxy_S3
# ls
Phone
# cd Phone
# ls
Alarms DCIM Movies PicSpeed Wallpapers Ringtones
Android Download Music Pictures samsungapps
Application media Notifications Podcasts



For unmounting the phone, be sure closing applications that are in the new mount directory (this include terminal)


fusermount -u ~/Samsung_Galaxy_S3


Thats it !

Hope this help someone...

virason
6th October 2012, 04:04 PM
Thanks for the post.

Having no problem reading the files on the phone but cannot read anything on the sd card although fedora 17 shows there is something there containing audio files when the S3 is connected to usb. Windows correctly identifies the sd card, sees the files on it and can usb transfer to/from without fault.

Anyone else run into this?

hadrons123
6th October 2012, 06:12 PM
Doesnt the exfat-utils and fuse-exfat do the job?

PabloTwo
6th October 2012, 06:34 PM
Unless you are using F15 or earlier, there is no reason to compile libmtp yourself to get the latest version.

BASH:~/-> sudo yum list libmtp
Loaded plugins: langpacks, presto
Installed Packages
libmtp.x86_64 1.1.5-1.fc16 @updates
Available Packages
libmtp.i686 1.1.5-1.fc16 updates
The mtpfs package is another alternative for mounting mtp devices (uses libmtp). Quoted from the README file included with the mtpfs package:

MTPFS
--------

MTPFS is a FUSE filesystem based on libmtp that allows a mtp device
to be browsed as if it were a normal external harddisk

Requirements
------------

FUSE >= 2.2
GLib >= 2.30
libmtp >= 1.1.2

How to mount a filesystem
-------------------------

To mount a device run:

mtpfs <mount_point>

To unmount do:

fusermount -u <mount_point>

Note that you may need to be root to do all this if permissions on the
MTP device are not correct
---<snip>---

binarynut
16th December 2012, 05:22 PM
How and what files would I need to edit to get the S2 to work .
jmtpfs compiled and installed okay in F17/S2, but when I did a ;

jmtpfs -o allow_other ~/Samsung_Galaxy_S2
Device 0 (VID=04e8 and PID=6866) is UNKNOWN.
Please report this VID/PID and the device model to the libmtp development team
Segmentation fault (core dumped)

smr54
30th December 2012, 05:54 AM
For what it's worth, I was just able to use the go-mtpfs binary to get to my Galaxy SIII. I grabbed the latest binary for amd64, then ran it, and got a message that the usage was mtpfs <mountpoint>

So ran sudo mtpfs /mnt and the files in the device were visible with a ls /mnt.

I was also able to get Ubuntu 12.04 to mount it--installed the various mtpfs packages (I'm not sure which) and it would, when I plugged in the phone, enable me to browse it. I was able to view files on the external SD card that I plugged in, but not do anything with them. If I wanted to, for example, move an epub into the nook app, I could do so from my computer to the phone, but not, (using the Ubuntu file browser) from SD card to the phone (or from SD card to the computer.) I was able to move the file around the phone from SD card and back by using the ES Explorer. There may be easier ways, but that was one of the first that came up in a google search.

I should add that I was doing this in console (as opposed to X) and some googling has indicated that if you're using Gnome, its attempts to automount might cause problems with the go-mtpfs, but I don't know. In Ubuntu, I couldn't get the go-mtpfs to work properly, which might be because Unity was already doing its thing as soon as I'd installed the various mtp stuff.

Anyway, doable--judging from the booklet that came with the phone, probably more easily done on Windows and Apple, but, at least on Ubuntu and Fedora, doable enough to use.

smr54
30th December 2012, 09:26 PM
Ok, after a lot of playing around, I've come up with these results fairly consistently.

On Ubuntu the phone will show up if I plug it in, and I can browse it. I'm not entirely sure which programs I wound up adding that fixed it so it would do that, probably all the mtp programs available. However, at that point, I hadn't realized that it's non-trivial, so I didn't check that hard.

I can do this, but, if I have the external SD card in there, I can't copy files to or, oddly enough, from it, nor can I move them around from, for example, the card to the Nook app's directory for side loaded epubs.

On Fedora, I found that that simple-mtpfs is working pretty well. (Fedora 18). This is command line, and after installing it, I can plug in the phone, then, as root, type simple-mtpfs /mnt and the phone's files will be visible in /mnt. In this case, if I put the card in , it shows up as a separate directory under /mnt, called, oddly enough Card. I am able to freely manipulate files with this, that is, move a movie into the phone's Movies directory, move something on or off the SD card, and so on.

On the phone itself, I installed the free ES File Explorer. Another way to move around files is to put them on the SD card, then put the card in the phone then use this explorer app to copy the file from the card and put it where I want. I've really only done this with a couple of videos my wife made and a DRM free epub--so, I put the videos into Movies and the epub into my Nook app's MyDocuments or whatever it's called.

As I understand it, there is some theoretical advantage to the MTPfs thing, but apparently not working all that transparently with anything but Windows yet--for example, my wife's Mac doesn't see it. My main CentOS machine doesn't work with it, but the laptops have Fedora and Ubuntu, so it's not a big deal.

virason
1st January 2013, 08:09 PM
Rechecked the mounts after latest f17 update and both directories are now mounted as gphoto2://[usb:002,009]/store_00010001 and gphoto2://[usb:002,009]/store_00020002 and auto open in Files so it appears the problem has been fixed at least for this Samsunger..

Cheers :D

tankist02
2nd January 2013, 11:23 PM
Here is a simple method that works perfectly for Nexus 7 and Galaxy Note on F17 and 18:




sudo yum install simple-mtpfs
mkdir -p ~/mnt/nexus
simple-mtpfs ~/mnt/nexus
...
fusermount -u ~/mnt/nexus

addnab
7th January 2013, 09:20 AM
You are a hero. I've been trying to use mtpfs with no luck. Didn't know there was something like jmtpfs. Any idea how to automate once i connect the usb?

binarynut
8th January 2013, 02:14 AM
sudo yum install simple-mtpfs
mkdir -p ~/mnt/nexus
simple-mtpfs ~/mnt/nexus
...
fusermount -u ~/mnt/nexus


do I run these commands to be installed in /root/mnt/nexus
or
/user directory ~/mnt/nexus

I understand the directories are to be created in /root/mnt/nexus .

# fusermount -u ~/mnt/nexus is not mounting /root/mnt/nexus .

wsteward
23rd December 2013, 02:30 PM
For us new smart phone users don't forget to change the USB connect protocol in the Galaxy Samsung S3. The simple-mtpfs works much better when the USB connection protocol is set to MTP from the default PTP.

marklf
19th February 2014, 07:40 AM
Here is a simple method that works perfectly for Nexus 7 and Galaxy Note on F17 and 18:




sudo yum install simple-mtpfs
mkdir -p ~/mnt/nexus
simple-mtpfs ~/mnt/nexus
...
fusermount -u ~/mnt/nexus



Thanks! You save me from days of searching and trying!

OzzYGuY
8th March 2014, 01:50 PM
Just for the record, each time i fresh install Fedora and want to access any of my samsung phones or tablets, i issue the following command :-

sudo yum install gvfs-mtp

Log out, and back in again....and have phone listed in thunar straight away.
Can read / write to both internal and external storage.

Cheers,

OzzY