PDA

View Full Version : ELO 1515L on FC 17



taquinas
5th October 2012, 01:38 AM
I have a ELO 1515L. I would like it to run consistently on FC 17.
AFTER BOOT, I can run
loadEloTouchUSB.sh and elova (which calibrates the screen) and then
all works well. However, I am doing this for a partially blind family
member and I would like this to work without being a Fedora afficionado..

After running these, it works. I cannot find rc.local and
tried to run the loadEloTouchUSB.sh in /etc/rc.d/rc.local
but it does not seem to work there.

Does anyone have this working?
How do you "save" the calibration so it does not have to be done
more than once.

Thanks!!

---------- Post added at 08:38 PM ---------- Previous post was at 05:37 PM ----------

Got it.
for FC16, 17 (I guess 18)
rc.local lives in the /etc/rc.d
directory.

It is way persnickity now. IF you do not have the
functions and the start and stop
it pukes.

To get elo to work
do the
loadEloTouchUSB.sh and elova
as root one time in the window environment
or the sudo loadEloTouchUSB.sh
and
sudo elova
where you are in the sudoers
file.

Also
make a new group "touchscreen" or something like that
put users of the touchscreen in that group.

chgrp -R touchscreen in the /etc/opt/elo-usb
and
chmod 0775 the executables in that directory.

once I fixed up the rc.local - all worked automagically.