PDA

View Full Version : Shutdown / power off problems



PrzemoF
4th October 2012, 11:19 AM
I have some problems with "Power Off" - it doesn't work but instead goes back to login screen. 'sudo shutdown -h now' works fine. I'm using gnome-shell

kernel: 3.6.0-2.fc18.x86_64
gdm: 3.6.0 1.fc18
gnome-shell: 3.6.0 1.fc18

Any hints how to diagnose that?

nonamedotc
4th October 2012, 05:15 PM
Is the system fully updated? There was a SELinux policy update and a systemd update that is supposed to fix the shutdown problem.

Take a look at these

http://lists.fedoraproject.org/pipermail/test/2012-October/110503.html
http://lists.fedoraproject.org/pipermail/test/2012-October/110587.html
http://lists.fedoraproject.org/pipermail/test/2012-October/110607.html

PrzemoF
4th October 2012, 05:36 PM
Yes, I run yum update daily.

I have sytemd-193 and selinux-polisy-3.11.1-25

I used a custom build kernel for a while and selinux was rebuilding database after it, but I'm not sure if it can be the reason.

I just tested the custom kernel (3.6-rc7) and power off works OK.

(booting fedora 3.6-rc7 now, but it's gonna take ages - sellinux again)

I'll try reboot with enforcing=0 next.
[some time later]
enforcing=0 fixes the problem, so I'll stick to it for now.
Thanks for help!

richk
4th October 2012, 06:32 PM
kdm defines shutdown under halt as /sbin/shutdown -h -P now

your desktop environment probably has a similiar settings.

PrzemoF
5th October 2012, 09:32 AM
Thanks for suggestion - I tried to find it, but I couldn't.

richk
5th October 2012, 06:26 PM
what I meant was to go to kde system settings -> login screen -> Shutdown

there will be two commands windows halt and reboot.

at the bottom is a button for defaults hit then apply

richk

PrzemoF
5th October 2012, 08:06 PM
I have gnome/gdm

AdamW
6th October 2012, 06:17 AM
you need systemd 194. once you have that the issue should be resolved.

PrzemoF
8th October 2012, 07:43 PM
Thanks AdamW! I'm on 194 now and it works fine! :)