PDA

View Full Version : install NVIDIA Binary drivers fedora 16 (my way and worked for me)



mokos
27th September 2012, 12:59 PM
first of all download from NVIDIA your driver and it should be put on the folder Downloads in your system
1. open terminal and write su and your pass
2. service prefdm stop
3.press ctl+alt+F5 and in the black screen login (mine root and pass press enter and write su and pass)
4.type cd Downloads press enter
5. type sh (name of your NVIDIA file).run
6. the installer says to install the binutils so exit the installer and type yum install binutils press enter
7.if you run the nvidia installer again it says than the nouveau driver is running and it fails the setup BUT the installer writes a script in your modprobe folder in order to disable on the next reboot
8. reboot system
9.on the login screen do the step 3 and type service prefdm stop again step 3 login on the black terminal screen both account and su
10. yum install kernel* selinux-policy* after the installation try to run the (NVIDIA file).run again if it fails (saying that the nouveau driver is on) do the reboot if it fails saying that there isnt any cc compiler thats good news!! anyway do the step 12 as it says
11. on the login screen do the step 3, type service prefdm stop and run the nvidia installer this time (it did in my pc) the installer failed to do the setup but it said there isnt any cc compiler
12. yum install kernel-devel gcc after the installation run for the last time the nvidia installer and it works!!! (it did for me...) after its done!
13.type service prefdm start , login in the login screen and go on the activities on the top left screen and check for the green icon of NVIDIA X Server Settings if you open it it says the same version of the driver as the binary NVIDIA code you ' ve downloaded!!! :P good luck!!

the same process it works on fedora 17
on the x86_64 systems runing the NVIDIA installer on the last step on some point of the procedure it says install 32bit libraries choose yes!!! and it works !!! good luck!! i hope i didnt give you a headache...