PDA

View Full Version : Accidental suspend --> unbootable



mjrice
13th September 2012, 05:05 PM
I just accidentally "suspended" Fedora, waited for all the lights to go out (and then some) and restored power to find neither of my HDs (Windows 7 & Fedora 16) would boot. In addition, pre-boot screens had screwed up graphics. Shut it down, tried again, same thing. Unplugged system for about a minute, and tried again. This time no screwed up graphics, so booted into Windows. Windows does repairs, restarts, and boots normally. Restart to Fedora, which boots normally. What would cause something like this?

Michael

hadrons123
13th September 2012, 06:54 PM
Strange, its bound to happen on both Windows and linux.

If possible look for /var/log/messages

mjrice
13th September 2012, 08:58 PM
Will do, and post back. In Windows right now.

---------- Post added at 03:58 PM ---------- Previous post was at 03:05 PM ----------

For what it's worth, messages file is attached.

Don't know that it will be much help. Both OSes booted to just a black screen. The only repairs were done by Windows. After that, Fedora booted normally.

Michael

bendib
13th September 2012, 11:09 PM
Windows repaired it's own filesystem and fedora, being on ext4 or btrfs I assume, silently and transparently fixed it's own issues.

george_toolan
14th September 2012, 10:00 AM
Was the windows partition mounted when you suspended?

mjrice
14th September 2012, 01:50 PM
Well, I just clicked on the Windows HD and it asked me for authorization to mount it. When I declined, I got the message that it wasn't mounted. So I guess the answer to your question is no, it wasn't mounted.

By the way, I'm on a desktop, so I don't normally (just accidentally) suspend, and wish it wasn't so easy to do it accidentally. Is there a standard way to proceed after I do accidentally suspend. I just power up again, which is what I did when this incident occurred.

Michael