PDA

View Full Version : Best way to install xwin through ssh?



powerskier
30th November 2004, 12:07 AM
Hello,

I've been using a FC2 system for a couple months administering the system through SSH (located in a different town). I did not originally install xwin on the system because it was only used for a temp webserver etc. The program that I need to use 'vec2web' needs to be able to connect to the X Server.

I've tried 'yum install xorg-x11' but it didn't seem to install all the required files.

Any suggestions ?

Thanks! :)

pigpen
30th November 2004, 06:17 PM
hi! why not use ssh's x forwarding? or are you using the same box as your desktop machine now?

powerskier
30th November 2004, 07:15 PM
Thanks for the reply,

My problem is that I don't have X installed on the box at all. I already have FC2 installed and am trying to figure out how to install X through SSH since I can't get to the box location.

Any suggestions ? :)

ilja
30th November 2004, 08:27 PM
yum groupinstall xorg-x11

try this.

pigpen
30th November 2004, 08:35 PM
You don't need to have an X server installed on the box to run X applications. X is network transparent.
Any linux box with X server or Windows box with e.g. Cygwin's X server will do. Just use ssh's X forwarding. Or does you app need X headers to compile?
@ilja: Do groupinstalls work in FC2?

ilja
30th November 2004, 08:36 PM
I never tried it in Fc3, but in Fc2 it worked fine for me.

pigpen
30th November 2004, 08:45 PM
Ok, then I've probably messed up my yum.conf ;)

ilja
30th November 2004, 08:46 PM
Ok, then I've probably messed up my yum.conf ;)
Not every repository provides the files needed for groupinstall. AFAIR the one in Karl-Marx-Stadt ;) does.

pigpen
30th November 2004, 09:30 PM
I see... I think I use the Esslingen mirror (Can't think of a funny name for Esslingen, though ;-)

powerskier
30th November 2004, 09:35 PM
The program that i am trying to run is a console application but uses the QT toolkit for unicode support etc. It will only run if the program can connect to a running X11 server.

So ' yum groupinstall xorg-x11 ' should do the trick?

ilja
30th November 2004, 09:42 PM
if you need qt, then maybe
yum groupinstall kde
is even better.

powerskier
30th November 2004, 09:49 PM
hrmmm I keep getting the error: 'No groups provided or accessible on any server' with yum...

Should i just keep trying different servers ?


Thanks !!

ilja
30th November 2004, 09:54 PM
Yes, try a different server.

powerskier
30th November 2004, 11:28 PM
Thanks for the tip, yum seems to have installed the xwindows system with the group install.

Is there anyway to check to see if it is working? I tried 'startx' and it just hangs because i'm connected through ssh. Also when i try the console program that required x server to be running, it just hangs as well?

Any suggestions? I'm running sort of blind on this one... Thanks!!!

pigpen
1st December 2004, 12:28 AM
Once again... you have 2 (actually even more) options to run X apps remotely:

1) VNC (execute 'vncserver' on the remote machine, then use 'vncviewer' on the local)
2) the aforementioned X server running on the machine you're connecting from
(_not_ on the remote box!!!). use 'ssh -X host' to log into the remote machine with X11 forwarding enabled.

Google for how-tos on the two options should you be new to VNC and/or SSH.
Good luck

crackers
1st December 2004, 05:03 AM
Try this:
[code]
[localsystem] $ ssh -Y
(login)
[remotesystem] $ xterm &
[code]
You should have a fresh terminal pop up on your system.