PDA

View Full Version : F17 Running steam under WINE



heyub
1st August 2012, 12:00 AM
Steam itself runs fine, however when I try to run Terraria I get the following error.


system.typeinitializationexception: An exception was thrown by the type initializer from microsoft.xna.framework.graphicsadapter---> system.IO.filenotfoundexception: failed to load d3dx9_41.dll. Please verify that you have the XNA framework installed.

I also noticed SELinux Alert Browser popped up

Source process: wine-preloader
Attempted this access: mmap_zero

Camberwell
1st August 2012, 12:15 AM
looks like you havn't got directx install, have you got winetricks?

that should do it for you

heyub
1st August 2012, 01:15 AM
When I launched the game from steam it installed directX, perhaps it did not install correctly. I just installed winetricks and it has proven to be tricky. After an hour I'm still not sure how to use it, I'll have to try again later.

heyub
10th August 2012, 11:34 PM
I reinstalled directX9 using winetricks, and also downloaded the XNA and .Net frameworks. I get the same error.
Edit: Checked video drivers, all up to date. Same error "failed to load d3dx9_41.dll"