PDA

View Full Version : [SOLVED] Dell Inspiron 5520 Wifi not working



jawadjee
17th July 2012, 08:50 AM
Hi,

I bought Dell Inspiron 15R (5520). It comes with Dell Wireless 1704. The chipset is Broadcom 4365. Following is the output for lscpi -vnn

02:00.0 Network controller [0280]: Broadcom Corporation Device [14e4:4365] (rev 01)
Subsystem: Dell Device [1028:0016]
Flags: bus master, fast devsel, latency 0, IRQ 11
Memory at c0500000 (64-bit, non-prefetchable) [size=32K]
Capabilities: [40] Power Management version 3
Capabilities: [58] Vendor Specific Information: Len=78 <?>
Capabilities: [48] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [d0] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [13c] Virtual Channel
Capabilities: [160] Device Serial Number 00-00-85-ff-ff-b8-c0-18
Capabilities: [16c] Power Budgeting <?>

I am using fedora 17 with b43-openfwwf package. It is not detecting the card. I guess this card is not supported.

I tried Broadcom driver and the card is still not detected.

How can I make it work?

mandarkhanolkar
25th August 2012, 09:04 AM
Hi

Do you have this problem resolved? Did you find driver working for Wireless Broadcom 4365 on your Dell Inspiron 115R 5520?
I am also facing the same issue and could not find working solution.
My fedora release is 17.

Any help is much appreciated?

Thanks.
mandar

PabloTwo
27th August 2012, 06:21 PM
I've been looking at "desktop replacement" class laptops with 17" screens to replace the old Dell XPS 170M that has developed issues with the graphics memory chips (puts artifacts on screen). One of my prime candidates has been another Dell (i17R series). It's one Linux friendly flaw is the Dell Wireless 1704 wireless/bluetooth chipset from Broadcom. Searching for possible solutions for that led me to one possible, though untried, solution for Fedora.

There is a .deb package file with a Linux driver for that chipset. From what I read, the driver was originally created by Dell and included with a Vostro series laptop that Dell sold with some flavor of Ubuntu installed. Here is a link (http://askubuntu.com/questions/178352/broadcom-4365-wireless-driver-on-12-04-with-3-4-3-5-kernel) to a askUbuntu page that contains a link to a dropbox download of that .deb package:

wireless-bcm43142-dkms-6.20.55.19_amd64.deb

Of course, this is intended to be installed into Ubuntu, and certainly won't work if installed directly into Fedora, but the source code and Makefile to compile the kernel module driver are included in the package. You can extract the package contents into a folder in your $HOME, then cd down into the directory where the Makefile is located and then compile the same as you would any other source code tarball.

To extract the package, you'll need to first "yum install dpkg"
Make a folder to extract into, example: "mkdir BCM43142"
Extract the .deb package into that folder: "dpkg-deb -x Downloads/wireless-bcm43142-dkms-6.20.55.19_amd64.deb BCM43142"
cd to the source code: "cd BCM43142/usr/src/wireless-bcm43142-oneiric-dkms-6.20.55.19~bdcom0602.0400.1000.0400/"
Then just issue the "make" command.

You'll need the usual compiling tools.... gcc, kernel-devel, etc. I gave it a preliminary test compile after installing the kernel-devel package and hit a missing dependency.... "asm/system.h". Unfortunately, the current Fedora kernel-devel packages don't include that, but doing:

"yum provides */asm/system.h" will show what packages you can install that will provide that. Since I haven't tested that far yet, I can't say what, if any, other deps might stop the show, but it's probably worth the effort to try this (especially if you actually own a laptop using wireless that requires this driver) to see if you can get this to fly. If you manage to successfully compile the module, then you'd either need to run, as root, "make install", or do it manually.

jawadjee
28th August 2012, 12:05 PM
Thanks PabloTwo,

Finally with your help, my wireless card is functioning now. Following are the steps I followed:

1) Download the file from the link (http://askubuntu.com/questions/178352/broadcom-4365-wireless-driver-on-12-04-with-3-4-3-5-kernel)

2) sudo yum install dpkg

3) mkdir BCM43142

4) dpkg-deb -x Downloads/wireless-bcm43142-dkms-6.20.55.19_amd64.deb BCM43142

5) cd BCM43142/usr/src/wireless-bcm43142-oneiric-dkms-6.20.55.19~bdcom0602.0400.1000.0400/src/wl/sys

6) sudo yum install kernel-devel kernel-headers

7) vi wl_linux.c

8)
around line 43, remove the line
#include <asm/system.h>

9) save the file (:wq)

10) cd ../../..

11) make

Things should work, and you'll have a file called "wl.ko" in the current directory.

12) sudo yum remove broadcom-wl

13) sudo mkdir -p /lib/modules/3.5.2-3.fc17.x86_64/extra/wl

14) sudo cp wl.ko /lib/modules/3.5.2-3.fc17.x86_64/extra/wl

15) sudo depmod -a

16) sudo modprobe wl

Voila! My wireless is working.

lshw -C network output:

================================================== ========
*-network
description: Wireless interface
product: Broadcom Corporation
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:02:00.0
logical name: eth0
version: 01
serial: c0:18:85:b8:2d:1d
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=wl0 driverversion=6.20.55.19 (r300276) ip=192.168.1.110 latency=0 multicast=yes wireless=IEEE 802.11abg
resources: irq:17 memory:c0500000-c0507fff
================================================== =========

I hope this helps.

PabloTwo
28th August 2012, 07:31 PM
That's great that you got that working on your system. Your lshw report shows "wireless=IEEE 802.11abg", no "n", which the newer 1704 chipsets support. I suppose this driver is a bit "dated". But even if you're only able to get "g" speeds with it, that's better than no connection at all.

And from your original post, you said "I tried Broadcom driver and the card is still not detected.". I presume you mean the kmod-wl driver from the rpmfusion-nonfree repo?

jawadjee
29th August 2012, 03:07 PM
Yes that is kinda strange. The driver has no wireless N support. Driver version 5.100.82 has Wireless N support and 6.20 is without it.

Yes you assumption is also right about my original post statement.

Lets hope some better solution become available soon. For the time being it could be a workaround we can use.

stoat
29th August 2012, 03:27 PM
.
.
Nice.




Lets hope some better solution become available soon.If that chipset becomes more and more common, I'm sure something eventually will happen to make it easier to install. Anyway, that's what has often occurred in the past with new Broadcom chipsets.




For the time being it could be a workaround we can use.jawadjee, I nominate you to create a little HOWTO in the Guides and Solutions sub-forum. It will make it easier for other people who also need that information to find it. You've already done it, practically. Just copy those steps. But forget about the computer model number. It's the Broadcom chipset number that mostly will matter to other people. Mention that in the title instead.

It's up to you, of course.

PabloTwo
29th August 2012, 07:50 PM
Yes that is kinda strange. The driver has no wireless N support. Driver version 5.100.82 has Wireless N support and 6.20 is without it.
I believe the driver version number on this package is misleading, and that the actual version of driver being compiled in this package is much older. Along the way to finding this .deb package, on one thread that led me to it, it was explained, somewhat briefly, that the packager took a current deb package that was dysfunctional with the current "Dell Wireless 1704" chipsets, and repackaged it by replacing the source code bits with the source code bits that were included in a package that Dell shipped with some Vostro laptop with Ubuntu installed some time ago.

It's very well likely the driver in this package dates to pre-N, or perhaps when there was just "draft N", or when "N" was somewhere out there on the horizon. I don't really know for sure, but that's the jest of what I deduced from the comments in a thread that pointed me to the download site. Note also, this is a Ubuntu user made package, not anything "official" from any flavor or release of Ubuntu. I don't easily find a link to the post/thread where I gleaned this information, but if you search and follow enough links in threads, you may come across it.

If you post a guide, I'd suggest changing this:

13) sudo mkdir -p /lib/modules/3.5.2-3.fc17.x86_64/extra/wl

to this:

13) sudo mkdir -p /lib/modules/$(uname -r)/extra/wl

That way, the users current working kernel will be invoked, instead of some clueless newbie just blindly copy and pasting from the guide, and specifying the wrong kernel version and/or arch.

mandarkhanolkar
30th August 2012, 04:13 PM
Great. It worked for me too.
Thank you Pablo for guiding on this problem and jawadjee for well documenting configuration steps.

thanks.

H0wdy
29th November 2012, 06:36 AM
This did not work for me:

However, because of this error:

[ 14.154407] iwlwifi 0000:02:00.0: request for firmware file 'iwlwifi-2030-6.ucode' failed.
[ 14.154847] iwlwifi 0000:02:00.0: request for firmware file 'iwlwifi-2030-5.ucode' failed.
[ 14.154851] iwlwifi 0000:02:00.0: no suitable firmware found!

From dmesg...


This did:

http://www.intellinuxwireless.org/?n=Downloads

Copy the appropriate download to /lib/firmware and you should be good to go with iwlwifi

mandarkhanolkar
24th March 2013, 04:36 PM
Could anyone make this device driver compile & working on 3.8.3-103.fc17.x86_64 kernel?

Thanks.
Mandar

RayMikkelson
14th June 2013, 10:19 PM
I have just done what you asked (make the code changes needed for a 3.8.13-100.fc17.x86_64 kernel). I'm not sure what the best way is to provide the changes to a 2665 line C file -- I don't want to include the entire file here. However, I think it's obvious what I did from below (bold code is what I added/changed; the old/previous code is unbolded and included in the else part of the #ifdef's):

After the initial comment block at the top of the file usr/src/wireless-bcm43142-6.20.55.19/src/wl/sys/wl_cfg80211.c (all the changes below are in that file):

/* REM added 6/14/13 to support new kernel header file changes */
#define KERNEL_3_8_13 TRUE


Around line #715:

#ifdef KERNEL_3_8_13
wl_ch_to_chanspec(params->chandef.chan,
&join_params, &join_params_size);
#else
wl_ch_to_chanspec(params->channel, &join_params, &join_params_size);
#endif



Around line #2002 (my line numbers might be slightly off since I don't have the original to refer to any longer):

#ifdef KERNEL_3_8_13
ie = bss->ies->data;
ie_len = bss->ies->len;
#else
ie = bss->information_elements;
ie_len = bss->len_information_elements;
#endif

NVieville
29th June 2013, 04:02 PM
Hello,

Maybe you should give a try to the packages proposed here:

https://bugzilla.rpmfusion.org/show_bug.cgi?id=2721#c47

Both of them are needed in order to get the akmod package to work. The akmod package also contains the src.rpm package needed in case you want to modify/build it to for F-17.
Sorry, but these packages don't contain the patch needed for kernel 3.10.xx already, but available here (some adaptation may be needed):

https://bazaar.launchpad.net/~ubuntu-branches/ubuntu/saucy/bcmwl/saucy/files/head:/debian/patches/

Cordially,


--
NVieville

mandarkhanolkar
23rd December 2013, 12:13 PM
Later I had not updated status on my BCM43142 problem here. But it worked with the solution provided by NVieville. Thanks a lot.

Mandar