PDA

View Full Version : Nvidia libglx causes segfault on X startup



mathteacher
17th July 2012, 04:28 AM
I just upgraded my laptop from F16 to F17 using preupgrade. It seemed to be working fine across several reboots, but this morning the boot sequence started to fail on X startup. X seems to be the only problem; I can switch VCs and work on the command line just fine. The logs show the problem to be a segfault when X is trying to load the libglx.so from the nvidia (not nouveau) drivers. By removing the libglx.so from the search path, I can get X to start, but of course without the capabilities of the glx extension.

I did not change any configuration between the last time fully successful (i.e. non segfaulting and GLX crippled) startup and the first time I so the segfault error. The only lead I have is that the successful boots were on my home network and at a hotel with completely open wifi; the segfaults began after I checked into a hotel with a captive portal that forces you to agree to terms of use before it will route traffic to the internet at large. I can't imagine why a lack of internet access should cause X to segfault, so I suspect this is a red herring, but as I can say it is the only variable I know of that changed.

Any ideas? Thanks.

F17
Kernel 3.4.4-5 i686
Nvidia kmod/libs 295.59
NVIDIA GPU GeForce 9300M GS

tromas
24th November 2012, 09:47 PM
Hi!
I just updated my sys with preupgrade and ended up in the same box.

[ 5923.543] Backtrace:
[ 5923.543] 0: /usr/bin/Xorg (xorg_backtrace+0x36) [0x4652d6]
[ 5923.543] 1: /usr/bin/Xorg (0x400000+0x6a2b9) [0x46a2b9]
[ 5923.543] 2: /lib64/libpthread.so.0 (0x36f6e00000+0xefe0) [0x36f6e0efe0]
[ 5923.543]
[ 5923.544] Segmentation fault at address (nil)
[ 5923.544]
Fatal server error:
[ 5923.544] Caught signal 11 (Segmentation fault). Server aborting

If i login as myself on the server X loads in various grades, craches and brings me back to the GUI login prompt.

Logging in as my wife, which is equivalent to logging in as a new user ;-) KDE plasma + plasma failsafe gives the same result
XBMC results in failure due to requirements on glx

Gnome however loads, though gnome3 informs me about fallback due to no accelerated graphics.

Question!
1) did u manage to slov the problem, and if thats the case how?
2) how did you exclude the glxlib from the path?

secipolla
25th November 2012, 12:50 AM
Check http://forums.fedoraforum.org/showthread.php?t=280750

Have you completely updated everything? What do you have in /etc/X11/xorg.conf.d?

tromas
25th November 2012, 01:30 PM
Yes I update with;
preupgrade
package-cleanup --orphans
yum distro-sync
yum -y update
------
I added rdblacklist=nouveau to /etc/default/grub and updated grub with grub2-mkconfig -o /boot/grub2/grub.cfg.
------
The odd thing is that the segfault stopped occuring. I managed to get into KDE but without accelerated graphics.

noted this in dmesg
[ 12.001764] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 304.64 Tue Oct 30 10:58:20 PDT 2012
[ 26.654323] NVRM: Your system is not currently configured to drive a VGA console
[ 26.654326] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
[ 26.654327] NVRM: requires the use of a text-mode VGA console. Use of other console
[ 26.654328] NVRM: drivers including, but not limited to, vesafb, may result in
[ 26.654329] NVRM: corruption and stability problems, and is not supported.
---------------
/etc/X11/xorg.conf.d holds 2 files

xorg.conf.d]# cat 00-nvidia.conf
#This file is provided by xorg-x11-drv-nvidia
#Do not edit

Section "Files"
ModulePath "/usr/lib64/nvidia/xorg"
ModulePath "/usr/lib64/xorg/modules"
EndSection
[xorg.conf.d]# cat 00-system-setup-keyboard.conf
# This file is autogenerated by system-setup-keyboard. Any
# modifications will be lost.

Section "InputClass"
Identifier "system-setup-keyboard"
MatchIsKeyboard "on"
Option "XkbModel" "pc105"
Option "XkbLayout" "se"
# Option "XkbVariant" "(null)"
Option "XkbOptions" "terminate:ctrl_alt_bksp,"
EndSection


-----

rpm -qa *\nvidia\* *\kernel\*|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat /etc/X11/xorg.conf
abrt-addon-kerneloops-2.0.18-1.fc17.x86_64
kernel-3.6.1-1.fc17.x86_64
kernel-3.6.7-4.fc17.x86_64
kernel-debug-3.6.1-1.fc17.x86_64
kernel-debug-3.6.7-4.fc17.x86_64
kernel-debug-devel-3.6.1-1.fc17.x86_64
kernel-debug-devel-3.6.7-4.fc17.x86_64
kernel-debuginfo-3.6.7-4.fc17.x86_64
kernel-debuginfo-common-x86_64-3.6.7-4.fc17.x86_64
kernel-devel-3.6.1-1.fc17.x86_64
kernel-devel-3.6.7-4.fc17.x86_64
kernel-headers-3.6.7-4.fc17.x86_64
kernel-tools-3.6.7-4.fc17.x86_64
kernel-tools-libs-3.6.7-4.fc17.x86_64
kmod-nvidia-2.6.43.2-6.fc15.x86_64-280.13-4.fc15.3.x86_64
kmod-nvidia-2.6.43.5-2.fc15.x86_64-280.13-4.fc15.5.x86_64
kmod-nvidia-2.6.43.8-1.fc15.x86_64-280.13-4.fc15.6.x86_64
kmod-nvidia-304.64-1.fc17.x86_64
kmod-nvidia-3.6.1-1.fc17.x86_64-304.51-1.fc17.x86_64
kmod-nvidia-3.6.7-4.fc17.x86_64-304.64-1.fc17.x86_64
libreport-plugin-kerneloops-2.0.18-1.fc17.x86_64
nvidia-settings-1.0-22.fc17.x86_64
nvidia-xconfig-1.0-20.fc17.x86_64
xorg-x11-drv-nvidia-304.64-1.fc17.x86_64
xorg-x11-drv-nvidia-libs-304.64-1.fc17.x86_64
3.6.7-4.fc17.x86_64
nvidia 11283757 24
i2c_core 38314 11 i2c_i801,tuner,saa7134_dvb,saa7134,tda8290,tda827x ,nvidia,v4l2_common,tveeprom,tda1004x,videodev
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 304.60 (mockbuild@) Thu Oct 25 17:46:49 CEST 2012

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 260.19.29 (mockbuild@hephaestus.wilsonet.com) Thu Dec 16 04:43:59 EST 2010

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
FontPath "/usr/share/fonts/default/Type1"
EndSection

Section "ServerFlags"
Option "DontZap" "false"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout" "se"
Option "XkbModel" "pc105"
Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

Section "Monitor"

# HorizSync source: xconfig, VertRefresh source: xconfig
Identifier "Monitor0"
VendorName "Unknown"
ModelName "CRT-1"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 60.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GT 240"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "CRT: 1600x1200 +4480+400, DFP-0: nvidia-auto-select +1920+0, DFP-2: 1920x1200 +0+400"
SubSection "Display"
Depth 24
EndSubSection
EndSection

secipolla
25th November 2012, 01:39 PM
Look, I'm no specialist, far from that.

The dmesg thing you posted is harmless.
Remove your xorg.conf and restore the one provided by the driver package (usually /etc/X11/nvidia-xorg.conf; copy it to xorg.conf)

tromas
25th November 2012, 03:10 PM
Good thinking.

I reverted back to the original which reads;
# RPM Fusion - nvidia-xorg.conf
#
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

Then i used nvidia-settings and re-configured.