PDA

View Full Version : [SOLVED] Teamspeak 3 and Fedora 17



techabyte
9th July 2012, 10:59 AM
Hey guys been trying to google search for this before posting and I dont think I found a solution for this.

I unziped the latest TS3 client.

But when I try to run


./ts3client_runscript.sh

i get this error


error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

the .sh file contains..


#!/bin/bash

export KDEDIRS=
export KDEDIR=
export QTDIR=.
export QT_PLUGIN_PATH=.
export LD_LIBRARY_PATH=".:$LD_LIBRARY_PATH"

D1=$(readlink -f "$0")
D2=$(dirname "${D1}")
cd "${D2}"

if [ -e ts3client_linux_x86 ]; then
./ts3client_linux_x86 $@
else
./ts3client_linux_amd64 $@
fi

SteveGYBE
9th July 2012, 03:44 PM
First check whether it is on your machine - I already had it
$ locate */libpng12.so.0
/usr/lib/libpng12.so.0If it is already installed on your machine, then change the "LD_LIBRARY_PATH" line in the shell script to
export LD_LIBRARY_PATH="/usr/lib:.:$LD_LIBRARY_PATH"Or the path where libpng12.so.0 is located, if different.

If you don't have libpng12.so.0 installed, you can use Yum to find a package providiing it
# yum provides */libpng12.so.0
2:libpng-compat-1.5.10-1.fc17.i686 : Temporary backwards-compatibility copy of old libpng
Repo : fedora
Matched from:
Filename : /usr/lib/libpng12.so.You can then install the package indicated
# yum install libpng-compat

techabyte
10th July 2012, 12:07 AM
Thanks mate I will give this a shot once I get home and update the post to solved once I've given it a shot