PDA

View Full Version : input/output error



papori
3rd July 2012, 09:23 AM
Hi all,
i am getting this error when using a regular commands as "cut" , "sort" and so on..
i found somewhere that it might cause by disk crushing..
Can i fix it?
How can i be sure what is my problem?
checkdisk?

Thanks

george_toolan
3rd July 2012, 09:50 AM
What exactly are you trying to do?

What is the error message?

Also check /var/log/messages

papori
3rd July 2012, 10:07 AM
Actually i am sorry.. i didnt notice that i am in fedora forums..
(i am regular to use fedora.)
But, at office i have also ubuntu machines... so, my problem is in ubuntu..
And, there isnt /var/log/massage..

What i was trying to do is:
i have text file, and i just want to
cut -c5-10 input > output

very simple command that worked until recently..
suddenly i am having this error:
cut: input: Input/Output error

Thanks

george_toolan
5th July 2012, 12:43 PM
Same difference. In ubuntu it's called /var/log/syslog or something like that.

The file is readable? Where are the files located in your office?


ls -l input
cat input

or use "cat input > /dev/null" if it's very large. So how about the output file?


ls -l output
cat input > output

Or do you have problems reading the binaries?


ls -l `which cut`
cat `which cut` > /dev/null

papori
16th July 2012, 07:31 AM
Hi again,
the problem is in the external disk that i am using..
i try to change some machine ant i am getting the same error everywhere..
I tried check disk in XP.. but didnt find anything..
Maybe fragmentation??

Any help will be appreciated!

Thanks