View Full Version : Fedora 17 - NFS video streaming problem

30th June 2012, 10:43 AM
I have a server with ubuntu 12.04 and lxde-core install which works as a torrentbox and distributes the files/disks over my other 3 devices in the network.i use NFS for distributing in linux clients and samba for windows. In my dual-boot laptop, Mint 13/Salix 13.37, NFS is working with zero problems. with automounting and the whole deal. In my triple boot desktop, Fedora 17 has issues. everyhting works great, (automounting with fstab etc.) except when it comes watching videos in smplayer 0.8.0. every other minute the video freezes and i have to stop it and restart it (the video, not smplayer) again. i tried running smplayer for command line in order to get some insight but nothing unsual comes up. My Desktop is an AMD x6-core, with a GeForce GTX 560Ti and 295.59 Nvidia drivers.

/etc/exports from ubuntu server:

# /etc/exports: the access control list for filesystems which may be exported
# to NFS clients. See exports(5).
# Example for NFSv2 and NFSv3:
# /srv/homes hostname1(rw,sync,no_subtree_check) hostname2(ro,sync,no_subtree_check)
# Example for NFSv4:
# /srv/nfs4 gss/krb5i(rw,sync,fsid=0,crossmnt,no_subtree_check)
# /srv/nfs4/homes gss/krb5i(rw,sync,no_subtree_check)
/media *(rw,sync,fsid=0,crossmnt,no_subtree_check,no_root _squash,no_wdelay,nohide)

my fedora 17 /etc/fstab:

# /etc/fstab
# Created by anaconda on Tue Jun 26 19:45:57 2012
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
UUID=41374257-c92b-4c13-bbed-eb04a8fc95ad / ext4 defaults 1 1
UUID=9c41ea30-4138-4da9-90bb-cd6d41d4a1ab /media/DATA ext4 defaults 1 2
UUID=9997ad93-4904-415a-916e-6a8a011b2a3c swap swap defaults 0 0 /media/nfs nfs rw,rsize=8192,wsize=8192 0 0

any help would be much appreciated

30th June 2012, 03:46 PM
/media *(rw,sync,fsid=0,crossmnt,no_subtree_check,no_root _squash,no_wdelay,nohide)

Maybe try async. Can't hurt, but it seems unlikely that would cause the problem.

/media *(rw,async,fsid=0,crossmnt,no_subtree_check,no_roo t_squash,no_wdelay,nohide) /media/nfs nfs rw,rsize=8192,wsize=8192 0 0

maybe ... /media/nfs nfs _netdev,rw,noatime,rsize=32768,wsize=32768 0 0

_netdev is just a clue so the mount isn't attempted till the networks are up. No relation to your problem, but a good practice.

noatime means there is not (expensive) nfs meta-data write for every read. It reduces overhead. These 'atime' writes with the 'sync' above *may* be the problem.

8KB is smallish for the maximum read size on a media filesystem. Maybe 64k would be better.

Run 'nuttcp' between the pair an tweak your nte parameters till you get goot throughput. If BOTH interfaaces support jumbo packets then configure it.

---------- Post added at 10:46 AM ---------- Previous post was at 10:44 AM ----------

Another hint - try 'gluster' to replace nfs (you can run both at once). gluster is certainly faster on large file I/O than NFS.

30th June 2012, 06:40 PM
netdev and noatime didn't work..

1st July 2012, 01:45 PM
i noticed that it occurs after i press pause for more tha a few seconds and i come to realize that is something happening because the disks on nfs server goes to sleep or stanby mode. is there any command to exports to prevent that?

3rd July 2012, 05:14 PM
solved it by downgrading to F16

5th July 2012, 06:45 PM
scratch that. issue remains in F16. any ideas???

11th July 2012, 02:24 PM
so no clues at all?? this thing is bugging me over a month now and i can't seem able to locate the problem... and the thing is, it happens in random distro's. F16 - F17 were always affected, linux mint 13 not once, opensuse 12.1 not a problem, ubuntu 11.10 not a problem also but ubuntu 12.04 is affected. so i can't figure is there a server problem or client's ?