View Full Version : FC3 on Compaq Presario R3120US

28th November 2004, 02:05 AM
I have successfully installed FC3 on my laptop, with a little work. I had trouble with the wireless card, and the WXGA screen, which I fixed with some help. The next thing I would like to have is to have the right side of the touchpad work as a scrollbar.

The first thing I did was to resize the ntfs partition windows was on. I loaded up knoppix (gnoppix has never worked for me). I tried to use ntfsresize, and then I'd load to windows, and the hard drive was what smaller, and then I booted up FC3 Installer, and the hard drive was full. It said it was all partitioned with an ntfs partition. So I tried a few more times, and finally decided to use qtparted. That worked, and Fedora Core installed fine.

I then had to install ndiswrapper and get the windows driver to get the wireless card to work. It wouldn't work at first, but I figured out I had to put in the encryption code in network setup. Anyone know how to set up the wireless to store multiple network information?? I get on wireless at work and home which are both encrypted, and I'd like to be able to detect it without reconfiguring it each time.

I figured out how to make my wxga. I added these lines to my xorg.conf under monitor:

DisplaySize 361 225
ModeLine "1280x800" 83.5 1280 1344 1480 1680 800 801 804 828
And under Screen (Subsection "Display"):

Modes "1280x800" "1024x768" "800x600" "640x480"

And that's where I am now. If anyone knows how to make the touchpad scrollbar work, or make multiple encrypted wireless networks work, please let me know.

Helpful Webpages:


28th November 2004, 05:23 AM
One of the web pages you linked specifies the instructions for setting up the ALPS touchpad (including the X configuration):


Did you make those changes? In particular, the X configuration contains the scrolling configuration in the input section:

Section "InputDevice"
Identifier "Alps Touchpad"
Driver "synaptics"
Option "CorePointer"
Option "Device" "/dev/input/event1"
Option "Protocol" "event"
Option "LeftEdge" "60"
Option "RightEdge" "830"
Option "TopEdge" "70"
Option "BottomEdge" "650"
Option "FingerLow" "25"
Option "FingerHigh" "30"
Option "MaxTapTime" "180"
Option "MaxTapMove" "110"
Option "EmulateMidButtonTime" "75"
Option "VertScrollDelta" "50"
Option "HorizScrollDelta" "50"
Option "MinSpeed" "0.2"
Option "MaxSpeed" "0.5"
Option "AccelFactor" "0.01"
Option "EdgeMotionSpeed" "40"
Option "UpDownScrolling" "1"
Option "TouchpadOff" "0"
Did you

28th November 2004, 06:56 AM
I tried that, and X never starts. I also have trouble when I push ctrl-alt-f[1-6]. The screen constantly scrolls or something. It's like a bad connection on a tv. I've tried to edit the xorg.conf file, and I have to boot up the rescue cd so I can re-edit the file.

Does anyone know what the problem is with the ctrl-alt-f[1-6] screens? It also does it whenever I shut down my computer. Is that a problem with LCD's, or is it fixable?

Does anyone know if synaptics (not synaptic the apt frontend) is compiled into the kernel? How would I find out if it is or not?

29th November 2004, 04:09 AM
Noone knows if synaptics is compiled into the kernel, or how I could find out??

How about the alternate screen problem? (ctrl-alt-f1 f2). It looks fine when I start up, but once I start the graphical part, it starts looking like a bad tv connection (text goes up and down sparatically).

30th November 2004, 04:39 AM
Just read another thread about your touchpad problems. Yes it's compiled into the kernel. Here's the thread.


Here's the quick answer. Add i8042.nomux to grub.conf kernel arguments.*

Worked for me .................

7th December 2004, 12:07 AM
let me know if u find anything about multiple networks connecting to them bradlis7. im in the same situation i have bcm 4306 chipset in my Presario r3240us.