PDA

View Full Version : [SOLVED] unrecoverable error / filesystem check failure



supergroove
18th June 2012, 12:48 PM
hi guys,
yesterday while i was watching some youtube videos, my fedora 17 system completely froze.
i had to hard reset it while long pressing the start button, and after reboot dracut warning appear and said something about manual system recovery, and since i have no idea how to do it, i decided to reinstall complete system.
i made fresh partitions and everything seems to be ok, but at the end i received this message


unrecoverable error

ext4 filesystem check failure on /dev/sda3

file system errors left uncorrected

errors like this usually mean there is a problem with the filesystem that will require user interaction to repair.
before restarting installation, reboot to rescue mode or another system that allow you to repair the filesystem interactively.
restart installation after you have corrected the problems on the filesystem.

i tried to format it with live system using gparted and even after that same message poped out.
i searched the forum but couldn't find anything that could help me, so if this was double post sorry for that.
thanks!

george_toolan
18th June 2012, 12:57 PM
Boot from a LiveCD and run


e2fsck /dev/sda3

You should also check your HDD for bad sectors and other problems


yum install smartmontools

smartctl -a /dev/sda

supergroove
18th June 2012, 06:25 PM
thanks man, but that didn't help.
when i do e2fsck /dev/sda3 i got this response:

e2fsck: Attempt to read block from filesystem resulted in short read while trying to open /dev/sda3
Could this be a zero-length partition?

smart says that disk is healthy and there's no bad sectors nor any other problems.

i also tried to install win xp and system stopped in the middle of formating.
i also tried bundle of linux distros and non of them can't be installed.

any other suggestions?
thanks!

dsmithhfx
18th June 2012, 07:26 PM
It sounds like you've given up on attempting to recover the original installation you had running before the crash.

That being the case, you need to determine if the drive can be formatted (the smart diagnostic is at least encouraging). There are a couple things you can try: either boot from a distro cd that has gparted on it, and see if you can reformat the disk (you may need to delete all existing partitions, assuming any are recognized).

If that doesn't work, you can try the disk manufacturer's tools (e.g. Western Digital "Data Lifeguard", Seagate "Diskwizard" etc.) from a bootable CD. Luckily HDDs have come back down in prices since the Thai floods, in case you need to buy a replacement.

I've had a couple of disks fail in recent years, that turned out to be fine when I use them in an external usb enclosure, but they are unreadable on the SATA bus and actually prevented my system from booting anything (including from cd) while hooked up to it.

supergroove
18th June 2012, 07:41 PM
i fixed it!
i followed this guide, http://www.cyberciti.biz/tips/surviving-a-linux-filesystem-failures.html , did everything on it, and im back with fedora 16.
ever since i upgraded (fresh clean installation) to f17, i had some troubles with it.
couple audio apps didn't work (rakarrack and some other audio editing tools), and i had random freezes.
i'm gonna stick with f16 for now.
thanks guys