PDA

View Full Version : [SOLVED] Borked Install--Where did I go wrong?



xtian
15th June 2012, 12:19 AM
I attempted to install F17 on top of the previous Dual Boot/F15 LUKS/LVM encrypted partition. Here were the major steps:


1. Anaconda recognized the LUKS and passphrase allowed installation.
2. Step 7 "What type of Install?" automatically recognized the previous system F15 and offered the best options to preserve /home partition.
+ I selected options,
-- LVM <yes>
-- Encryption, <no>
-- Review and Modify, <yes>
3. I had to recreate the LVM partitions as there was no option to preserve the previous LV partitions or home directory. Everything was backed up so I went for it.
4. Step 9 Boot loader device:
+ Install boot loader on /dev/sda
-- master boot record /dev/sda
-- first sector of boot partition /dev/sda2, <yes>
-- boot loader password, <yes>The result is the system boots to a grub prompt.
If I boot with Livemedia, I can't open LUKS anymore.


# cryptsetup luksOpen /dev/sda3 luks-de25ac97-6a32-4b79-a6a0-296a39376b3b
Device /dev/sda3 is not a valid LUKS device.

I have a backup of the data. That's not an issue. I simply want the simplest way to start over the process without having to remake the dual boot install.

george_toolan
15th June 2012, 09:53 AM
You install without encryption and now you wonder why it isn't encrypted anymore?

Just install Fedora 17 with or without LVM and then copy your home directory from your backup ;-)

xtian
15th June 2012, 04:03 PM
@george_toolan: It is encrypted. In fact the installer recognized the need for a passcode and I entered it successfully.

What I had was instructions to encrypt and install Fedora on an unencrypted drive (http://forums.fedoraforum.org/showthread.php?t=266868). What I needed was instructions to upgrade over an existing system and encrypted drive.

Not finding any posts or examples of this, I assumed it was straight forward. :Y

sea
16th June 2012, 12:37 AM
Easy to tell, whats the output of

lsblk

---------- Post added at 11:37 PM ---------- Previous post was at 10:54 PM ----------

Your issue with the installation is probably like this:
You booted off an(y) installation media, wheter that is dvd or live-image.
The installer asked for the encryption password.
You selected that the installer shiould hanle partitioning..
And the installer did so.
Sadly, the installer defaults are usualy diffrent from what one has it set up previously, thus, you lost the installations with the encryption on it.
Grats to your new system without encryption ;)

george_toolan
16th June 2012, 09:37 AM
How is the installer supposed to keep encrypted partitions when the new operating system doesn't have encryption?


I selected options,
-- LVM <yes>
-- Encryption, <no>

xtian
17th June 2012, 01:10 AM
@george_toeland: i think if you look at the link, it will be easier to understand where I'm coming from. The link has instructions I used in a previous successful install of Fdora 15. The big idea was to set up luks before begining the installation process with Anaconda. It worked for a fresh install, and without selecting Anaconda's encryption option. As I'm sure you know, a LVM at /dev/mapper is supposed to behave same as a physical volume. (^_^) So then, Anaconda thinks its installing on normal partition.

I've since taken the leap and reformated Luks, and, indeed, there was no encryption after the previous attempt. I think I must have missed a step before launching the installer (not properly mounted the LVM partitions?). I'm guessing whereever Luks header is located in relation to the pv and preexisting LVM partitions, this was lost when the installer did its thing.

Now that I'm starting over, I'm back to following the link's steps. What has me puzzled is the last step see message fourteen. It says to close Luks. When I try this, I get the error that the partition is in use/ can't be closed. I can' remember if I went ahead with it open (as I describe here above) or if I restarted and Anaconda sorted out using existing Luks and LVM (which is how I got here oin the first place!) (>_<)

xtian
17th June 2012, 09:01 PM
Update: the luks and lvm problem is sorted. the custom install setting features the necessary options to install and not destroy the partitions i created in lvm. in fact it also has the feature i needed to set the mount point in the installer without formatting an existing file system. However, grub is still borked. there is no grub.conf inthe /grub directory.

now that the two different problems are seperated, i think it would be better to start a new post just for the grub issue. I am marking this solved. in the end it was easier to backup ALL of the system and reformat the partitions so I could start over again with the same instructins.