PDA

View Full Version : Problem with dns in Fedora 17



kidboy
14th June 2012, 01:37 AM
Hi, i install a Fedora 17 in my notebook, but every time i try edit the /etc/resolv.conf i recive a permission denied, how i can disable this protection ?

/etc/resolv.conf
dnssec-trigger 0.10

Please someone can help me ?

BBQdave
14th June 2012, 02:07 AM
Hi, i install a Fedora 17 in my notebook, but every time i try edit the /etc/resolv.conf i recive a permission denied, how i can disable this protection ?

In your favorite CLI, you need to type su and then your root password.

If root is disabled, you need to type sudo and then your password, assuming you are set up as an administrator.

kidboy
14th June 2012, 12:48 PM
But i try to do this as root user

nirik
15th June 2012, 02:32 AM
dnssec-trigger sets /etc/resolv.conf to be immutable.

You can do:

chattr -i /etc/resolv.conf

or (much better)

systemctl stop dnssec-triggerd.service

to disable dnssec-trigger

george_toolan
15th June 2012, 11:55 AM
What exactly are you trying to do?

You should be able to configure your nameservers with NetworkManager.

How did you configure your network?

nirik
15th June 2012, 03:59 PM
dnssec-trigger is a new feature/process that sets you to always use dnssec for dns queries. You can read more about it here:

https://fedoraproject.org/wiki/Features/DNSSEC_on_workstations