PDA

View Full Version : google-earth / FC16/64



lightman47
10th June 2012, 10:18 PM
I've never gotten GoogleEarth to run successfully on this Dell Lattitude D531 with the ATI/AMD video drivers installed. I've been through the myriad of messages (from terminal mode) and installation of all the recommended packages/libraries from many helpful people ... I can't say nothing has worked because I do indeed now get the pretty Initialization screen - but it then aborts with Signal 11 - "this shouldn't have happened. If you report this crash, please include the file 'yada-yada-yada'" - it's Google Earth Free - Google wants no part of it! I've left an email but doubt anyone will read it. Incidentally, the resultant file they want me to include in the report contains little more than version info - no real 'dump', so ithe program doesn't get far enough to even produce a dump.

For the third time, I have just (via yumex) uninstalled "earth", rebooted, re-installed it, then rebooted - same result - pretty splash Initializing, then squat.

I don't NEED the program, of course, but it's so fantastically useful when it works.

Any ideas?? Thank you!!

bob
10th June 2012, 10:42 PM
In the Fedora Set-Up Guides, I'd use AutoPlus's script to install it. Working fine here.

lightman47
10th June 2012, 11:30 PM
POOP! Didn't work. Probably something I did thinking I was FIXING something a while back. Oh, well - the laptop is finally working under F16 - I'll likely tackle this again with the next upgrade it's likely to get - FC18.

I did, however, bookmark the site. What an amazing piece of work and great to have in your back pocket.

Thank you.
jje

bbfuller
11th June 2012, 12:30 AM
Hello lightman47

Well, I've had it working on F16/64 and I've got it working now with F17/64 so it's not mission impossible. That said, I've only got it on machines with nVidia cards.

I usually do:


yum install redhat-lsb.i686 redhat-lsb-graphics.i686 redhat-lsb-printing.i686

and then I do a local install of the google-earth rpm.

That's using the nouveau driver.

I've got a note to do:


yum install xorg-x11-drv-nvidia-libs.i686

if I install the nVidia driver. Is there a similar xorg package for ati?

If you've done all of that I'll see if I can unearth something with an ATI card in it tomorrow and see what happens.

lightman47
11th June 2012, 01:07 AM
Yeh - tried that (it turns out, again) - all installed & up to date.

I'm not horribly 'burnt' about this, if I get it working, I do. If I don't, something for another day/time. Don't go researching - I appreciate your reply & effort already.

Thanks,
jje

And, yes - there is an ATI equivalent (unbeknownst to me upon the above reply), but that is already installed as well.

Jon Heron
27th June 2012, 01:36 PM
Has anyone had any success with this yet?
Gateway laptop, Pentium(R) Dual-Core CPU T4400 @ 2.20GHz × 2 64bit, Graphics: Mobile Intel® GM45 Express Chipset
Running F16, 3.3.8-1.fc16.x86_64, Gnome 3.2.1
I have done all the various steps as seen here and elswhere such as
sudo yum install redhat-lsb.i686 redhat-lsb-graphics.i686 redhat-lsb-printing.i686

and AutoPlus's script, etc. with no joy as of yet....
I get the splash screen to come up but thats it, it then crashes instantly...
Here is the crash log contents:

Major Version 6
Minor Version 0
Build Number 0003
Build Date May 17 2011
Build Time 00:40:40
OS Type 3
OS Major Version 3
OS Minor Version 3
OS Build Version 8
OS Patch Version 0
Crash Signal 11
Crash Time 1340797236
Up Time 0.826387

Stacktrace from glibc:
./libgoogleearth_free.so(+0xab953)[0xf775e953]
./libgoogleearth_free.so(+0xabad3)[0xf775ead3]
[0xf77b2400]

Any guidance would be appreciated! :)
Cheers,
Jon