PDA

View Full Version : FC3 on Vmware



Tobinator
27th November 2004, 02:59 AM
I truely love Fedora Core 3. The only problem I am really having isn't with FC3 itself but rather vmware. Does anyone else have FC3 installed on vmware?? Vmware keeps crashing and gives me some goofy error that I can't view all the way. Has anyone else had this problem??

amiller
27th November 2004, 03:14 AM
Fedora Core is not a supported Guest operating system. As far as I know, VMware doesn't have any current plans to add it either. I've tried installing the OS and getting a crash as well.

HOWEVER, there are some workarounds and I've tried the linux vdso=0 and got the OS to boot.

Here is some info I got from the web:
http://kerneltrap.org/node/view/3097

Installation

1. Boot installation CD.
2. At boot: prompt, type "linux vdso=0". This is very important, otherwise VMware will crash.
3. Install as usual, configure however you like. You'll need to ensure "vdso=0" is set in the "advanced boot configuration" options.
4. If you just reboot at the end of the install, the system will "freak out" a bit trying to start the x server. You can avoid this by editing the boot line (at the Fedora grub splash screen) and appending a 3 to the line.
5. Boot.
6. Unpack the VMware Tools tarball, then apply the patch below (vmware-fc2t3.patch) to vmwares-tools-distrib/bin/vmware-config-tools.pl.
7. Install VMware tools. Use the defaults for all questions, except say NO when asked if you want to compile a vmhgfs module. It doesn't seem compile with the 2.6 kernel headers.
8. Reboot, and enjoy.

sej7278
27th November 2004, 09:16 AM
I didn't really have the issues mentionned above, I did have to apply the patch though. I just did a text install using ISO images.

It was much more painless than FC1, which I almost gave up on.