PDA

View Full Version : Problems with shutdown in FC3



gaurav
27th November 2004, 02:53 AM
I appologize if this has be asked already.

I am having problems with shutting down FC3. It never shutsdown the system instead it just halts all activity after this message in the end.

Powerdown
acpi_power_off called

and hangs...

The system is shutting down fine with win95. And restart is fine, I installed after fresh formating. FC3 itself is working fine.

System Specs, IGb DDR, Athlon Xp 1700, KTM266.

thanks for any help,

gaurav

linedpaper
27th November 2004, 03:07 AM
Ensure that power management is enabled. This happened when I used gentoo and it was because I never compiled acpi into the kernel. If you created a custom kernel ensure that you compiled it in, otherwise check fc3 setup options for anything that isn't default and ensure you didn't take away power management features. I'm sure there are options for it in the gui, but I don't know where exactly they are. Lastly you do have an atx power supply don't you? For example it did power off in fc2 or win95 and not just shutdown?

Tim

gaurav
27th November 2004, 05:01 AM
Thanks. I'll try it out. It did power off in Win9x and previous fedora versions.

Gaurav

smitjel
27th November 2004, 05:43 AM
I'm having this same issue with my fresh install of FC3. Shutdown worked fine in FC1 and FC2. I hope this is just a bug or something but I found some other threads talking about the same thing. It sounds like you have to enter custom kernel boot options though...

http://www.fedoraforum.org/forum/showthread.php?t=26540

http://www.fedoraforum.org/forum/showthread.php?t=26331

shtik
1st December 2004, 10:51 PM
i've had the same problem with core 3. i figured this solution out:

to shut down probably, i must go to bios and then in power management menu. there is an entry "acpi aware os", when setting to "no" (just like you would expect a modern os to need), power down works as well as in older linux versions.

maybe it's worth a try!

shtik

bob
2nd December 2004, 12:27 AM
Imdeemvp has made this 'how-to', which should solve it: http://fedoraforum.org/forum/showthread.php?t=28228&highlight=acpi%3Don

shtik
12th December 2004, 09:34 PM
i would suggest to prefer imdeemvp solution over mine if you are using a dual boot system with windows xp.
point is that on my pc windows won't boot anymore when acpi is disabled in bios while linux seem to have no problem with this, so it's probably better to turn off by hand and being able to use windows;

shtik