View Full Version : Kernel compilation FC2 x86_64

26th November 2004, 10:27 PM

I'm currently running FC2 x86_64 on AMD Athlon 64 with kernel 2.6.9-1.6_FC2

I have to configure, compile and install a custom kernel so that I'm able to load realtime-lsm-0.1.1 kernel module. This kernel module is needed to gain a possibility for a normal user to execute software in realtime mode.

I need that module to run Rosegarden audio software with JACK 0.99 with reasonable latency.

I have tried the following:

1. Installed kernel-sourcecode.noarch 0:2.6.9-1.6_FC2 with yum
2. at /usr/src/linux-2.6.9-1.6_FC2 executed following actions:
- make mrproper
- make menuconfig (xconfig will not compile and gconfig looks weird when loading alternate configuration file)
- Selected needed features, processor type and deselected a lot of unneeded drivers for my system
- Saved the configuration to the alternate location as a backup
- Exited menuconfig saving the changes
- Executed make all install_modules install (as descriped in
kernel recompilation (http://fedoraforum.org/forum/showthread.php?t=27646) )

However the install phase crashes with following message:

if [ -r System.map ]; then /sbin/depmod -ae -F System.map 2.6.9-1.6_FC2custom; fi
Kernel: arch/x86_64/boot/bzImage is ready
sh /usr/src/linux-2.6.9-1.6_FC2/arch/x86_64/boot/install.sh 2.6.9-1.6_FC2custom arch/x86_64/boot/bzImage System.map ""
No module sata_via found for kernel 2.6.9-1.6_FC2custom, aborting.
mkinitrd failed
make[1]: *** [install] Error 1
make: *** [install] Error 2

This happens if I choose the sata_via driver or not. What should I do?

Best Regards:

27th November 2004, 12:52 AM
If it helps here's the link to my kernel configuration:

2.6.9 config (

executing diff on the .config file on /usr/src/linux-2.6.9-1.6_FC2 and my backup results the following:

[root@athlon64 linux-2.6.9-1.6_FC2]# diff ~romu/kernel_config/2.6.9-1.6_FC2_exitium /usr/src/linux-2.6.9-1.6_FC2/.config
< # Fri Nov 26 22:45:09 2004
> # Fri Nov 26 22:45:12 2004

Please help me!!!

Best regards:

27th November 2004, 01:23 PM
Oh. Forgot to mention that the compile phase succeeds. I've also tried separately:

make modules_install
make install

And yes - as a root.

also I have tried make clean and make mrproper. Separately and together.

Obviously I'm just missing some trivial thing, so please throw some comments at me. If there's any more information that you would like to have please send a request and I'll try to dig it up.

27th November 2004, 04:39 PM
You probably want to start with the Fedora kernel configuration, then make the changes you need:

cp /usr/src/linux-x.y.z-a.bcd/configs/kernel-x.y.z.i686.config /usr/src/linux-x.y.z-a.bcd/.config

See this page for a step-by-step:


27th November 2004, 11:11 PM
Thank you for your answer macemoneta. Ireally forgot about the make oldconfig. It has been a while since I have been compiling any Linux kernel.

However. I did everything excactly as descriped in Advanced Fedora Core 2 Notes (http://www.mjmwired.net/resources/mjm-notes-fc2.shtml) except I made my own driver and option selections ofcourse. The install still fails. What am I missing? :(

if [ -r System.map ]; then /sbin/depmod -ae -F System.map 2.6.9exitium; fi
[root@athlon64 linux-2.6.9]# make install
CHK include/linux/version.h
make[1]: `arch/x86_64/kernel/asm-offsets.s' is up to date.
CHK include/linux/compile.h
LD vmlinux
ld: BFD 20040415 assertion fail ../../bfd/linker.c:619
SYSMAP System.map
SYSMAP .tmp_System.map
OBJCOPY arch/x86_64/boot/compressed/vmlinux.bin
GZIP arch/x86_64/boot/compressed/vmlinux.bin.gz
LD arch/x86_64/boot/compressed/piggy.o
LD arch/x86_64/boot/compressed/vmlinux
OBJCOPY arch/x86_64/boot/vmlinux.bin
BUILD arch/x86_64/boot/bzImage
Root device is (9, 0)
Boot sector 512 bytes.
Setup is 4729 bytes.
System is 1750 kB
Kernel: arch/x86_64/boot/bzImage is ready
sh /usr/src/linux-2.6.9/arch/x86_64/boot/install.sh 2.6.9exitium arch/x86_64/boot/bzImage System.map ""
No module sata_via found for kernel 2.6.9exitium, aborting.
mkinitrd failed
make[1]: *** [install] Error 1
make: *** [install] Error 2

27th November 2004, 11:22 PM
Oops :o That exactly was a bit of an overstatement. Here's my exact procedure:

1. I downloaded the 2.6.9 source code from kernel.org mirror
2. copied config-2.6.9-1.6_FC2 to the /usr/src/linux-2.6.9/.config
3. make oldconfig
4. make xconfig (still no go)
5. make menuconfig
6. selected drivers and options
7. make all
8. make modules_install
9. make install

Got the error in previous message

Best Regards:

28th November 2004, 12:20 AM
The only difference from the procedure I use is:

1. make clean after make oldconfig
2. I use make xconfig; the error you're getting tells you what package you need to install to get it to work.
3. Use make instead of make all

I suggest trying to just build the kernel with the Fedora config file (which one are you using?), to verify that the problem is the set of build options you are changing. If the build works with the default config, then one of the "unneeded" drivers that you're deleting from the build process probably has a dependancy that the menuconfig script is not handling. Leave the "unneeded" drivers alone, and just make the changes you HAVE to.

28th November 2004, 02:37 AM
Thanks, macemoneta! Your suggestion solved the problem. I used your procedure for compilation and modified only three options in the menuconfig. I selected the proper CPU (AMD Athlon 64), removed the kernel hacking and changed Default Linux capabilities to the module so that the realtime module can be loaded.

Only time will tell if I have to add/remove some other options but they propably will not affect the install script. I wonder what was the option that should not be removed ... :rolleyes:

Thank you again. I'll start tweaking the realtime module and my sound apps now :)

28th November 2004, 04:13 AM
You're welcome! Glad to hear you're back in business. By the way, for xconfig, I think the only thing I needed to do is:

yum -y install qt-devel

28th November 2004, 11:22 PM
It is actually the qt that xconfig is missing. However I have had installed the qt and qt-devel:

yum search qt
Looking in installed packages for a providing package
Installed package: qt-devel.x86_64 1:3.3.3-0.1 matches with
Installed package: qt.x86_64 1:3.3.3-0.1 matches with
2 results returned

I've read somewhere (can't remember where) that there is actually some problem relating to x86_64 distro and xconfig.