PDA

View Full Version : [Solved] Fedora 17 and Canon LBP 2900



santos
4th June 2012, 12:09 AM
Hello.
I'm goingo to post the new guide for the installation of Canon LBP2900 series on Fedora 17.
I think that this guide may be useful for all Canon LBP series.

1)open root terminal and dont' connect the printer

2) install all dependancies
#yum install libc.so.6 libgcc_s.so.1 libpopt.so.0 libstdc++.so.6 libxml2.so.2 libz.so.1

3) link to http://support-au.canon.com.au/contents/AU/EN/0900772408.html and dowload the driver Canon CAPT 2.40

4)after you have extract the files, from terminal go to
/Linux_CAPT_PrinterDriver_V240_uk_EN/64-bit-Driver/RPM

5)install cndrvcups-common file
#rpm -ivh cndrvcups-common-2.40-1.x86_64.rpm

6)install cndrvcups-capt file

#rpm -ivh cndrvcups-capt-2.40-1.x86_64.rpm

7)switch on the printer and connect it on PC
wait the system to recognize the printer

8) record the printer on the Print Spooler
#/usr/sbin/lpadmin -p LBP2900 -m CNCUPSLBP2900CAPTK.ppd -v ccp:/var/ccpd/fifo0 -E

9)record the printer on daemon setup file
# /usr/sbin/ccpdadmin -p LBP2900 -o /dev/usb/lp0

10)restart ccpd daemon

# /etc/init.d/ccpd restart

11) go to Applications/System Settings/Printers from Fedora menu.
You will find the printer. You can print a test page. Set it as default printer.

12)edit rc.local to start the ccpd daemon at boot
# echo /etc/init.d/ccpd start >> /etc/rc.local

13)set cups service to start at boot
#chkconfig --level 35 cups on

14)set ccpd service to start at boot
#cd /etc/init.d
#sudo gedit ccpd
(replace "gedit" with "kwrite" or other test editor if you use KDE or other DE)

and paste under #!/bin/sh this
# chkconfig: 2345 95 20
# description: Some description
# What your script does (not sure if this is necessary though)
# processname: myscript

including in the copy also #
and save

15)
#chkconfig --level 35 ccpd on

16)you can reboot and good printing ;)


If you have a LBP series different from 2900
you can replace the point 8) and 9) with the following command

# ls /usr/share/cups/model/ | grep CNCUPS

for see the list of drivers for the LBP series printers.
this is the result
CNCUPSLBP1120CAPTJ.ppd
CNCUPSLBP1120CAPTK.ppd
CNCUPSLBP1210CAPTJ.ppd
CNCUPSLBP1210CAPTK.ppd
CNCUPSLBP2900CAPTK.ppd
CNCUPSLBP3000CAPTJ.ppd
CNCUPSLBP3000CAPTK.ppd
CNCUPSLBP3200CAPTJ.ppd
CNCUPSLBP3200CAPTK.ppd
CNCUPSLBP3210CAPTJ.ppd
CNCUPSLBP3210CAPTK.ppd
CNCUPSLBP3300CAPTJ.ppd
CNCUPSLBP3300CAPTK.ppd
CNCUPSLBP3600CAPTJ.ppd
CNCUPSLBP5000CAPTJ.ppd
CNCUPSLBP5000CAPTK.ppd

there are two driver


*K.ppd

*J.ppd

you have to try first with file K.ppd

and to record printer on print spooler
# /usr/sbin/lpadmin -p [printer model] -m [printer driver file name] -v ccp:/var/ccpd/fifo0 -E

and to record printer on daemon setup file
# /usr/sbin/ccpdadmin -p [printer model] -o /dev/usb/lp0

That's all. Ciao ciao from Sicily (Italy).

munishbedi
12th October 2012, 06:49 PM
Hi Iam stuck at step 4
the message comes " No such file or directory"
I have extracted the folder in downloads
what to do next

santos
13th October 2012, 06:54 PM
Sorry, I implied this :)

You have to install the two files on RPM (in the specified order of the guide). You can do it by two ways:

1)like windows. Enter on your extracted folder on Download, and go on the RPM folder.
With double click you can install the files(in order) and goto step 6.

2)by linux terminal
open terminal and with command "cd" you can move on all the hierarchical directories.
http://www.reallylinux.com/docs/direct.html

you can search on the net for "howto use cd command"

when you will be on RPM folder by terminal you can continue on step 5.

munishbedi
16th October 2012, 09:52 AM
The printer 3018b is recognised, ihave installed linux drivers from canon latest version................but there is no output.........even though the dialog window shows the print in que.......but there is no printout

santos
16th October 2012, 11:09 PM
in step 8) what ppd file have you used? CNCUPSLBP3000CAPTK.ppd?

kawaikx15
7th November 2012, 05:33 AM
Very useful post.. installing the printer was a breeze, following your instructions

thanks :dance:

aeonssr
17th July 2013, 11:08 PM
thanks a lot.
after three hours of continuous effort i found that the for some reason test print didnt work but document print worked. i completed the whole process , rebooted only after which i connected the printer. but it just works. hope it keeps working.

Mithesh
20th June 2014, 11:19 AM
i am able to print using test print...... but if i print .txt file its not printing.... please give solution

bob
20th June 2014, 11:30 AM
This is an OLD thread. Please post your question and give specifics of your printer, fedora version and other details in a fresh post.

This thread's CLOSED.