PDA

View Full Version : custom-built kernel and RPM interaction



grifferz
26th November 2004, 04:58 PM
Hi there,

I needed to install a custom kernel, so I did so. However, now yum is telling me that a new kernel RPM is available. Since I have not installed my current kernel from RPM or source RPM, this is irrelevant to me and I would like it to stop telling me.

At first I looked for a way to make yum always ignore the Kernel RPM. However there seems to only be a command line option.

Secondly I decided maybe I could just remove that RPM, but lots of things depend on it.

So now I'mt hinking maybe I could do a "pretend" install of the new kernel RPM so that everything which expects it to be there is happy. But I can't see how to do this with yum.

If that is the best approach, is there an easy way to do it? If not, what would be the best option?

Thanks,
Andy

Jman
27th November 2004, 01:52 AM
There should be an ignore option on the up2date GUI somewhere.

Installing a dummy package somehow is probably not the best idea because that exact kernel version is not there.

Next time you do a custom kernel try making an rpm. I think the make process enables you to do that fairly easily.

grifferz
27th November 2004, 02:12 PM
There should be an ignore option on the up2date GUI somewhere.
I'm actually using yum. I don't want to use a GUI (this is a server). DOes up2date have a text-only interface and if so is it better than yum?


Next time you do a custom kernel try making an rpm. I think the make process enables you to do that fairly easily.
Do you have any pointers to a good document on how to do that, with a custom kernel config?

Thanks for the reply.

Lenard
27th November 2004, 06:50 PM
Just do a 'make rpm' (as root) when done building/installing your custom kernel. Ehen done have a look in /usr/src/redhat/RPMS/i386 and install it with; rpm -i <name_of_the_package>

grifferz
27th November 2004, 11:05 PM
Thanks Lenart but that didn't appear to work. :(


[andy@juice ~]$ cd /usr/src/linux
[andy@juice linux]$ sudo make rpm
/bin/sh /usr/src/linux-2.6.9/scripts/package/mkspec > /usr/src/linux-2.6.9/kernel.spec
/usr/bin/make clean
CLEAN arch/i386/boot/compressed
CLEAN arch/i386/boot
CLEAN arch/i386/kernel
CLEAN drivers/char
CLEAN drivers/md
CLEAN drivers/pci
CLEAN drivers/scsi/aic7xxx
CLEAN drivers/video/logo
CLEAN init
CLEAN kernel
CLEAN lib
CLEAN usr
CLEAN .tmp_versions
CLEAN include/asm-i386/asm_offsets.h vmlinux System.map .tmp_kallsyms1.o .tmp_kallsyms1.S .tmp_kallsyms2.o .tmp_kallsyms2.S .tmp_kallsyms3.o .tmp_kallsyms3.S .tmp_vmlinux1 .tmp_vmlinux2 .tmp_vmlinux3 .tmp_System.map
set -e; cd ..; ln -sf /usr/src/linux-2.6.9 kernel-2.6.9
set -e; cd ..; tar -cz -f kernel-2.6.9.tar.gz kernel-2.6.9/.
set -e; cd ..; rm kernel-2.6.9
set -e; \
/bin/sh /usr/src/linux-2.6.9/scripts/mkversion > /usr/src/linux-2.6.9/.tmp_version
set -e; \
mv -f /usr/src/linux-2.6.9/.tmp_version /usr/src/linux-2.6.9/.version
rpm --target i386 -ta ../kernel-2.6.9.tar.gz
--target: unknown option
make[1]: *** [rpm] Error 1
make: *** [rpm] Error 2

any ideas?

grifferz
29th November 2004, 12:40 PM
Installing the rpm-build RPM and then adding the lines to /etc/popt that it says in "man rpm" seems to have fixed this rpoblem for me.

I'm still interested to know whether people are using yum or up2date (or both??)..

Thanks,
Andy