PDA

View Full Version : [SOLVED] How to install Nvidia driver for Fedora 17 64bit?



Ariya
30th May 2012, 01:20 PM
How to install Nvidia driver for Fedora 17 64 bit version?
I had not been with Fedora for a long time, so don't know how to do this.

Thank you!

Yellowman
30th May 2012, 01:29 PM
How to install Nvidia driver for Fedora 17 64 bit version?
I had not been with Fedora for a long time, so don't know how to do this.

Thank you!

So where's your guide? :blink:

Ariya
30th May 2012, 01:39 PM
I am the one, who is asking how to install the Nvidia driver for the Fedora 17 64 bit.

I understand that this is not the write place, so I'd try to delete this post and go somewhere else in the forum.

Ariya
30th May 2012, 01:47 PM
How to install Nvidia driver for Fedora 17 64 bit version?
I had not been with Fedora for a long time, so don't know how to do this.

Thanks!

Yellowman
30th May 2012, 01:51 PM
Nothing has changed since F16

http://forums.fedoraforum.org/showthread.php?t=204752

Dan
30th May 2012, 02:07 PM
Threads merged. Please don't do that again.

Ariya
30th May 2012, 02:20 PM
Sorry, I didn't see that before. Long time away from the forums.

http://forums.fedoraforum.org/showthread.php?t=204752 is for 64 bit too? I see yum install akmod-nvidia xorg-x11-drv-nvidia-libs.i686

Is it the same for the 64 bit one too?

Or can I go through the Add/Remove software and then remove Noveau driver?

Yellowman
30th May 2012, 02:28 PM
Sorry, I didn't see that before. Long time away from the forums.

http://forums.fedoraforum.org/showthread.php?t=204752 is for 64 bit too? I see yum install akmod-nvidia xorg-x11-drv-nvidia-libs.i686

Is it the same for the 64 bit one too?

Or can I go through the Add/Remove software and then remove Noveau driver?



If you want to run 32bit apps on fedora 64bit you will require the 32bit nvidia libs.

Ariya
30th May 2012, 02:33 PM
Thank you, Yellowman!

Fred Zyphal
30th May 2012, 07:53 PM
Nothing has changed since F16

http://forums.fedoraforum.org/showthread.php?t=204752

Leighs' instructions have worked perfectly, with every release back to about 10, but I'm getting a black screen after reboot with 17 ... trying to figure out why.

Solved, well, at least working: I read another post about this issue, where it was blamed on the contents of the xorg.conf file. That user claimed that the "ServerLayout" seciton of xorg.conf was missing the Identifier "Layout0" line. I checked mine, and sure enough it was missing, so I tried putting it in manually, but no luck. So, being the lazy type, I just took a copy of xorg.conf from my working F16 system, copied it to the failing F17 system, and all is well ... I'm writing this post from my new F17 system.

Sorry I can't tell you exactly what is missing from xorg.conf after following Leighs' installation instructions ... but this worked for me.

Riotvan
31st May 2012, 03:56 PM
Leighs' instructions have worked perfectly, with every release back to about 10, but I'm getting a black screen after reboot with 17 ... trying to figure out why.

Solved, well, at least working: I read another post about this issue, where it was blamed on the contents of the xorg.conf file. That user claimed that the "ServerLayout" seciton of xorg.conf was missing the Identifier "Layout0" line. I checked mine, and sure enough it was missing, so I tried putting it in manually, but no luck. So, being the lazy type, I just took a copy of xorg.conf from my working F16 system, copied it to the failing F17 system, and all is well ... I'm writing this post from my new F17 system.

Sorry I can't tell you exactly what is missing from xorg.conf after following Leighs' installation instructions ... but this worked for me.

I'm having the same problem, could you please post the working xorg.conf?

Yellowman
31st May 2012, 04:01 PM
I'm having the same problem, could you please post the working xorg.conf?

The default works fine here



[root@main-pc leigh]# cat /etc/X11/xorg.conf
# RPM Fusion - nvidia-xorg.conf
#
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection


Try


su
cp /etc/X11/nvidia-xorg.conf /etc/X11/xorg.conf

Riotvan
31st May 2012, 04:09 PM
The default works fine here



[root@main-pc leigh]# cat /etc/X11/xorg.conf
# RPM Fusion - nvidia-xorg.conf
#
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection


Try


su
cp /etc/X11/nvidia-xorg.conf /etc/X11/xorg.conf

I tried that it won't work the system basically freezes right when GDM is loaded, one time i've gotten past it but then nvidia-settings says my driver isn't loaded. I have tried it with a GT520 and 9500GT under fedora 17 and archlinux and the same thing happens. Only way to start the system is boot into init 3 otherwise i can't even ssh into the system, i'm guessing it freezes before it brings up the network.

Yellowman
31st May 2012, 04:11 PM
I tried that it won't work the system basically freezes right when GDM is loaded, one time i've gotten past it but then nvidia-settings says my driver isn't loaded. I have tried it with a GT520 and 9500GT under fedora 17 and archlinux and the same thing happens. Only way to start the system is boot into init 3 otherwise i can't even ssh into the system, i'm guessing it freezes before it brings up the network.

Post the output as an attachment


su
nvidia-bug-report.sh

Riotvan
31st May 2012, 04:19 PM
Ok done, seems to be allot of errors related to DMAR maybe i can try disabling intel_iommu=on but i actually need that for this system. Thanks for your help so far :)
Edit: yup it was intel_iommu=on which causes problems but that kinda sucks since this machine is also a KVM host.

Yellowman
31st May 2012, 04:33 PM
Ok done, seems to be allot of errors related to DMAR maybe i can try disabling intel_iommu=on but i actually need that for this system. Thanks for your help so far :)
Edit: yup it was intel_iommu=on which causes problems but that kinda sucks since this machine is also a KVM host.

Add yourself to this report so nvidia can fix it.

http://www.nvnews.net/vbulletin/showthread.php?t=181745

Ariya
31st May 2012, 06:27 PM
Guys,

Please check this thread; http://forums.fedoraforum.org/showthread.php?t=204752 and do exactly as instructed. :)

Riotvan
31st May 2012, 06:36 PM
Add yourself to this report so nvidia can fix it.

http://www.nvnews.net/vbulletin/showthread.php?t=181745

Yes i guess that's the only thing left to do. Maybe it will work if i install the 3.4 kernel..

Fred Zyphal
1st June 2012, 12:16 AM
I'm having the same problem, could you please post the working xorg.conf?

Sure, but keep in mind it's for my hardware configuration: GeForce GTX 550 Ti, running two monitors in twinview mode. My new F17 is a fresh install on a new SSD, in the same exact machine, so based on Yellowmans' statement "nothing has changed since F16", I felt pretty confident that this would work for me. I'll just post it here, and you can use it to compare:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 285.05.09 (mockbuild@hephaestus.wilsonet.com) Thu Oct 13 16:12:50 EDT 2011

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
FontPath "/usr/share/fonts/default/Type1"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "SAMSUNG"
HorizSync 30.0 - 81.0
VertRefresh 60.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 550 Ti"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "CRT-0: nvidia-auto-select +0+0, CRT-1: nvidia-auto-select +1920+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

---------- Post added at 11:16 PM ---------- Previous post was at 11:10 PM ----------


Guys,

Please check this thread; http://forums.fedoraforum.org/showthread.php?t=204752 and do exactly as instructed. :)

Ariya ... I think the "guys" in this thread have been there, and done that, many times in the past ... it just didn't work this time. My issue was the xorg.conf file, but it sounds like some of the others are slightly different.

Dan
2nd June 2012, 05:15 AM
Good grief! That'll be quite enough of that, guys. I've purged a few posts, and that's the end of it ... kapish?

<..:dis:..>