PDA

View Full Version : system won't start init after FC2->FC3



horst
26th November 2004, 01:43 AM
i upgraded my system from FC2 to FC3 and now i've got the problem that it won't boot anymore. well, it does boot but it hangs before the init-process is started, just after the "Freeing unused kernel memory" message without any error message.

i have no idea what the problem could be but i already recognized that there was no /dev/console so it might be a problem with the devfs->udev upgrade. i already created the /dev/console with mknod (before that i also got the message that no initial console could be opened. that message is gone now). but this doesn't change anything, still no error and no init.

i already tried to pass init=/bin/sh during the boot to see if it's a problem with the init-process but i don't get a console, it still hangs after the freeing memory message.

the rescue-mode from the cd is not very helpful either because it tells me that there are no linux partitions on my system even though i can mount and access the partitions from the rescue console.

so i can read and write to the damaged installation but i have no idea what i have to do to fix this. any help is appreciated.