PDA

View Full Version : yum command is not working



coolarif
19th May 2012, 07:15 PM
hi friends ! I am newbie to fedora 16 . I used ubuntu before this jump. i have installed fedora just now . i need software packages which i used in ubuntu. to install vlc , i hit following command on terminal :

$ yum install vlc

Loaded plugins: langpacks, presto, refresh-packagekit
You need to be root to perform this command.

a) how do i become root in fedora ? b) I have given a password during installation.But the password is not prompted after hitting that command. I think my user account do not have or missing some administrator level previllages.



Please help me to clear it . Proceed to install other packages :

1. sun or oracle java jdk

2. libre office package

3. vlc

4. gnome tweak tool

5. blue tooth manager

6. netbeans or an editor equivalent to notepad++

7. mysql

8. apache

9. php

10. mysql jdbc driver for linux

11. phpmyadmin


i have to install all of them . These are my needs. Kindly ! guide me to install them all please .......

Thanks a lot in advance !

bob
19th May 2012, 07:19 PM
To become root, simply sign in as 'su' or 'su -'. So, your command would be "su -" (then give your password), "yum install ...."

coolarif
19th May 2012, 07:44 PM
Thanks a lot ! BOB

" su - " did not work

" su " works fine . Thanks a lot.

mschwendt
19th May 2012, 10:10 PM
Thanks a lot ! BOB

" su - " did not work

Sure it does! You must have made a mistake. The following three commands are the same:



su --login
su -l
su -
Consult "man su" if you don't believe this. ;)

marko
19th May 2012, 11:05 PM
Or if you want to be very literal:


su --login root

coolarif
20th May 2012, 10:45 AM
Oh thats intresting ..... I wish to explore more about fedora... After my last post.... i tried to install vlc as my first attempt ...

Now i learnt to become a root user... Thanks .... It is because of you all friends.....

Now again a big monster stands in my way.....

I gave those commands as you guided...

13MB of data was downloaded but the installation was failed ....

glennzo
20th May 2012, 11:12 AM
You should post some relavant information about the failure, like some of the error output that was seen. That would allow members to help by giving them some insight into exactly what went wrong.


[glenn@server ~>$ sudo yum install vlc
Password:
Loaded plugins: fastestmirror, local
Loading mirror speeds from cached hostfile
* fedora: mirror.seas.harvard.edu
* rpmfusion-free: mirror.us.leaseweb.net
* rpmfusion-free-updates: mirror.us.leaseweb.net
* rpmfusion-nonfree: mirror.us.leaseweb.net
* rpmfusion-nonfree-updates: mirror.us.leaseweb.net
* updates: mirror.seas.harvard.edu
_local | 2.9 kB 00:00 ...
Resolving Dependencies
--> Running transaction check
---> Package vlc.i686 0:1.1.13-3.fc16 will be installed
--> Processing Dependency: vlc-core(x86-32) = 1.1.13-3.fc16 for package: vlc-1.1.13-3.fc16.i686
--> Processing Dependency: libtar.so.1 for package: vlc-1.1.13-3.fc16.i686
--> Processing Dependency: dejavu-sans-mono-fonts for package: vlc-1.1.13-3.fc16.i686
--> Processing Dependency: xdg-utils for package: vlc-1.1.13-3.fc16.i686
--> Processing Dependency: libminizip.so.1 for package: vlc-1.1.13-3.fc16.i686
--> Processing Dependency: dejavu-sans-fonts for package: vlc-1.1.13-3.fc16.i686
--> Processing Dependency: dejavu-serif-fonts for package: vlc-1.1.13-3.fc16.i686
--> Processing Dependency: libxcb-keysyms.so.1 for package: vlc-1.1.13-3.fc16.i686
--> Processing Dependency: kde-filesystem for package: vlc-1.1.13-3.fc16.i686
--> Processing Dependency: libvlccore.so.4 for package: vlc-1.1.13-3.fc16.i686
--> Processing Dependency: libprojectM.so.2.0.1 for package: vlc-1.1.13-3.fc16.i686
--> Running transaction check
---> Package dejavu-sans-fonts.noarch 0:2.33-1.fc16 will be installed
--> Processing Dependency: dejavu-fonts-common = 2.33-1.fc16 for package: dejavu-sans-fonts-2.33-1.fc16.noarch
---> Package dejavu-sans-mono-fonts.noarch 0:2.33-1.fc16 will be installed
---> Package dejavu-serif-fonts.noarch 0:2.33-1.fc16 will be installed
---> Package kde-filesystem.i686 0:4-38.fc15 will be installed
---> Package libprojectM.i686 0:2.0.1-12.fc16 will be installed
--> Processing Dependency: libGLEW.so.1.6 for package: libprojectM-2.0.1-12.fc16.i686
--> Processing Dependency: libftgl.so.2 for package: libprojectM-2.0.1-12.fc16.i686
---> Package libtar.i686 0:1.2.11-20.fc15 will be installed
---> Package minizip.i686 0:1.2.5-6.fc16 will be installed
---> Package vlc-core.i686 0:1.1.13-3.fc16 will be installed
--> Processing Dependency: libcddb.so.2 for package: vlc-core-1.1.13-3.fc16.i686
--> Processing Dependency: libdvbpsi.so.7 for package: vlc-core-1.1.13-3.fc16.i686
--> Processing Dependency: libsmbclient.so.0 for package: vlc-core-1.1.13-3.fc16.i686
--> Processing Dependency: libtag.so.1 for package: vlc-core-1.1.13-3.fc16.i686
--> Processing Dependency: libtiger.so.5 for package: vlc-core-1.1.13-3.fc16.i686
--> Processing Dependency: libzvbi.so.0 for package: vlc-core-1.1.13-3.fc16.i686
--> Processing Dependency: libvcdinfo.so.0 for package: vlc-core-1.1.13-3.fc16.i686
--> Processing Dependency: libSDL_image-1.2.so.0 for package: vlc-core-1.1.13-3.fc16.i686
--> Processing Dependency: libthreadutil.so.6 for package: vlc-core-1.1.13-3.fc16.i686
--> Processing Dependency: libvcdinfo.so.0(VCDINFO_0) for package: vlc-core-1.1.13-3.fc16.i686
--> Processing Dependency: libmatroska.so.4 for package: vlc-core-1.1.13-3.fc16.i686
--> Processing Dependency: libebml.so.3 for package: vlc-core-1.1.13-3.fc16.i686
--> Processing Dependency: libmtp.so.9 for package: vlc-core-1.1.13-3.fc16.i686
--> Processing Dependency: libixml.so.2 for package: vlc-core-1.1.13-3.fc16.i686
--> Processing Dependency: libupnp.so.6 for package: vlc-core-1.1.13-3.fc16.i686
--> Processing Dependency: libshout.so.3 for package: vlc-core-1.1.13-3.fc16.i686
---> Package xcb-util.i686 0:0.3.6-2.fc15 will be installed
---> Package xdg-utils.noarch 0:1.1.0-0.10.20111207.fc16 will be installed
--> Running transaction check
---> Package SDL_image.i686 0:1.2.10-2.fc15 will be installed
---> Package dejavu-fonts-common.noarch 0:2.33-1.fc16 will be installed
--> Processing Dependency: fontpackages-filesystem for package: dejavu-fonts-common-2.33-1.fc16.noarch
---> Package ftgl.i686 0:2.1.3-0.4.rc5.fc15 will be installed
---> Package libGLEW.i686 0:1.6.0-1.fc16 will be installed
---> Package libcddb.i686 0:1.3.2-7.fc16 will be installed
---> Package libdvbpsi.i686 0:0.2.2-1.fc16 will be installed
---> Package libebml.i686 0:1.2.1-1.fc16 will be installed
---> Package libmatroska.i686 0:1.2.0-1.fc16 will be installed
---> Package libmtp.i686 0:1.1.3-2.fc16 will be installed
---> Package libshout.i686 0:2.2.2-6.fc15 will be installed
---> Package libsmbclient.i686 1:3.6.5-85.fc16 will be installed
---> Package libtiger.i686 0:0.3.4-2.fc16 will be installed
---> Package libupnp.i686 0:1.6.13-2.fc16 will be installed
---> Package taglib.i686 0:1.7.2-1.fc16 will be installed
---> Package vcdimager-libs.i686 0:0.7.24-1.fc15 will be installed
--> Processing Dependency: vcdimager = 0.7.24-1.fc15 for package: vcdimager-libs-0.7.24-1.fc15.i686
---> Package zvbi.i686 0:0.2.33-9.fc16 will be installed
--> Running transaction check
---> Package fontpackages-filesystem.noarch 0:1.44-2.fc15 will be installed
---> Package vcdimager.i686 0:0.7.24-1.fc15 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ================================================== =========================
Package Arch Version Repository Size
================================================== ================================================== =========================
Installing:
vlc i686 1.1.13-3.fc16 rpmfusion-free-updates 1.9 M
Installing for dependencies:
SDL_image i686 1.2.10-2.fc15 fedora 44 k
dejavu-fonts-common noarch 2.33-1.fc16 fedora 63 k
dejavu-sans-fonts noarch 2.33-1.fc16 fedora 1.4 M
dejavu-sans-mono-fonts noarch 2.33-1.fc16 fedora 432 k
dejavu-serif-fonts noarch 2.33-1.fc16 fedora 776 k
fontpackages-filesystem noarch 1.44-2.fc15 fedora 9.0 k
ftgl i686 2.1.3-0.4.rc5.fc15 fedora 101 k
kde-filesystem i686 4-38.fc15 fedora 47 k
libGLEW i686 1.6.0-1.fc16 fedora 91 k
libcddb i686 1.3.2-7.fc16 updates 68 k
libdvbpsi i686 0.2.2-1.fc16 rpmfusion-free 47 k
libebml i686 1.2.1-1.fc16 fedora 67 k
libmatroska i686 1.2.0-1.fc16 fedora 139 k
libmtp i686 1.1.3-2.fc16 updates 106 k
libprojectM i686 2.0.1-12.fc16 fedora 465 k
libshout i686 2.2.2-6.fc15 fedora 42 k
libsmbclient i686 1:3.6.5-85.fc16 updates 1.5 M
libtar i686 1.2.11-20.fc15 fedora 30 k
libtiger i686 0.3.4-2.fc16 fedora 34 k
libupnp i686 1.6.13-2.fc16 fedora 96 k
minizip i686 1.2.5-6.fc16 updates 32 k
taglib i686 1.7.2-1.fc16 updates 217 k
vcdimager i686 0.7.24-1.fc15 rpmfusion-free 294 k
vcdimager-libs i686 0.7.24-1.fc15 rpmfusion-free 93 k
vlc-core i686 1.1.13-3.fc16 rpmfusion-free-updates 6.8 M
xcb-util i686 0.3.6-2.fc15 fedora 39 k
xdg-utils noarch 1.1.0-0.10.20111207.fc16 updates 68 k
zvbi i686 0.2.33-9.fc16 fedora 392 k

Transaction Summary
================================================== ================================================== =========================
Install 1 Package (+28 Dependent packages)

Total download size: 15 M
Installed size: 48 M
Is this ok [y/N]:

There are a lot of dependencies there and a lot of opportunity for things to go wrong.

coolarif
20th May 2012, 08:48 PM
Again i tried to install vlc by using same command . It is installed successfully.....

Thanks bob , marko , mschwendt , glennzo ,.... for spending your valuable time for me .....

marko
21st May 2012, 03:26 AM
Sometimes when a yum transaction doesn't complete (suppose the internet connection is broken in the middle of the download), you can also try running the command afterwards:

yum-complete-transaction

This frequently will fix the problem

mschwendt
21st May 2012, 09:52 AM
Sometimes when a yum transaction doesn't complete (suppose the internet connection is broken in the middle of the download), you can also try running the command afterwards:

yum-complete-transaction

The downloading of packages is a step before the transaction. You can interrupt it without problems, and simply re-running the previous Yum command will complete the partially downloaded packages. No transaction related special command is needed.

Only if the actual RPM related transaction gets interrupted, you may need the yum-complete-transaction command, or else it sometimes can be either much more difficult or time-consuming to fix the installation with other commands.