PDA

View Full Version : pptp client and Fedora Core 3



jmakis
25th November 2004, 10:54 PM
I want to install pptp client to Fedora, because at the moment only way I can connect internet is Windows XP..

I have installed Fedora Core 3, with "workstation"-option selected during install.
I have also done everything like here (http://pptpclient.sourceforge.net/howto-fedora-core-3.phtml)

Everything goes OK (I think) until I try to install the configuration program GTK+ interface (step 4):

# rpm --install php-gtk-pcntl-1.0.1-2.i386.rpm

warning: php-gtk-pcntl-1.0.1-2.i386.rpm: V3 DSA signature: NOKEY, key ID b56a8bac
error: Failed dependencies:
libglade is needed by php-gtk-pcntl-1.0.1-2.i386
libglade.so.0 is needed by php-gtk-pcntl-1.0.1-2.i386
libxml is needed by php-gtk-pcntl-1.0.1-2.i386
libxml.so.1 is needed by php-gtk-pcntl-1.0.1-2.i386

---
That means I don't have installed all needed packages? How and where I can find the right packages?

I really hope someone can help, because this really isn't first time I try to get this work... :(

ilja
25th November 2004, 10:57 PM
That means that this package is already installed. Try


rpm -q php-gtk-pcntl

There is a difference between -i that you use and -U that should be used. If you use -i it tries to install a paralel version, if you use -U it tries to update the existing version, and if not installed it installs the new package. So just go on with the next step.

jmakis
25th November 2004, 11:26 PM
I tried rpm -q php-gtk-pcntl and it just tells that "package php-gtk-pcntl-1.0.1-2.i386.rpm is not installed"

And next step (5) is :

# rpm --install pptpconfig-20040722-4.noarch.rpm

the result:

warning: pptpconfig-20040722-4.noarch.rpm: V3 DSA signature: NOKEY, key ID b56a8bac
error: Failed dependencies:
php-gtk-pcntl is needed by pptpconfig-20040722-4.noarch

ilja
25th November 2004, 11:32 PM
ok, you are right.
Do


rpm -Uhv http://download.fedora.redhat.com/pub/fedora/linux/core/3/i386/os//Fedora/RPMS/libglade-0.17-15.i386.rpm

and


rpm -Uhv http://download.fedora.redhat.com/pub/fedora/linux/core/3/i386/os//Fedora/RPMS/libxml-1.8.17-11.i386.rpm


Or the best would be to install them with yum http://fedorafaq.org/#installsoftware

jmakis
26th November 2004, 02:50 PM
Thank you very much! It works now finally, thanks to you!

rhoekstra
26th November 2004, 04:41 PM
Strong advice to start using yum, as it resolves the dependancies for you.

It also keeps your machine up to date using 'yum update'