PDA

View Full Version : boot off a custom kernel, stops on "probing for new hardware"



jeremym
30th May 2004, 10:46 AM
I have tried the 2.6.6 kernel and tried just compiling the fd core kernel.

Each time it just sits there forever (let sit for almost 3 hours) on probing for new hardware.

If i boot the default smp kernel everything boots fine.

My hardware is as follows:

Abit IC7-Max3
Intel Pentium 4 2.8c
2x512mb hyperx ram
Ati radeon 9800xt

Anyone have any ideas why this is happening?

SuperNu
30th May 2004, 04:07 PM
Kudzu could be looking for a module that you didn't compile into your kernel, so this could cause your problems. For me, I would just turn off kudzu and see if you can boot your custom kernel. To turn off kudzu, open a shell, su to root, type /sbin/chkconfig kudzu off. This will turn kudzu off on all levels.

--SN

jeremym
31st May 2004, 03:17 PM
ty for the suggestion but i figured it out.

I was compiling in firewire support and this was causing problems.

I dont know why it causes problems since i do have firewire ports. 2 on board and one on my audigy.

SuperNu
31st May 2004, 05:35 PM
From what I have read, firewire is broken in the 2.6.6 kernel. That could be why you are having problems with firewire.

--SN