View Full Version : Virtualization issue

28th April 2012, 12:07 PM
Hey guys , i have the following problem when trying to use pci-passthrough/vt-d with hardware that i have confirmed works with another distro and custom kernel(debian testing kernel 3.3.3). Being an arch guy i wanted something a bit less bleeding edge and have the intel_iommu/vt-d stuff built in, i have added intel_iommu=on to /etc/default/grub and then updated grub.

However when starting a vm using virt-manager and kvm i get the following error:

Error starting domain: internal error Process exited while reading console log output: char device redirected to /dev/pts/1
No IOMMU found. Unable to assign device "hostdev0"
qemu-kvm: -device pci-assign,host=00:19.0,id=hostdev0,configfd=22,bus=pc i.0,addr=0x3: Device 'pci-assign' could not be initialized

some more info:

grep -e DMAR -e IOMMU
[ 0.000000] ACPI: DMAR 00000000dafdf000 000E8 (v01 INTEL SNB 00000001 INTL 00000001)
[ 0.000000] Intel-IOMMU: enabled
[ 0.062384] DMAR: Host address width 36
[ 0.062391] DMAR: DRHD base: 0x000000fed90000 flags: 0x0
[ 0.062406] IOMMU 0: reg_base_addr fed90000 ver 1:0 cap c0000020e60262 ecap f0101a
[ 0.062412] DMAR: DRHD base: 0x000000fed91000 flags: 0x1
[ 0.062424] IOMMU 1: reg_base_addr fed91000 ver 1:0 cap c9008020660262 ecap f0105a
[ 0.062428] DMAR: RMRR base: 0x000000dacd5000 end: 0x000000dacebfff
[ 0.062433] DMAR: RMRR base: 0x000000db800000 end: 0x000000df9fffff
[ 0.062518] IOAPIC id 2 under DRHD base 0xfed91000 IOMMU 1

virsh nodedev-dettach pci_0000_00_19_0
Device pci_0000_00_19_0 detached

Maybe i'm missing something but i did the exact same thing under debian and it worked fine, the hardware is a Thinkpad X220 and i'm trying to passthrough the onboard NIC.

29th April 2012, 03:46 PM
Had some time today to look into it and solved it, i was under the assumption that the kernel had everything enabled by default going by the wiki but that was not the case.

Built a kernel form source with the fedora settings while adding the following to config-local during the build:


Not sure if this is fc17 specific but im glad it works now.