PDA

View Full Version : mysql down, wont' fix.



Secret Agent
25th November 2004, 04:44 AM
MySQL, Exim and PostgreSQL shown down (red) in WHM after doing a simple Apache update and cPanel update (Release).

Restarted MySQL

DBI connect('mysql:localhost','root',...) failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) at /scripts/restartsrv_mysql line 75 mysql has failed, please contact the sysadmin (result was "Warning, no valid mysql.sock file found.mysql has failed").


I ran /scripts/upcp --force
./updatenow
./fixeverything

Still doesn't fix it.

I also switched to v3, and then back to v4. That fixed it momentarily until I restarted MySQL and then back to the error again.

Please give me a hand.

Specs:
Fedora Core 1
cPanel 9.9.8 R119

Coven@nt
28th November 2004, 11:22 AM
if you are using a graphical enviroment go check to your system / protection
go to your firewall settings or seLInUX (or something like that) and disable your http protection.
hope that helped but it looks like a source problem (re-download maybe?)