View Full Version : [SOLVED] Kernel stack is corrupted.

27th April 2012, 09:12 PM
I reinstalled fedora yesterday and everything worked great as per usual.

I then went ahead and did a full update and now my new kernel is getting this error and preventing fedora from booting:

Kernel panic - not syncing: stack-protector:
Kernel stack is corrupted in: c0bd4600
Kernel 3.3.2-8.fc17.i686

Before I reinstalled I was running that exact kernel, I believe it's been out since 4-21-12 and this issue hasn't seem to came up for anybody else before.

So I'm wondering what I did wrong to create this issue. I didn't do anything besides install fedora and perform the update. I went ahead and played Skyrim while it was updating, so nothing other than the update was being performed while I was waiting.

---------- Post added at 03:12 PM ---------- Previous post was at 01:42 PM ----------

I'm really sorry for wasting space in this forum with this topic.
I should have tried to reinstall the kernel before posting, I really don't know what made me jump the gun and post a topic in the forum.

Anyway, reinstalled the kernel fixed the issue. Once again, sorry for the waste of time/space.

28th April 2012, 04:08 AM
Hey... DELL XPS l702 here with same error..
I ran a yum update a few minutes ago..the terminal ended up with "cannot mount file-system and then after a reboot the exact same message you mention...

dell xps exclusive bug? :-) I can still boot with kernel 3.3.2-1.fc17.x86_64 . but If i try 3.3.2-8 I will get the error.

Just to add.. I upgraded from F16

DEll XPS 17 L702 here.

28th April 2012, 06:32 AM
I'm getting the same thing with all the F17 kernels, for 3.3.1-5 the number was c0bfb961 and for 3.3.0-1 the number was c0bfb971. Mine is a Asus barebones desktop.

28th April 2012, 07:10 AM
I was getting kernel panics with 3.3.2-8.

TC2 has 3.3.4-1 and is working for me. In fact, 3.3.4-1 and its nouveau is working with EFI booting Macbook Pro 4,1 for the first time ever.

28th April 2012, 07:13 AM
Like I said, if you reinstall the kernel you should be fine.
I don't know if yum reinstall kernel will work because that was not the method I tried.

I ran:
yum remove kernel kernel-headers

And it removed the kernel, kernel-headers, and a few other dependent packages.

yum install kernel kernel-headers

It reinstalled those same dependent packages. I then rebooted and it worked just fine.

Also, the issue is not specific towards your computer, as I am using a dell dimension 3000.

1st May 2012, 08:38 PM
I'm afraid to update the system with the new kernel(had a day ago a bad experience with arch due a bug on linux-3.3.3-4 or so) the system hanged and freezing no keyboard no mouse...


no problem with the update!