View Full Version : Can't boot livecd

21st April 2012, 10:00 AM
after release F17 beta, i downloaded 'Fedora-17-Beta-x86_64-Live-Desktop', but i can't boot it.
During booting it just stop during starting some services and freeze.
I tried also Basic graphics mode and it neither work.
I guess it is related with some missing modulse, cause i had the same problem with F16 after release kernel 3.3.04 -> http://forums.fedoraforum.org/showpost.php?p=1569290&postcount=24

I downloaded Ubuntu12.04 Beta and opensuse Livecd and it everything was fine.
I'm using Dell Studio 1749.

21st April 2012, 08:19 PM
i can't boot it.
During booting it just stop during starting some services and freeze.
I tried also Basic graphics mode and it neither work.

Not enough information provided.

Change the boot line to remove 'quiet rghb' and find out where it's stopping. Or hit ESC after you get the gray splash screen so you can see the boot messages scrolling by and what's happening when it stops.

21st April 2012, 08:57 PM
In 'normal' boot it stops on 'Starting LSB: daemon for libvirt virtualization API', but in 'Basic mode', it stops on other services, so it seems it doesn't matter on which services it stops.

Booting just stops and give totally no information, so if you know some tips how to get more debug information i would be grateful. I also tried 'systemd.log_level=debug' command but it also give no more info.

21st April 2012, 09:11 PM
Speculation, but sounds like maybe the drive isn't getting data off the media reliably. What is the media? How was it produced? Have you tried making install media more than one way?

21st April 2012, 09:35 PM
Yeap, I used usb and cd and it doesn't work, but it works on other pc. Maybe it happened because of loading wrong modules or sth like that?

21st April 2012, 09:49 PM
sth doesn't compute. Try whole words. There are many modules baked into the kernel to no ill effect and many others than load dynamically when needed and this happens very early on in the boot process. Technically you're booting fine, the problem is with some subsequent service that's not loading correctly and that's what needs to get figured out.

---------- Post added at 02:49 PM ---------- Previous post was at 02:43 PM ----------

Also, you haven't told us anything about your hardware: make model memory configuration. Have you successfully booted single user? If not, what about passing systemd.unit=emergency.target at boot?

If single user boots fine, then what about passing systemd.unit=multi-user.target at boot? If that doesn't work, I think you're going to need to find out what's in multi-user.target and load service individually until you can find out what's stalling the startup process.

If multi-user boot works, then you'll need to find out what's in graphical.target and load services individually until you find out what's stalling the startup process. Could be X. So you're right, it could be video driver related. But until you've tried other ways to start up, it's speculative to just start troubleshooting video problems.

21st April 2012, 10:13 PM
ok, sory for misunderstaning, now I have 2 problems and I wanna solve any of them:

1) can't boot F17 live cd beta - it impossible to change runing level during startup

2) can't boot F16 - it impossible to bootin graphics mode, but in emergency it works, I describe my problem in this post: http://forums.fedoraforum.org/showpost.php?p=1569290&postcount=24 but i didn't get any working solution, so i decided to download F17 beta and reinstall system

I will try, as you describe, boot F16 in emergency mode and start serives individually. Thanks for usefull tips!!

21st April 2012, 10:28 PM
LiveCD uses syslinux so it's slightly different to edit the kernel parameters than with GRUB. Basically at the default chosen "Start Fedora" option you hit tab and you'll get the boot options. I do it all the time, so it's definitely not impossible.