PDA

View Full Version : display manager not loading in fedora 16



linuxlearner28
4th March 2012, 01:38 AM
hello all ... i have been using fedora 16 for some time now and never had a problem until 2day............ i did an update 2day a couple hours ago ( truth be told i dont really know what all was in it as i was working on some other stuff along side) and later i went to reboot my computer... while it was booting up and that splash image was loading all of a sudden it just stopped so i hit the escape key to look at the info ( i am not an expert trouble shooter but i thought i would take a look) i noticed that it sed the display manager failed to start and that i should see the 'systemctl status prefdm.service' for details i really dont know what happened or what i should do ..i am sure it had something to do with that update and i have been looking online for answers for a while and have found some things SIMILAR to my situation but not exactly like it, plus all those posts are 5-6 years old if anyone could help me with this problem and the steps i would need to take i would appreciate it, i would really not prefer to have to reinstall the entire OS over a problem like this as i am sure this problem can be fixed

thank you

matt

---------- Post added at 06:38 PM ---------- Previous post was at 04:58 PM ----------

ok i have been working on this for a while now and so here is MORE of what i have done to find out whats wrong


i booted up into recovery mode and mounted the image at the /mnt/sysimage

then issued the command "'systemctl status prefdm.service" and this is what i got

"prefdm.service- Display Manager
Loaded: (/lib/systemd/system/prefdm.service; static)
Active: inactive (dead)
CGroup: name=systemd:/system/prefdm.service"

does anyone have any clue from this input what the solution would be? i really dont wanna just give up and reinstall the whole OS i am really hoping that this can be fixed without using that as the answer. i have been working on this for a while and could really use some help if anyone has any idea

thanks

matt

jlucasps
4th March 2012, 08:00 PM
identical problem, the same happened to me.
some help?

jpollard
4th March 2012, 08:56 PM
BTW, showing the status that way will always show it as "inactive(dead)" because it isn't running - what is on the recovery disk is running...

You can only query services from the active system. To do that, you switch to a console vertual terminal, log in as root. Then do the command.

You could look at any messages logged, such as the current /var/log/Xorg.0.log, or /var/log/messages.

linuxlearner28
5th March 2012, 01:56 AM
@: jlucasps

i followed the instructions from another person i found online who had a similar problem..... he said when the system is booting choose the recovery mode kernel from the list instead of the normal one you would normally boot into... then when u r at the command prompt press ctrl +d and BOOM runlevel 5 boots up just fine but this is just a workaround and i really dont know exactly how this problem started .. i can only assume it had something to do with the update i did yesterday... but i wasnt paying attention to what was in the update so i really dont know how to fix this permanently



@jpollard: i will try looking at the files you recommended but it didnt matter whether i was booting rescue mode from the actual DVD or selecting one of the recovery mode kernels installed on the actual HD while it was booting.. the same command yielded the same results the only way to get runlevel 5 to boot up was by booting into a rescue mode kernel and then pressing ctr +d like i stated above. its a minor inconvenience but at least i was able to get it up and running so i could quick copy some stuff to my portable HD lol

jlucasps
6th March 2012, 01:49 AM
@ linuxlearner28

I have tried a lot of options, none of them worked for me.
Did u try restore a previous installation point using yum? I tried, but didnt work too.
Try restore before your update.

see ya

minasmir
8th March 2012, 10:51 PM
Same thing happened to me this morning. I booted in single user mode and looked at /var/log/messages it says that "pref.service holdoff time over, scheduling restart"
Then, "Unit prefdm.service entered failed state"
And "prefdm.service start request repeated too quickly, refusing to start"

---------- Post added at 04:51 PM ---------- Previous post was at 02:20 PM ----------

I ran yum history and xorg was updated recently. That could explain the issue.

also tried run level 5 after booting into som as stated above. didnt work for me