PDA

View Full Version : Is Eclipse difficult to install in Fedora 16



marko
20th February 2012, 08:10 PM
I have a possible upcoming job where I'll have to use Eclipse, so I'm trying to install eclipse and get it working with Java EE. I tried the


yum groupinstall "Fedora Eclipse"and then running eclipse to download and install the plugins. The problem I have is that the plugin installations always bomb with failed/missing dependencies. As a I back out the plugins that had problems it just gets a bit farther and hits another bad/missing dependency. Is Eclipse in Fedora 16 really buggy?

I'm using Oracle Java SE 1.6.0_30 64bit on Fedora 16 64bit

I'm more familiar with netbeans 7.1, it seems to have much less plugin trouble

Back to Eclipse 3.7.1 (indigo), you go into installing plugins via: "Help" -> "Install new software"
if I use the spring plugin repo at: springide.org/updatesite to try to install spring plugins for Eclipse, I get (even with "--All Available Sites--" in the "work with"):


Cannot complete the install because one or more required items could not be found.
Software being installed: Spring IDE Core (required) 2.6.0.201103160035-RELEASE (org.springframework.ide.eclipse.feature.feature.g roup 2.6.0.201103160035-RELEASE)
Missing requirement: Spring IDE Core (required) 2.6.0.201103160035-RELEASE (org.springframework.ide.eclipse.feature.feature.g roup 2.6.0.201103160035-RELEASE) requires 'org.eclipse.wst.xml_ui.feature.feature.group 0.0.0' but it could not be found

So I guess this might be a problem at springide.org/updatesite

Pitfall
20th February 2012, 08:30 PM
Is Eclipse buggy? No, at least not in my experience. I have it running on my netbook for android programming. I had to install the eclipse repo and an android repo for my packages. Installed it, and it works fine.

marko
20th February 2012, 08:45 PM
Did you succeed at installing Spring support or are you not using it?

By buggy I mean for how I need to use it, I need full EE and Spring support but the plugin system
seems clunky and hard to use due to dependencies not being found. Assuming I was not
exposing a needed repository I used the 'all available' repos mode and it still can't find
the spring dependencies it needs.

I suspect the spring repo is at fault but since so many users must be using Spring with Eclipse (it's a big IDE in Java EE right?)
I don't understand how they got their Spring plugins installed.

sanhozay
20th February 2012, 08:45 PM
The variety of plugins in Eclipse can sometimes make setting it up awkward. If you are doing Spring stuff, I can recommend downloading SpringSource Tool Suite from springsource.org and installing it under your home directory somewhere, e.g. ~/Software. It comes with Spring and associated plugins preinstalled so there's no fiddling to do. It's basically Indigo but configured for Spring development.

If you want an icon in Gnome Shell, just make a .desktop file and put it into ~/.local/share/applications:

~/.local/share/applications/springsource.desktop

[Desktop Entry]
Name=Spring Source Tool Suite
Comment=Spring Source Tool Suite
Exec=/home/<your_username_here>/Software/springsource/sts-2.8.1.RELEASE/STS
Icon=/home/<your_username_here>/Software/springsource/sts-2.8.1.RELEASE/icon.xpm
Terminal=false
Type=Application
StartupNotify=true
Categories=Development

marko
21st February 2012, 02:51 AM
@sanhozay (http://forums.fedoraforum.org/member.php?u=192039)

Thanks, that worked much better, I groupremove'd "Fedora Eclipse" and I installed the archive/installer file

springsource-tool-suite-2.8.1.RELEASE-e3.7.1-linux-gtk-x86_64-installer.sh

then ran the Help-> Install New Software to get the Java EE stuff and the rest, there
was one minor dependency failure for one Grails package but I didn't need grails so I uncheck it and and all the rest installed.