PDA

View Full Version : Gnome3 GDM user list not showing - would like to enable libfprint auth



Kaya Saman
11th February 2012, 11:33 PM
Hi,

I am not sure if this is because my user doesn't show or if it's something else but am having difficulties in finding a solution.


Am running Fedora 16 x64 and up till just now was running it in runlevel mode 3 (init3) and using startx to start the X server.


Now, for whatever reason HW video acceleration was not enabled so in order to be able to make the most of my machine I had to make the switch.


Upon changing the /etc/systemd/system/default.target to runlevel5 I discovered that I don't have any users listed within the GDM greater so I have to manually enter the name. This is not an issue!


I do however want to enable the fingerprint reader for login authentication but it seems that without any users System Settings don't allow for ANY fingers to be 'scanned'.

My other boot is Fedora 15 x64 and was able to create scanned finger print images no problem. There doesn't seem to be a PAM module with that though so I was unable to login using the finger reader.


My concern right now is not F15 but F16 so to not get distracted and stay on track I need to be able to get the finger print reader working somehow.


I did discover this: http://miltus31.blogspot.com/2011/03/enable-root-login-in-gdm3.html

which lead me to the /etc/pam.d directory, of which the contents are below (libfprint is installed on the system):



chfn gdm-welcome poweroff sshd
chsh gnome-screensaver ppp su
config-util halt reboot sudo
crond login remote sudo-i
fingerprint-auth other run_init su-l
fingerprint-auth-ac passwd runuser system-auth
gdm password-auth runuser-l system-auth-ac
gdm-autologin password-auth-ac smartcard-auth v4l-conf
gdm-fingerprint polkit-1 smartcard-auth-ac xserver
gdm-password postlogin smtp
gdm-smartcard postlogin-ac smtp.sendmail





Can anyone help?


Thanks!

hmaarrfk
4th April 2012, 08:39 AM
What is the make and model of your laptop?

You should be ale to go to the User Account settings, select your users and then find an entry with fingerprint login, then follow the on screen instructions for it.

(Press super/menu/windows key then type "user accounts")

Kaya Saman
8th April 2012, 01:49 PM
Thanks for the response and sorry for the delay in getting back!

I managed to solve this.


I have a Lenovo X220 notebook; but my issue wasn't the system but infact the install. I did a minimal install which meant that Gnome3 wasn't really setup properly as unlike installing a full system some scripts or other internal components don't get run so bits go missing.


I can't remember exactly what I did but hopefully this will be a rundown:


fingerprint-auth file:



#%PAM-1.0
# This file is auto-generated.
# User changes will be destroyed the next time authconfig is run.
auth required pam_env.so
auth sufficient pam_fprintd.so
auth required pam_deny.so

account required pam_unix.so
account sufficient pam_localuser.so
account sufficient pam_succeed_if.so uid < 1000 quiet
account required pam_permit.so

password required pam_deny.so

session optional pam_keyinit.so revoke
session required pam_limits.so
-session optional pam_systemd.so
session [success=1 default=ignore] pam_succeed_if.so service in crond quiet use_uid
session required pam_unix.so



fingerprint-auth-ac:




#%PAM-1.0
# This file is auto-generated.
# User changes will be destroyed the next time authconfig is run.
auth required pam_env.so
auth sufficient pam_fprintd.so
auth required pam_deny.so

account required pam_unix.so
account sufficient pam_localuser.so
account sufficient pam_succeed_if.so uid < 1000 quiet
account required pam_permit.so

password required pam_deny.so

session optional pam_keyinit.so revoke
session required pam_limits.so
-session optional pam_systemd.so
session [success=1 default=ignore] pam_succeed_if.so service in crond quiet use_uid
session required pam_unix.so



system-auth:




#%PAM-1.0
# This file is auto-generated.
# User changes will be destroyed the next time authconfig is run.
auth required pam_env.so
auth sufficient pam_fprintd.so
auth sufficient pam_unix.so nullok try_first_pass
auth requisite pam_succeed_if.so uid >= 1000 quiet
auth required pam_deny.so

account required pam_unix.so
account sufficient pam_localuser.so
account sufficient pam_succeed_if.so uid < 1000 quiet
account required pam_permit.so

password requisite pam_cracklib.so try_first_pass retry=3 type=
password sufficient pam_unix.so sha512 shadow nullok try_first_pass use_authtok
password required pam_deny.so

session optional pam_keyinit.so revoke
session required pam_limits.so
-session optional pam_systemd.so
session [success=1 default=ignore] pam_succeed_if.so service in crond quiet use_uid
session required pam_unix.so



Hopefully this will be sufficient for anyone else with the same issues or as an illustration (to the best of my recolection) as to what was added/changed within the setup.