View Full Version : Wireless problems

9th February 2012, 03:51 AM
After using Ubuntu (and others distros but mainly Ubuntu) for a few years, I decided to give Fedora a try. I downloaded Fedora and installed it from USB (lots of trouble to get this working starting on with a Windows machine in Portuguese!)


I was a little bit disappointed when after a fresh install Fedora couldn't connect to wireless networks. lspci told me I was using a "Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)" and after a while (with a wired network) I got it working by following some tutorials found online.

What I did (broadcom-wl should be used in my case):
yum -y install yum-fastestmirror
yum -y update
yum localinstall --nogpgcheck .../rpmfusion-free-release-stable.noarch.rpm .../rpmfusion-nonfree-release-stable.noarch.rpm
yum install kmod-wl

After a reboot everything was working fine :D until...it was not.

The internet was slow and soon I got disconnected, from this time on I could not connect to WiFi, once I tried to access my wireless network my password was asked again and again with no sucess connecting.

I found it even spookier that sometimes it would connect,just to fail miserably soon after ...

After what I heard about fedora, I really wasn't expecting this kind of problems, thought it would be ready to work out of the box. *sigh*

Additional info:
$ uname -r
Using an EEE PC 1215B

After a few reboots I noticed I can connect to my wireless network everytime I booted but once it failed, I could no longer connect again.

Thanks in advance guys :)

9th February 2012, 12:45 PM
what's the output of 'lspci -k | grep -A5 [Nn]et' ?

usually it's best to install akmod-wl rather than kmod-wl, since installing akmod-wl ensures the kernel module is rebuilt whenever a kernel update is booted. Then you need to blacklist some modules by adding these lines to the end of /etc/modprobe.d/blacklist.conf

blacklist b43-pci-bridge
blacklist bcm43xx
blacklist ssb
blacklist b43
blacklist b44

and reboot

(if you do this and your hard wired ethernet uses b44 then do 'modprobe b44' before using hardwired ethernet)

9th February 2012, 02:26 PM
Thanks for such a quick reply!

I think it is working now, at least the netbook hasn't disconnected yet from the wireless network :dance:

The output of 'lspci -k | grep -A5 [Nn]et' was

01:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
Subsystem: AzureWave Device 2047
Kernel driver in use: wl
Kernel modules: bcma, wl
02:00.0 Ethernet controller: Atheros Communications AR8152 v2.0 Fast Ethernet (rev c1)
Subsystem: ASUSTeK Computer Inc. Device 8468
Kernel driver in use: atl1c
Kernel modules: atl1c
07:00.0 USB Controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
Subsystem: ASUSTeK Computer Inc. Device 8488

after blacklisting all the modules and installing akmod-wl it was the same but everything seems to be working now.

Thank you Gödel!

10th February 2012, 06:49 PM
Ok, after a while I noticed wireless isn't working at 100% yet...

I am getting some weird problems, not all wireless networks are being listed and sometimes I have problems reconnecting...

Also, my boot time was horrible so I did:

cat /var/log/boot.log
Failed to start LSB: Builds and install new kmods from akmod packages [FAILED]

So akmods is giving me some problems at boot.

I tried to run
su -c "akmods --kernels 3.2.3-2.fc16.x86_64"
Checking kmods exist for 3.2.3-2.fc16.x86_64 [ OK ]

and it just seems to run fine!

I did some "investigating" of my own but I can't seem to go any further, here is some information that may be helpful...

(grep -i akmod /var/log/messages gives me a lot of messages so I thought it would be better not to get it all in here)

systemctl status akmods.service
akmods.service - LSB: Builds and install new kmods from akmod packages
Loaded: loaded (/etc/rc.d/init.d/akmods)
Active: failed since Fri, 10 Feb 2012 17:12:20 +0000; 33min ago
Process: 989 ExecStart=/etc/rc.d/init.d/akmods start (code=exited, status=0/SUCCESS)
CGroup: name=systemd:/system/akmods.service

systemctl list-units --failed
akmods.service loaded failed failed LSB: Builds and install new kmods from a

LOAD = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB = The low-level unit activation state, values depend on unit type.
JOB = Pending job for the unit.

1 units listed. Pass --all to see inactive units, too.

10th February 2012, 09:50 PM
yes, there are problems with the akmods service at boot eg see http://forums.fedoraforum.org/showthread.php?t=266780

if the delayed boot is too much of a bother then disable the akmods service:
sudo systemctl disable akmods.service

and just run it manually after a boot when required (ie when a new kernel update has been installed):
sudo akmods --kernels $(uname -r)

(check service is enabled/disabled at boot with 'chkconfig --list')

as regards your reconnection problems, can you duplicate the errors in windows or ubuntu? it's hard to know what the problem is, could be a microwave nearby for example. If the problem is known to be absent in windows then try ndiswrapper (link to windows drivers and instructions in first post here (http://forums.fedoraforum.org/showthread.php?t=230669))

---------- Post added at 08:50 PM ---------- Previous post was at 08:26 PM ----------

make sure the boot delay is not caused by iscsi service - press escape during boot to see boot log and see which service it gets delayed on - if iscsi is a problem and you have no iscsi targets (networked storage devices) then do

sudo systemctl disable iscsi.service
sudo systemctl disable iscsid.service

11th February 2012, 01:30 AM
The problem isn't only with reconnection as some wireless networks aren't even listed ( and are with Windows ).

About the boot delay I think iscsi and iscsid were one of the problems but I ended up disabling some other unnecessary services too.

Sorry for having so many subjects on one post only...

I will try NDISwrapper as soon as I get the chance,

Thank you

11th February 2012, 02:00 PM
for fixing boot issues with services take a look at AdamW's hints in this thread http://forums.fedoraforum.org/showthread.php?t=273317

(particularly, run 'systemd-analyze blame' just after boot)

If you're gonna try ndiswrapper you'll have to remove wl, you can do it temporarily as described in the thread I linked to above, and if you like ndiswrapper and want to stick with it, you'll have remove the wl rpms from the system.

I have my doubts that the windows driver will show any improvement, but if it does it would be nice to have confirmation

23rd March 2012, 09:49 PM
Hi CattyFox.

Did you get your Broadcom 4313 wireless working? I've never got mine working on my HP DM1-4108au.

It works in WindoWzz 7 but not in Fedora.

How did you go about getting it working?