PDA

View Full Version : glibc_2.0 error



ChrisR(sql dba)
21st November 2004, 07:28 PM
Howdy kids! Im a brand new Linux user so please be gentle. Im trying to install Oracle 9i on Fedora 3 and get the error:

[oracle@localhost root]$ Initializing Java Virtual Machine from /tmp/OraInstall2004-11-21_10-07-08AM/jre/bin/java. Please wait...
Error occurred during initialization of VM
Unable to load native library: /tmp/OraInstall2004-11-21_10-07-08AM/jre/lib/i386/libjava.so: symbol __libc_wait, version GLIBC_2.0 not defined in file libc.so.6 with link time reference

Any ideas on how to fix this would be greatly appreciated.

Thanks in advance!
ChrisR

sideways
21st November 2004, 07:48 PM
this sometimes fixes that error

export LD_ASSUME_KERNEL=2.4.1

ChrisR(sql dba)
21st November 2004, 08:06 PM
No such luck. Any other ideas would be appreciated.

ChrisR(sql dba)
21st November 2004, 08:10 PM
I take it back. It did work, I just needed to run it under the account Im trying to install Oracle as. Thanks!

ChrisR(sql dba)
21st November 2004, 10:07 PM
BTW, what was it that the command did? Change the whole kernel version? How can I tell the version Im currently on?

sideways
21st November 2004, 11:44 PM
No it just affects the dynamic linker for the duration of the session (so once you close the terminal window or log off the environment is reset), basically it enables backwards compatibility temporarily
here's some technical detail
http://people.redhat.com/drepper/assumekernel.html

No permanent changes are made.

you can see your current kernel version by typing 'uname -r' (or 'uname -a').

ChrisR(sql dba)
23rd November 2004, 06:18 AM
This sucks! I had assumed this fix worked because after I ran it I got another error message about my hard drive running out of room. I had assumed the propesed fix worked and as a result the install was beginning and I just needed to make space. Well now Ive got space o' plenty and the message is back. Does anyone have any other ideas? Sorry to be the total newbie, it just made so much sense at the time.

sideways
23rd November 2004, 10:48 AM
are you typing 'export LD_ASSUME_KERNEL=2.4.1' directly before running the installer? (by typing '<cdrom path>/runinstaller' or similar)

(ie you're not switching user 'su' between 'oracle' and 'root' in between for instance?)

The other option is to copy the entire install cd to a temp directory and manually replace the java binary used during installation - a similar fix is required for installing maple v8 for instance - see this thread for the procedure used there

http://www.fedoraforum.org/forum/showthread.php?t=25113&highlight=mathematica


(And then contact Oracle and ask why they don't allow a text-only based install)